Repository 32bit  Forum
Repository 64bit  Wiki

SLAMD64--->compiz-fusion--->sexy-python......le maledette

Forum dedicato ai Porting ufficiali e non di Slackware, vedi Slack/390, ARMedslack, Slamd64, Slackintosh, Ocsid, Sloox, Zenwalk, How-Tux, Slax etc etc

Moderatore: Staff

Regole del forum
1) Specificare nome e versione del porting.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda dottor3 » ven nov 14, 2008 19:04

Salve esimi
ecco pronto per voi n altro bel mistero della fede linux :pottytrain5:

Dunque, un bel giorno mi viene in mente di aggiungere questi tanto blasonati effetti 3d al mio desktop (kde)..... :sign3:
........allora prendo un how-to...........installo cio' che serve...........ma nel mezzo del cammin di installazione delle librerie incontro lei....la sexy-python :study:
Nome simpatico.......sicuramente avranno uno slackbuild!!! NO :fuori:
Bhe fa nulla.........compilo a mano IO!!! :cvdf:
1° errore <poi risolto> : il config nn trova la sexylib (installata minuti prima) nonostante un bel LDCONFIG.....usando CFLAGS e LIBS ci sono riuscito

2°errore : al MAKE mi da errori di compilazione (che io attribuisco alla mancanza di qualche libreria) http://rafb.net/p/qksePO27.html --->l'errore nella sua completezza


Se sapete dirmi qualcosa io sono a vostra disposizione!!!!

Vi saluto e vi ringrazio!! :mille:
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda albatrosla » ven nov 14, 2008 19:21

Package per la 12.0. Penso ci sia anche lo slackbuild.
http://www.slacky.eu/index.php?option=c ... &Itemid=56
Altre libs "sexy" che non so se c'entrano, ma sono comunque su slacky:
http://www.slacky.eu/index.php?option=c ... &Itemid=65
albatrosla
Packager
Packager
 
Messaggi: 1294
Iscritto il: sab mar 27, 2004 0:00
Località: Bressa - Friuli / Torino
Slackware: current
Desktop: fluxbox.git

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda idefix » ven nov 14, 2008 19:34

idefix
Linux 2.0
Linux 2.0
 
Messaggi: 136
Iscritto il: gio giu 19, 2008 0:48
Nome Cognome: stefano
Slackware: slack64-14
Kernel: 3.5.4
Desktop: tde 3.5.14

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda dottor3 » sab nov 15, 2008 18:08

Lo slackbuild non esiste........... [-(

Mentre le repository che ci sono su slacky sono compilate per altr piattaforme non la mia x86_64.......

Mon dieu ........ come faro' 8-[
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda conraid » sab nov 15, 2008 18:12

dottor3 ha scritto:Lo slackbuild non esiste........... [-(


http://repository.slacky.eu/slackware-1 ... 0.1.9/src/
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda dottor3 » lun nov 17, 2008 21:15

Lo Slackbuil mi restituisce il problema n°1 (scritto nel mio primo messaggio)

Eppure ho modificato lo slackbuild in modo che passi a "configure" gli stessi parametri delle CFLAS LIBS usati per risolverlo a mano!!!!!! #-o :banghead:

Sono sicuro sia una libreria posseduta dal maligno :evil1:
Vi pasto la mia modifica :
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
GLIBM_CFLAGS=/usr/include GLIBMM_LIBS=/usr/lib \ ----> che dite????
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
|| exit 1
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda conraid » mar nov 18, 2008 15:47

Per rendere uno SlackBuild compatibile con Slamd64 non basta aggiungere quelle due cose.
Oltre a cambiare ARCH a x86_64, mi sembra che devi cambiare il percorso delle lib che di default sono in lib64.
Ma qui ci vorrebbe qualcuno che usa quella distribuzione e che ha dimestichezza con gli SlackBuild della stessa
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda dottor3 » gio nov 20, 2008 18:28

Lo SLACKBUID l'ho modificato come deve essere modificato.............
gli ho detto dove cercare (cflags e libs) ma nulla.............

ditemi se erro nelle mie convizioni!!!!!!
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda gohanz » mer nov 26, 2008 19:41

Prova ad inserire nello SlackBuild

LDFLAGS="-L/usr/lib64" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda dottor3 » dom dic 07, 2008 22:10

Scusate per il delay :-D

Neanche con queste modifiche funziona......... :-k

eppure i parametri glieli passo bene........
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: SLAMD64--->compiz-fusion--->sexy-python......le maledette

Messaggioda sunreal » sab dic 13, 2008 13:07

Scusate, senza che apro un altro post pongo qui la mia domanda. La guida per installare compiz-fusion è ancora questa?
http://www.slacky.eu/wikislack/index.ph ... _Slackware
perchè nella guida si fa riferimento a dei pacchetti ancora per slack 12.0. Quello che volevo sapere è in primis, se esiste una versione più aggiornata dei vari pacchetti <<fusion>> ed inoltre se bisonga installare le versioni più aggiornate degli altri, tanto per capirci questi: libsexy, libwnck, pycairo, pygobject, pygtk, sexy-python, fuse, pyrex. Grazie
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.


Torna a Porting Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti