Repository 32bit  Forum
Repository 64bit  Wiki

pulseaudio 2.24.1

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

pulseaudio 2.24.1

Messaggioda buteo » ven nov 07, 2008 14:26

Il problema del blocco di pulseaudio non è risolto in Gslacky 2.24.1?
Ho appena verificato un blocco durante la riproduzione audio, risolto con uno stop e un restart di rc.pulseaudio.
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda gohanz » ven nov 07, 2008 19:58

Confermo anche io il blocco di Pulseaudio dopo circa 40 minuti si suono continuato. Pensavo che fosse solo un mio problema, ma ora ci sei anche tu che mi confermi la stessa cosa. Slucky, un'utente di Slacky, però alcuni giorni fa ha testato per almeno due ore Pulseaudio senza problemi. Ho un sospetto sul kernel, visto che entrambi usiamo la stessa versione. Bisognerebbe provare su un kernel recente per avere la conferma o meno del problema.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: pulseaudio 2.24.1

Messaggioda slucky » sab nov 08, 2008 19:17

....alcuni giorni fa ha testato per almeno due ore Pulseaudio senza problemi.


e te lo riconfermo, non solo una volta, bensì tutte le volte che uso rhythmnbox funziona senza problemi o blocchi :) ....non so se dipenda dal kernel perchè è il 2.6.24.7 o da qualche altro pacchetto aggiornato dalla 12.1, visto e lo ripeto che io gslacky l'ho installato sulla current non sulla 12.1, forse la differenza è tutta qui.

ciao e saluti a tutti
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 12.0 / 14.1
Kernel: default
Desktop: gslacky / xfce

Re: pulseaudio 2.24.1

Messaggioda buteo » ven nov 21, 2008 10:47

Salve a tutti, ci risiamo.
Nei giorni scorsi non avevo più ascoltato musica al PC, oggi ci ho riprovato e pulseaudio è di nuovo caduto, senza più rialzarsi.
La configurazione del sistema non è cambiata di molto (ho solo aggiornato gli ultimi pacchetti da slackware-security: firefox/seamonkey, net-snmp, gnutls, cups).
Durante la riproduzione, audacious si blocca. Se si tenta di farlo ripartire da console, si vedono i messaggi:
Codice: Seleziona tutto
E: shm.c: shm_open() failed: Permission denied
ALSA lib pcm_pulse.c:629:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

evidentemente perché il demone pulseaudio non è più in esecuzione.
Ma, se faccio partire manualmente pulseaudio lasciando l'output sulla console:
Codice: Seleziona tutto
/usr/bin/pulseaudio -vv  --system --daemonize --high-priority
D: main.c: Started as real root: yes, suid root: no
I: main.c: setrlimit(RLIMIT_RTTIME, (1000000, 1000000)) failed: Invalid argument
I: core-util.c: Successfully gained nice level -11.
D: main.c: Can realtime: yes, can high-priority: yes
W: main.c: Running in system mode, but --disallow-exit not set!
W: main.c: Running in system mode, but --disallow-module-loading not set!
N: main.c: Running in system mode, forcibly disabling SHM mode!
N: main.c: Running in system mode, forcibly disabling exit idle time!
E: main.c: Daemon startup failed.

Ho letto qualche ticket dal sito di pulseaudio e sembra che i blocchi si verifichino spesso se l'hardware audio è -come nel mio caso- l'AC97 del southbridge Intel ICH5, anche con kernel più recenti del mio. Ma stavolta pulseaudio non si avvia e dovrò aspettare il prossimo reboot...
Idee? Esperienze analoghe?
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda gohanz » ven nov 21, 2008 11:56

Sei sicuro di non avere il demone pulseaudio in esecuzione? Prova prima a killarlo
Codice: Seleziona tutto
killall pulseaudio
. Poi lo puoi riavviare anche non in system-wide. Quindi semplicemente lanciando dalla shell
Codice: Seleziona tutto
pulseaudio -v
.
Sto anche valutando la possibilità di abbandonare la modalità system-wide per le prossime uscite di GSlacky. Quindi usare un setup di Pulseaudio senza init script. Lo sto provando e sembra funzionare bene.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: pulseaudio 2.24.1

Messaggioda buteo » ven nov 21, 2008 14:38

Sei sicuro di non avere il demone pulseaudio in esecuzione?

Non è in esecuzione, l'ho anche regolarmente killato ogni volta in modo superfluo...
Il comportamento è strano. Ecco l'output dopo il boot, avendo modificato lo script di avvio per avere loglevel debug su file:
Codice: Seleziona tutto
D: main.c: Started as real root: yes, suid root: no
I: main.c: setrlimit(RLIMIT_RTTIME, (1000000, 1000000)) failed: Invalid argument
I: core-util.c: Successfully gained nice level -11.
D: main.c: Can realtime: yes, can high-priority: yes
W: main.c: Running in system mode, but --disallow-exit not set!
W: main.c: Running in system mode, but --disallow-module-loading not set!
N: main.c: Running in system mode, forcibly disabling SHM mode!
N: main.c: Running in system mode, forcibly disabling exit idle time!
E: main.c: Daemon startup failed.

dopo aver lanciato audacious:
Codice: Seleziona tutto
ps ax |grep pulse
 2813 ?        Ssl    0:09 /usr/bin/pulseaudio --log-target=syslog -Lmodule-esound-compat-spawnfd fd=19
 2824 ?        S      0:00 /usr/libexec/pulse/gconf-helper
 3298 pts/0    S+     0:00 tail -f /var/log/pulse.log
 3416 pts/1    S+     0:00 grep pulse

prova:
Codice: Seleziona tutto
root@# /etc/rc.d/rc.pulseaudio stop
Stopping PulseAudio Daemon: /usr/bin/pulseaudio.
root@medusa:~# ps ax |grep pulse
 3298 pts/0    S+     0:00 tail -f /var/log/pulse.log
 3428 pts/1    S+     0:00 grep pulse

Codice: Seleziona tutto
root@medusa:~# /etc/rc.d/rc.pulseaudio start

stesso messaggio nel log ma:
Codice: Seleziona tutto
 audacious
amidi-plug(amidi-plug.c:amidiplug_init:97): init, read configuration
amidi-plug(i_backend.c:i_backend_load:107): loading backend '/usr/lib/audacious/Input/amidi-plug/ap-alsa.so'
amidi-plug(i_backend.c:i_backend_load:145): backend /usr/lib/audacious/Input/amidi-plug/ap-alsa.so (name 'alsa') successfully loaded
E: shm.c: shm_open() failed: Permission denied
ALSA lib pulse.c:266:(pulse_connect) PulseAudio: Unable to connect: Connection refused


** (audacious:3576): WARNING **: alsa_setup(): Failed to open pcm device (default): Connessione rifiutata
ERROR: libflacng.so: plugin.c:339 (flac_play_loop): Could not open output plugin!
Segmentation fault

audacious va in crash appena clicco su play, il demone pulseaudio non va in esecuzione
Se ora invece lo lancio da console come utente standard pulseaudio parte (non so ancora quanto dura...) e audacious pure
Alla prossima
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda buteo » lun nov 24, 2008 16:13

Rieccomi.
Dopo un minimo di indagini posso confermare che lo script rc.pulseaudio di Gslacky è -almeno nel mio sistema- del tutto inutile. Il suo compito si esaurisce nell'errore all'avvio che ho riportato nel post precedente, e il file di log che ho creato ad hoc rimane "congelato" in quello stato. In effetti il demone pulseaudio che ho in esecuzione è quello lanciato da gnome-session con lo script
Codice: Seleziona tutto
/usr/bin/start-pulseaudio-x11

con errori indirizzati di default allo stdout e regolare crash dopo circa 35 minuti di riproduzione continua
Codice: Seleziona tutto
pulseaudio[2829]: cpulimit.c: Recevied request to terminate due to CPU overload


A questo punto rilancio lo script:
Codice: Seleziona tutto
/usr/bin/start-pulseaudio-x11
I: caps.c: Dropping root priviliges.
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied

e poi modifico /etc/pulse/daemon.conf
Codice: Seleziona tutto
high-priority = no
log-target = syslog
log-level = error


Ho anche modificato /etc/esd.conf ponendo
Codice: Seleziona tutto
auto_spawn=0

per evitare i numerosi errori del tipo
Codice: Seleziona tutto
pulseaudio[3962]: pid.c: Daemon already running.
pulseaudio[3962]: main.c: pa_pid_file_create() failed.

Niente da fare: gli errori si riducono ma il crash si ripresenta
Ho anche provato (in daemon.conf)
Codice: Seleziona tutto
no-cpu-limit = yes

così pulseaudio resiste più di 40 minuti, ma dopo la fatidica soglia i disturbi audio e i "salti" nella riproduzione divengono insopportabili, e pulseaudio si mantiene stabilmente sopra il 90% si utilizzo CPU.
Allora ho nuovamente modificato daemon.conf, dopo aver abilitato in policykit le apposite opzioni per il mio utente:
Codice: Seleziona tutto
realtime-scheduling = yes
high-priority = yes
no-cpu-limit = no

Nuovo crash dopo i soliti 40min, ma CPU sotto il 2%
Infine ho posto (da http://pulseaudio.org/wiki/FAQ#HowdoesPulseAudiocomparewithESOUNDaRtsNAS)
Codice: Seleziona tutto
default-fragment-size-msec = 50

i disturbi audio si sono ridotti, ma non annullati, ma a 37 minuti esatti:
Codice: Seleziona tutto
pulseaudio[3329]: cpulimit.c: Recevied request to terminate due to CPU overload.

Nulla di fatto, dunque.
Resta da capire la relazione pulseaudio-versione kernel-hardware audio.
Io ho pulse 0.9.13 - kernel 2.6.24.5 custom - Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02).
Magari gli atri utenti ci fanno sapere la loro cfg e se hanno problemi.
Ciao a tutti
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda gohanz » lun nov 24, 2008 19:15

Dopo un po di ricerche ho trovato che il problema è generale e non riguarda solo PulseAudio di GSlacky. Dai un'occhiata
Devo trovare queste patch di Fedora, inoltre suggeriscono anche l'upgrade degli alsa-driver. Alsa-lib e Alsa-plugins sono già aggiornati dall'installazione di GSlacky.
Io comunque un sospetto l'ho anche per quanto riquarda il kernel.

http://ubuntuforums.org/showthread.php?t=978393


https://tango.0pointer.de/pipermail/pul ... 02632.html


Forse la patch è questa :-k . http://cvs.fedoraproject.org/viewvc//de ... time.patch
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: pulseaudio 2.24.1

Messaggioda buteo » mar nov 25, 2008 11:44

Gohanz:
Dopo un po di ricerche ho trovato che il problema è generale e non riguarda solo PulseAudio di GSlacky

Di questo ero convinto anch'io, il forum di Gslacky era solo il mio luogo preferito per discuterne...
Ho visto anch'io più di qualche discussione su fedora e il bugtrack di Pulseaudio.
Guardate anche http://pulseaudio.org/ticket/396 e soprattutto https://bugzilla.redhat.com/show_bug.cgi?id=462200
Sembra che i crash siano causati da una combinazione di versione di hw (intel e creative soprattutto... ma forse sono anche i più diffusi...) kernel (alsa driver), alsa-plugins.
La nota più ottimistica è:
From Lennart Poettering 2008-10-23 23:00:03 EDT -------
OK, so I am one step further.
First, this issue has multiple different causes. I nailed at least one of them,
which was specific to 32bit machines which is the reason I was unable to
reproduce this on my 64bit machine. The fix is trivial:
http://git.0pointer.de/?p=pulseaudio.gi ... 1d6f0ce2c2
Brrr, I lost too much time on this one.
This patch is included in 0.9.13-4. So, everyone, please give it a try. It's in
koji right now.
This should hopefully fix the issue for the majority of people. Still there
seem to be some driver issues left. I know for sure that the Creative ALSA
drivers are borked. 0.9.13-4 includes some diagnostic code that will verify the
results of a couple of ALSA calls and log a warning if they are inconsistent or
have values that are suspicously high.
So, even if you have a Creative card, give this a try and watch your logs. It
will hopefully give us a hint what is wrong so we can inform the ALSA people
about this.

Il link al repository pulseaudio di Fedora è http://koji.fedoraproject.org/koji/packageinfo?packageID=3527, quello dello sviluppatore Lennart Poettering, che interviene nel bugzilla, è: http://git.0pointer.de/?p=pulseaudio.git;a=summary.
Si potrebbe provare a ricompilare il tgz utilizzando le versioni patchate dei sorgenti di pulseaudio. Per il kernel non ho al momento tempo per un upgrade alla 2.6.27.7, comunque nel giro di un mese dovrebbe essere anche rilasciata la 2.6.28.
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda buteo » gio nov 27, 2008 13:51

Risalve-rieccomi.
Sto testando l'ultima versione git disponibile di pulseaudio, con patch (obbligatoria) messa a disposizione nel bugtrack degli sviluppatori.
Per chi volesse condividere questa esperienza, metto a disposizione il pacchetto:
http://eth.altervista.org/pulseaudio-0. ... -11-05.tgz
Ho pacchettizzato anche due versioni precedenti (http://eth.altervista.org/pulseaudio-0. ... -10-24.tgz corrispondente alla build 0.9.13-4 di Fedora e http://eth.altervista.org/pulseaudio-0. ... -11-01.tgz corrispondente alla -6) per chi volesse provare anche quelle. Attenzione, probabilmente dovrete copiare e incollare i link nel browser, non funziona linkando dal forum.
Nel mio caso solo l'ultima versione va in esecuzione. Il demone sta sopravvivendo decisamente oltre la storica mezzora e la qualità della riproduzione audio è nettamente migliorata, almeno per ora (domani lascio la riproduzione continua per più ore). Restano errori nei log, ma almeno si sente qualcosa...
La mia impressione è che il codice sia ancora molto beta e si proceda per tentativi, ma almeno si fanno passi in avanti. Stando a quanto ho letto nei forum, non credo avremo una release 0.9.14 ufficiale prima di un mese, per assenza del principale sviluppatore (Lennart Poettering).
La mia configurazione -differente da quella del pacchetto- è al momento:
/etc/pulse/daemon.conf
Codice: Seleziona tutto
realtime-scheduling = yes
high-priority = yes
no-cpu-limit = no
log-target = syslog
log-level = error
default-fragment-size-msec = 50

/etc/esd.conf:
Codice: Seleziona tutto
auto_spawn=0
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda gohanz » gio nov 27, 2008 16:05

Grazie Buteo vado a provare il tuo pacchetto. Ho visto che hai usato una personalizzazione per il tuo processore "nocona", spero che vada bene per tutti. In ogni caso, se non uscirà la versione stabile di PulseAudio, parlo della 0.9.14, possiamo usare il tuo SlackBuild per GSlacky-2.24.2. Tra l'altro è stato rilasciato proprio oggi Gnome-2.24.2. Non so quanto convenga pacchettizzarlo per la 12.1, visto l'imminenza dell'uscita della Slackware 12.2. Vediamo.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: pulseaudio 2.24.1

Messaggioda buteo » gio nov 27, 2008 17:25

forse ho sbagliato l'upload del pacchetto, visto che ne avevo fatto una versione standard per i686 con lo slackbuild di Gslacky quasi immutato. Domani in ufficio controllo e ci risentiamo
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda gohanz » gio nov 27, 2008 18:08

Buteo sto provando il tuo pacchetto. Funziona alla grande, PulseAudio gira da più di un'ora senza fare un piega. Credo che, a questo punto, uscirà anche una versione bugfix di GSlacky-2.24.2 per Slackware 12.1. Userò le tue indicazioni per il pacchetto di PulseAudio! :thumbright:
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: pulseaudio 2.24.1

Messaggioda buteo » gio nov 27, 2008 19:56

Ho controllato, gli eseguibili del pacchetto siano giusti, compilati per i686 con le opzioni dello slackbuild di Gslacky bloccate (-03 ...). Era sbagliato solo il file di slackbuild incluso nel tgz. In effetti ho usato per generare il pacchetto i686 uno slackbuild rinominato, mentre il pulseaudio.slackbuild incluso è rimasto -per caso- quello ottimizzato per la mia macchina.
Ho rifatto il tgz e quello pubblicato ora nel sito dovrebbe essere corretto: http://eth.altervista.org/pulseaudio-0. ... -11-05.tgz
Ho aggiunto anche i sorgenti già patchati: http://eth.altervista.org/pulseaudio-gi ... hed.tar.gz
In attesa di Gslacky 2.24.2, ciao a tutti.
Ultima modifica di buteo il ven nov 28, 2008 10:08, modificato 1 volta in totale.
buteo
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: mar apr 05, 2005 23:00
Slackware: 9.1-12.1
Kernel: 2.6.24.5

Re: pulseaudio 2.24.1

Messaggioda gohanz » ven nov 28, 2008 9:08

Buteo mi servirebbe SlackBuild modificato ed eventuali patch. Così posso riscostruire il pacchetto per GSlacky-2.24.2. Altrimenti uso direttamante l'svn. Un'altra cosa il tuo pacchetto ha il nome sbagliato, contiene troppi segni ( - ).
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti