Repository 32bit  Forum
Repository 64bit  Wiki

Problema Hibernate/Suspend

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema Hibernate/Suspend

Messaggioda Slack_Eater » lun mar 23, 2009 10:22

Ciao a tutti,

ho un problema con il suspend e rispettivamente l'hibernate del mio dell xps1330.
Praticamente ogni volta che voglio metterelo in suspend/hibernate invece di fare quello che dovrebbe parte lo screen saver e non succede niente.

Utilizzo KDE 4.2.1, slackware-current, kernel 2.6.28.7 ricompilato da me.
Con la vecchia versione di kde 3.5.10 l'hibernate ed il suspend funzionavano, ora no.

Cosa potrebbe essere?

Vi ringrazio anticipatamente.

Saluti
Avatar utente
Slack_Eater
Linux 2.0
Linux 2.0
 
Messaggi: 163
Iscritto il: gio feb 14, 2008 21:29
Località: Svizzera
Nome Cognome: Giuseppe Scalzi
Slackware: 13.37
Kernel: 2.6.38.2-smp
Desktop: KDE 4.7.0

Re: Problema Hibernate/Suspend

Messaggioda mbrancalion » lun mar 23, 2009 13:47

A me a volte, dopo prove varie di configurazioni personali, e' successo che l'ibernazione/sospensione fallisse, ma nei log (per esempio /var/log/pm-suspend.log) c'e' sempre scritto tutto, dove fallisce....
Per cui si puo' correggere quello che non va.......
Avatar utente
mbrancalion
Linux 2.0
Linux 2.0
 
Messaggi: 185
Iscritto il: ven ago 31, 2007 15:01
Località: Grignano Polesine (RO)
Nome Cognome: Marco Brancalion
Slackware: nessuna
Kernel: 2.6.38-11
Desktop: kde 4.6.2
Distribuzione: kubuntu 11.04

Re: Problema Hibernate/Suspend

Messaggioda neongen » lun mar 23, 2009 14:45

potrebbe dipendere da hal. metti questo http://slackware.com/~rworkman/hal.conf.txt in /etc/dbus-1/system.d/hal.conf
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: Problema Hibernate/Suspend

Messaggioda Slack_Eater » lun mar 23, 2009 22:49

Allora grazie a tutti per i consigli ma:

- i log non dicono niente inoltre nel mio sistema pm-suspend.log non esiste
- ho provato a sostituire hal.conf con quello indicato nel link ma il risultato non cambia

Ho provato ad usare il kernel 2.6.28.8 precompilato da Pat per verificare che magari ci fossero problemi con moduli o altro ma anche con quel kernel non ho risolto nulla.

Saluti
Avatar utente
Slack_Eater
Linux 2.0
Linux 2.0
 
Messaggi: 163
Iscritto il: gio feb 14, 2008 21:29
Località: Svizzera
Nome Cognome: Giuseppe Scalzi
Slackware: 13.37
Kernel: 2.6.38.2-smp
Desktop: KDE 4.7.0

Re: Problema Hibernate/Suspend

Messaggioda Blallo » mar mar 24, 2009 1:04

Vedi se nel kernel sono abilitati i moduli..devono essere abilitati con la spunta e non caricati come moduli (segno col pallino)
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problema Hibernate/Suspend

Messaggioda Roland » mar mar 24, 2009 9:34

sì, se stai usando il kernel default di slackware devi ricompilare ;)
Avatar utente
Roland
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: mer ago 20, 2008 0:32
Località: Catanzaro Lido
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2

Re: Problema Hibernate/Suspend

Messaggioda Slack_Eater » mer mar 25, 2009 10:19

Ok i moduli nel kernel ci sono:

Codice: Seleziona tutto
[*] Power Management support                                                                                           
[ ]   Power Management Debug Support                                                                                   
[*] Suspend to RAM and standby                                                                                         
[*] Hibernation (aka 'suspend to disk')                                                                                 
(resume=/dev/sda2) Default resume partition                                                                           
[*] ACPI (Advanced Configuration and Power Interface) Support  --->                                                   
< > APM (Advanced Power Management) BIOS support  --->                                                                 
CPU Frequency scaling  --->                                                                                       
[*] CPU idle PM support


In ogni caso questa configurazione prima con kde3 funzionava. È stato il passaggio di versione a non fare piu funzionare l'hibernate ed il suspend. Ma il demone che gestice queste operazioni è acpid?
Avatar utente
Slack_Eater
Linux 2.0
Linux 2.0
 
Messaggi: 163
Iscritto il: gio feb 14, 2008 21:29
Località: Svizzera
Nome Cognome: Giuseppe Scalzi
Slackware: 13.37
Kernel: 2.6.38.2-smp
Desktop: KDE 4.7.0

Re: Problema Hibernate/Suspend

Messaggioda Blallo » sab mar 28, 2009 0:20

si esatto, controlla che venga avviato al boot
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problema Hibernate/Suspend

Messaggioda Slack_Eater » lun mar 30, 2009 21:02

Si acpid si avvia al boot.
Avatar utente
Slack_Eater
Linux 2.0
Linux 2.0
 
Messaggi: 163
Iscritto il: gio feb 14, 2008 21:29
Località: Svizzera
Nome Cognome: Giuseppe Scalzi
Slackware: 13.37
Kernel: 2.6.38.2-smp
Desktop: KDE 4.7.0

Re: Problema Hibernate/Suspend

Messaggioda Blallo » lun mar 30, 2009 22:13

Devi cercare il modulo che si addice al tuo computer...
Il mio è un acer e uso quindi acer-wmi
cerca nel kernel Dell laptop extras e abilitalo come statico e non come modulo
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron