Repository 32bit  Forum
Repository 64bit  Wiki

Postgresql-7.4.1

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Postgresql-7.4.1

Messaggioda Loris » sab feb 21, 2004 17:34

Alcune settimane fa ho fatto per un ragazzo uno SlackBuild (mezzo copiato) che compila Postgresql 7.4.1 per Slackware...... <BR>Io non uso nessun db e quindi non potrei realmente testare a fondo questo pacchetto, ma se tra voi super utenti c´è una buona anima gentile che vuole farlo per tutti si faccia vivo qui....anche solo per dire che ho fatto una vaccata :) <BR>I file sono ===> <a href="http://www.slacky.it/download/traverse.php?dir=.%2Fsource-packages%2Fpostgresql%2F7.4.1" target="_blank">QUI</a> troverete lo SlackBuild il pacchetto .tgz per Slackware e anche i sorgenti.
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Postgresql-7.4.1

Messaggioda benez » dom feb 22, 2004 12:50

Salve Lorys, <BR>appena installato il pkg e tutto sembra andare 0k <BR>non ho ancora provato il programma ma ho dato un´occhiata la FS per controllare dove l´ha installato. non lo trovo. <BR>Dovrei installare un´altro pacchetto che si chiama Postgis ( <a href="http://postgis.refractions.net" target="_blank" target="_new">http://postgis.refractions.net</a> ) e si compila partendo dalla contrib nel tree di postgres (nell´installazione di default va a finire in /usr/local/postgresql-xxxxx/contrib/ ) <BR>Si tratta di un modulo che abilita la gestione di geometrie e dati geografici in pgsql (cioè lo rende Geodatabase) e necessita di vari altri moduli che andrebbero specificati nel configure per la compilazione di pgsql. Sul sito di postgis c´è una discussione in corso per la pacchettizzazione per ora in rpm e sarebbe molto fico arrivare ad una installazione completa tramite pacchetto. <BR>per ora volevo provare a compilare gli altri moduli sul pacchetto che hai costruito, ma non trovo i sorgenti di pgsql che probabilmente non sono previsti. <BR>Se mi puoi dare indicazioni, te ne sono veramente grato. <BR> <BR>PS complimenti per tutto il sito (è da un po´ che mi son registrato e ora lo seguo sempre) <BR>benez
benez
Linux 1.0
Linux 1.0
 
Messaggi: 43
Iscritto il: ven gen 09, 2004 0:00

Postgresql-7.4.1

Messaggioda Loris » dom feb 22, 2004 19:00

Ma intendi i sorgenti di Postgresql-7.4.1 ? li trovi nella dir src sempre nel solito link.
<BR>Cosa intendi per <!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> occhiata la FS per controllare dove l´ha installato. non lo trovo </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End -->
<BR>Grazie per l´interesse, è un peccato buttare tutto questo lavoro ;-)
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Postgresql-7.4.1

Messaggioda benez » dom feb 22, 2004 22:47

<BR>intendevo dire nell´intero file system <BR>comunque dopo l´installazione non trovo la dir "contrib" dei sorgenti di postgres. <BR>in quella dir dovrei scompattare i sorgenti e compilare da lì l´altro modulo postgis. <BR>non so se hai potuto dare un´occhiata alla documentazione di quel modulo, li è spiegato abbastanza bene e magari non mi sono fatto capire io. <BR>benez
benez
Linux 1.0
Linux 1.0
 
Messaggi: 43
Iscritto il: ven gen 09, 2004 0:00

Postgresql-7.4.1

Messaggioda Loris » lun feb 23, 2004 0:01

Ora ho capito, il problema è che i sorgenti vengono eliminati, eventualmente puoi usare lo SlackBuild senza l´opzione --cleanup e compilare il tuo modulo nella dir contrib, che troverai in /tmp/package-postgresql o al limite modificare lo script che lo faccia lui in automatico... una cosa che devi spiegarmi, questo modulo deve essere compilato prima di postgresql o dopo ?
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Postgresql-7.4.1

Messaggioda benez » lun feb 23, 2004 23:57

ciao lorys, <BR>il modulo va compilato dopo; <BR>riporto i comandi per il quick install dalla pagina doc di <a href="http://postgis.refractions.net" target="_blank" target="_new">http://postgis.refractions.net</a> <BR> <BR> <BR> <BR>cd contrib <BR>gunzip postgis-0.8.0.tar.gz <BR>tar xvf postgis-0.8.0.tar <BR>cd postgis-0.8.0 <BR>make <BR>make install <BR>createlang plpgsql yourtestdatabase <BR>psql -d yourtestdatabase -f postgis.sql <BR>psql -d yourtestdatabase -f spatial_ref_sys.sql <BR> <BR>in pratica è una aggiunta di una serie di funzioni con operatori geometrici al SQL standard + alcune estensioni (lo spatial_ref_sys), <BR>che sarebbero indicazioni sulle proiezioni geografiche mondiali) <BR>la contrib è la contrib del source tree di postgresql. <BR>inoltre ci sono altri moduli (GEOS che trovi sullo stesso sito) <BR>che invece vanno compilati prima del postgres <BR> <BR>sono contento che ci sia un certo interesse per questo applicativo che secondo me ha potenzialità enormi <BR>in pratica eleva il postgres alle funzionalità di oracle spatial (unico db geografico commerciale valido) - pensa solo alle applicazioni per le registrazioni catastali. Sarebbe molto fico riuscire a fare un installer pulito per slack <BR> <BR>benez
benez
Linux 1.0
Linux 1.0
 
Messaggi: 43
Iscritto il: ven gen 09, 2004 0:00

Postgresql-7.4.1

Messaggioda Loris » mar feb 24, 2004 21:09

Non ho fatto molte ricerche ma compilando il modulo postgis in contrib ricevo questo errore: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> make: *** [postgis_transform.o] Error 1 </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR>Se sai come risolvere avvisami io intanto cerco...... <BR> <BR>p.s. prova anche tu a fare esperimenti :-P
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Postgresql-7.4.1

Messaggioda benez » mer feb 25, 2004 9:13

make: *** [postgis_transform.o] Error 1 <BR>hhhmmmmm.......... <BR>dovrebbe essere dovuto alla mancanza del pacchetto Proj4, <BR>una libreria per le trasformazioni di coordinate geografiche tra i vari sistemi di proiezione mondiali, inizialmente sviluppato da USGS e ora su <a href="http://www.remotesensing.org/proj/" target="_blank" target="_new">http://www.remotesensing.org/proj/</a> <BR> <BR>Ci dovrebbe essere la possibilità di disattivarlo, modificando direttamente il makefile di postgis (USE_PROJ=0) oppure installando prima proj4. Può darsi che le ultime versioni (0.8.x) non abbiano più questa possibilità <BR>Appena ho fatto un po´ di prove ti faccio sapere <BR>(non ho molto tempo a disposizione) <BR>benez <BR>
benez
Linux 1.0
Linux 1.0
 
Messaggi: 43
Iscritto il: ven gen 09, 2004 0:00

Postgresql-7.4.1

Messaggioda Loris » mer feb 25, 2004 22:43

Con l´aiuto di Marco ho terminato il pacchetto di Postgresql-7.4.1 ora su questa base lavoriamo per il resto..... a che punto sei tu ?
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Postgresql-7.4.1

Messaggioda benez » gio feb 26, 2004 0:47

completata l´istallazione di tutto (modulo geos_refractions.net + proj + postgresql + postgis finalmente) <BR>ho fatto tutto compilando con le opzioni di default dei vari configure (quindi le path sono tutte /usr/local/programma ) e partendo dai sorgenti. <BR>tutte le compilazioni sono andate bene e senza errori <BR>io sto lavorando su slack 9.1 kernel 2.6.1 SMP <BR>(aahh ovviamente del postgresql è la current 741) <BR>ora per me il problema è che sono nuovo di slack - solo anni fa avevo usato un po´ la 3.6 o giù di lì) e soprattutto non ho mai fatto un build pkg. <BR>proverò a studiare l´howto oltre a testare tutto l´insieme di applicazioni <BR>ma se intanto mi dai qualche dritta (non programmo ne sono sistemista- solo umile geologo prestato all´informatica) <BR> <BR>benez <BR> <BR>
benez
Linux 1.0
Linux 1.0
 
Messaggi: 43
Iscritto il: ven gen 09, 2004 0:00

Postgresql-7.4.1

Messaggioda pinguinosn » gio feb 26, 2004 1:31

per installare correttamente postgresql occorre anche <BR>ant (come descritto sul sito di postgresql) <BR>altrimenti l´opzione --with-java che compila vari moduli <BR>per l´accesso tramite java non è possibile <BR>inoltre ci sono alcune patch da installare (versione 7.4.1) <BR>in sinstesi non è uno dei pkg + semplici da compilare <BR>correttamente però prova e riprova ... <BR>ciao <BR><BR><BR>[ Questo Messaggio è stato Modificato da: pinguinosn il 26-02-2004 01:32 ]<br>
Avatar utente
pinguinosn
Linux 2.0
Linux 2.0
 
Messaggi: 110
Iscritto il: dom feb 08, 2004 0:00
Località: livorno
Slackware: 13.37
Kernel: 3.3
Desktop: gnome3
Distribuzione: archlinux

Postgresql-7.4.1

Messaggioda Loris » gio feb 26, 2004 12:45

OK quindi dici che così non è completo ? ma oltre alle patch e a ant secondo te siamo sulla strada giusta ?
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Postgresql-7.4.1

Messaggioda pinguinosn » gio feb 26, 2004 23:32

Postgresql (almeno in tutte le distro che lo supportano) <BR>è composto e dipende da altri package. <BR>penso (ma è un mio modesto parere) <BR>che al momento non è ancora completo. <BR> <BR> <BR> <BR> <BR> <BR> <BR> <BR><BR><BR>[ Questo Messaggio è stato Modificato da: pinguinosn il 26-02-2004 23:49 ]<br>
Avatar utente
pinguinosn
Linux 2.0
Linux 2.0
 
Messaggi: 110
Iscritto il: dom feb 08, 2004 0:00
Località: livorno
Slackware: 13.37
Kernel: 3.3
Desktop: gnome3
Distribuzione: archlinux

Postgresql-7.4.1

Messaggioda kual » ven feb 27, 2004 9:53

Ciao, prima volta che accedo ad un forum, siate clementi! <BR>Ho iniziato a ´smanettare´ con PostgreSQL(ottimo!)+Red-Hat8.0(<ottimo) qualche mese fa. <BR>Compilato sorgenti, tutto OK. <BR>Passato a Slack 9.1 due mesi fa (bella distro!) ho compilato postgresql741-base- con fortunato successo. <BR>Provato e riprovato stessa cosa su macchina altra macchina, identica distro(Slack9.1) con vari pacchetti, anche quello trovato su slacky.it denominato "----".1sl.tar.gz. <BR>In fase di ´make´ il Gcc(3.2.3) va in segmentation fault. <BR>Qual´è il concetto che sta dietro a questo pacchetto che pesa circa 6M contro i 18-20 del pacchetto scaricabile dal sito ufficiale? <BR>Basta lanciare lo script nella dir install per installare? Se cosi´ fosse, non funge!! <BR>Sarei ULTRALieto di avere costruttive diatribe con altri personaggi, info su come si sta in forum, su come aprire un canale ICQ o mIrc...apppongo la mia mail (aihme´ ancora su hotmail..) <BR>lukabass@hotmail.com <BR><br>
Avatar utente
kual
Linux 1.0
Linux 1.0
 
Messaggi: 37
Iscritto il: mer feb 25, 2004 0:00

Postgresql-7.4.1

Messaggioda Loris » ven feb 27, 2004 13:37

Il file che trovi su questo sito è un pacchetto precompilato per Slackware, se tu vai nella dir src trovi lo SlackBuild, script che contiene tutti i passi svolti per la compilazione di PostreSql, pesa poco perchè i binari e le librerie vengono strippate, i man vengono gzippati etc etc <BR>Per installare questo pacchetto ti basta un installpkg nomepackage e basta o meglio ancora scarichi i sorgenti modifichi a piacere lo SlackBuild e compili la tua versione ottimizzata lanciando semplicemente lo script all´interno della dir dei sorgenti.... <BR> <BR>In area Howto trovi un tutorial a riguardo..<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Majestic-12 [Bot] e 1 ospite