Repository 32bit  Forum
Repository 64bit  Wiki

problemi slack-required

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

problemi slack-required

Messaggioda ZeroUno » sab mag 02, 2009 15:45

Salve.
Ho riscontrato un difetto nello slack-required del pacchetto music-applet di gnome-slacky-12.1:
avahi >= 0.6.23-i486-1as | avahi-0.6.23-i686-12gslacky-upgraded >= 2008-08-08,09

questo genera qualche problema a livello di repository per la gestione con slapt-get e affini.

Saluti,
01
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: problemi slack-required

Messaggioda gohanz » lun mag 04, 2009 19:47

ZeroUno, se possibile, dovresti ricompilare tu il pacchetto. Io sono sulla 12.2. Eventualemte poi lo possiamo mettere a disposizione corrett :thumbright: o!
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: problemi slack-required

Messaggioda ZeroUno » mar mag 05, 2009 14:57

quindi stai sviluppando gslacky per 12.2?

mmm.. io sono con la 12.2 (peggio, -current) e non ho gslacky installato.
Nella riorganizzazione della gestione dei repository quella dipendenza ci sta dando qualche grana.
In verità c'è anche qualche altro pacchetto, tipo beagle su gslacky 12.0

comunque quello che serve non è ricompilare ma ritoccare lo slack-required a mano e in qualche caso il changelog.
Il problema è solo sulle dipendenze; il pacchetto non ne è affetto, ma slapt-get e affini potrebbero incastrarsi.

beagle.SlackBuild:
ADD="chmlib >= 0.39-i486-1bj, evolution-sharp >= 0.15.4-i686-9as, gtk-sharp >= 2.10.2-i686-9as, gnome-sharp >= 2.16.0-i686-9as, gsf-sharp >= 0.8.1-i686-9as, pygtk >= 2.12.1-i686-9as, gmime >= 2.2.15-i686-9as. ndesk-dbus >= 0.6.0-i686-9as, ndesk-dbus-glib >= 0.4.1-i686-9as, taglib-sharp >= 2.0.3.0-i686-1as" \
(notare il punto tra gmime e ndesk-dbus)
che si riperquote su slack-required
gmime >= 2.2.15-i686-9as. ndesk-dbus >= 0.6.0-i686-9as

ci sono anche altri casi (ora non ricordo quali). Credo che sia sufficiente una scompattazione, modifica di install/slack-required e usr/doc/*/*.Slackbuild, ricompattazione, upload.

mentre per music-applet
avahi >= 0.6.23-i486-1as | avahi-0.6.23-i686-12gslacky-upgraded >= 2008-08-08,09
credo dovrebbe essere sufficiente eliminare " | avahi-0.6.23-i686-12gslacky-upgraded >= 2008-08-08,09" da install/slack-required

Ciao,
01

P.S. Assicurati di avere l'ultima versione di requiredbuilder perchè alcune versioni passate hanno alcuni brutti bug noti.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: problemi slack-required

Messaggioda gohanz » lun mag 11, 2009 19:39

Ok allora domani revisiono manualmente gli Slack-Required che danno problemi.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti