Repository 32bit  Forum
Repository 64bit  Wiki

Rilasciato GNOME-2.26.0!

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » lun mag 04, 2009 19:21

Grazie a Slucky per il report ed a Mohaa per la soluzione! :thumbright: Sarà un bug di Gnome-2.26.1, ora c'è da capire il pacchetto che causa il problema.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Rilasciato GNOME-2.26.0! << Seed please

Messaggioda mohaa » lun mag 04, 2009 20:22

Bravo a te Gohanz ;)
2.26 o il rilascio più strano mai visto, id est non si po usare quasi nessuno dei componenti *2.26* (sia gdm che gnome-session o g-p-m)
Please seed the torrent : I am stuck at 4,8% after few 24 hours
Avatar utente
mohaa
Linux 2.0
Linux 2.0
 
Messaggi: 181
Iscritto il: mar mar 04, 2008 8:52
Località: Francia
Slackware: 12.1
Kernel: 3
Desktop: Gnome2
Distribuzione: Gentoo

Re: Rilasciato GNOME-2.26.0!

Messaggioda sombriks » ven mag 08, 2009 13:14

nice work, this release is a must-have.

i also got some problem with gconf-sanity-check-2 and found the solution here, thanks a lot!
sombriks
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: gio lug 31, 2008 21:15

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » sab mag 09, 2009 17:13

Ottimo lavoro gohanz... come al solito :D

Una cosa non ho capito... nella pagina di informazioni su gslacky, alla fine viene detto:

Per usare gli strumenti di amministrazione da user, occorre aggiungersi al gruppo stb-admin.


Ma purtroppo questo gruppo non esiste... devo crearlo io? devo fare qualcosa in particolare?

ciao e grazie
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » sab mag 09, 2009 19:23

mkt0 ha scritto:Ottimo lavoro gohanz... come al solito :D

Una cosa non ho capito... nella pagina di informazioni su gslacky, alla fine viene detto:

Per usare gli strumenti di amministrazione da user, occorre aggiungersi al gruppo stb-admin.


Ma purtroppo questo gruppo non esiste... devo crearlo io? devo fare qualcosa in particolare?

ciao e grazie


No le info devono essere aggiornate. Adesso il gruppo per usare gnome-system-tools è "adm" in standard Slackware. Inoltre il pacchetto system-tools-backends è stato patchato, per aggirare policykit-gnome. Adesso non dovrebbe essere più necessario dare i permessi tramite il tool grafico, ma basta usare il classico sistema Slackware. Quindi aggiungere manualmente l'account al gruppo desiderato, adm, power, plugdev...
Appena posso apro un nuovo post, con la descrizione del nuovo GSlacky. ( Supporto midi, fax....)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » dom mag 10, 2009 9:41

ok, capito.

comunque funziona quasi tutto... tranne NetworkManager... che nelle precedenti versioni di Gslacky andava.
penso forse che ci sia qualche errorino nel suo rc di avvio.

con lo start, non deve essere avviato anche wpa_supplicant? o ci deve pensare qualche altro script?

eppure nello stop si cerca di killarlo... ed inoltre si fa' riferimento ad una variabile $WPA_PIDFILE, che non mi pare sia stata dichiarata da nessuna parte, ed infatti nello stop lo script mi si pianta....

Codice: Seleziona tutto
  echo -en "Stopping wpa_supplicant dbus services: "
  local pidlist=`cat $WPA_PIDFILE 2>/dev/null`
  if [ ! -z "$pidlist" ]; then
    kill $pidlist &>/dev/null
    rm -f $WPA_PIDFILE &>/dev/null
  fi
  ## Be sure we're dead
  killall -q -15 wpa_supplicant
  killall -q -15 nm-system-settings
  echo "stopped";


ora l'ho modificato, avviando wpa_supp quando faccio start, aggiungendo il WPA_PIDFILE, ma NM mi dice che il dispositivo non è pronto....
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » dom mag 10, 2009 11:09

wpa_supplicant viene avviato tramite un service file di dbus
Codice: Seleziona tutto
/usr/share/dbus-1/services/fi.epitest.hostap.WPASupplicant.service
. Il file rc di avvio effettivamente è sbagliato, ma non credo che sia poi quello il problema. Slucky in un post precedente mi ha segnalato il corretto funzionamento. Comunque in GSlacky-2.26.1, NetworkManager è passato alla versione 0.7.1, GSlacky-2.24.3 usava la versione 0.7.0.
Forse un problema con la nuova versione?

Per il file rc elimina tutta questa parte dalla riga 73 alla riga 82

Codice: Seleziona tutto
echo "stopped";

  echo -en "Stopping wpa_supplicant dbus services: "
  local pidlist=`cat $WPA_PIDFILE 2>/dev/null`
  if [ ! -z "$pidlist" ]; then
    kill $pidlist &>/dev/null
    rm -f $WPA_PIDFILE &>/dev/null
  fi
  ## Be sure we're dead
  killall -q -15 wpa_supplicant



Putroppo non avendo una connessione wireless, non ho modo di testare bene NetworkManager. Però con la mia connessione fissa funziona correttamente.

Immagine
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » dom mag 10, 2009 11:44

il service file dbus riporta:
Codice: Seleziona tutto
[D-BUS Service]
Name=fi.epitest.hostap.WPASupplicant
Exec=/usr/sbin/wpa_supplicant -u                                       
User=root


ma non mi pare che -u sia un opzione valida per wpa_supplicant, inoltre non e' tra i processi in esecuzione.

ovviamente se mi avvio wpa_supp e wpa_gui la wifi funziona alla grande (non tramite nm-applet ovviamente...)

strano...

altra cosa notata... dall'applet cpu-freq non mi fa' cambiare le impostazioni della frequenza. da shell ovviamente posso modificarli... ma prima anche dall'applet :| roba di permessi ovviamente.

EDIT:

inoltre, non mi funziona nessuno degli strumenti di amministrazione... il tasto sblocca rimane sempre e solo opaco... anche con X avviato da root. possibile?
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » dom mag 10, 2009 19:02

Per quanto riguarda l'applet cpu-freq devo indagare, in effetti da GSlacky-2.26.1 dovrebbe usare Policykit invece che Setuid. Però ho visto che manca il file di configurazione di Policykit. Di conseguenza anche aprendo Policykit-gnome non compare nessuna voce per l'autorizzazione all'uso dell'applet. Devo provare a ricompilare con il vecchio metodo Setuid.
Se vuoi smanettare con gnome-applets, i sorgenti li trovi in /source/desktop.
Per gli strumenti di amministrazione è giusto che il pulsante "sblocca" sia disablitato. Come ti ho detto prima, sytem-tools-backends è patchato per aggirare Policykit. Basta avere il proprio account nel gruppo "adm" .
Immagine
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » dom mag 10, 2009 19:22

Si infatti ho notato che in Policykit non c'e' nulla a riguardo... non sarebbe male che comparisse li al posto di setuid :D
Per ora ho messo l'ondemand come governor e puo' anche andar bene cosi'.

Questione NetworkManager. Non mi sapresti dire nulla? Dovrebbe essere lanciato automaticamente all'avvio? Se si... a me non lo fa'. Strano...

Questione strumenti amministrazione. Ok la storia del bottone, pero' sul mio utente non posso fare nulla, ne' tanto meno sui gruppi, servizi etc etc. E' normale? Famo tutto da shell?

Il mio file /etc/group recita:
Codice: Seleziona tutto
adm:!:4:adm,daemon,mkt0


anche groups mi dice che sono in adm.

Ciao e grazie ancora.
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » lun mag 11, 2009 19:29

Mkt0 l'installazione di Gslacky-2.26.1 l'hai fatta su una Slackware 12.2 pulita o hai fatto l'update di GSlacky-2.24.3?

Comunque per quanto riguarda gnome-applets dovresti ricompilare il pacchetto
Codice: Seleziona tutto
/source/desktop/gnome-applets
usando queste impostazioni nello SlackBuild. Io ho provato e, finalmente, sono stati installati i file per Policykit.

Codice: Seleziona tutto
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure  --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-static \
--enable-mixer-applet \
--enable-flags \
--program-prefix= \
--program-suffix= \
--build=$CHOST-slackware-linux
make
make install DESTDIR=$PKG


Per quanto rigurada NetworkManager devi solo rendere eseguibile lo script di avvio e aggiungere il tuo account al gruppo "netdev"

Per i tool di amministrazione, un minimo di debug di puo avere da shell.

Codice: Seleziona tutto
cd /usr/share/system-tools-backends-2.0/scripts/


Codice: Seleziona tutto
perl SystemToolsBackends.pl --module UsersConfig --verbose
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » mer mag 13, 2009 10:49

gohanz ha scritto:Mkt0 l'installazione di Gslacky-2.26.1 l'hai fatta su una Slackware 12.2 pulita o hai fatto l'update di GSlacky-2.24.3?

Si, installazione su Slackware 12.2 full senza nessuno gnomo preinstallato. Al max ho levato qualche pacchetto tipo driver video che non mi servono, server ftp e apache.

Questione gnome-applets.
gohanz ha scritto:Comunque per quanto riguarda gnome-applets dovresti ricompilare il pacchetto [.... cut .... ]


Ok risolto :)

Questione networkmanager.
gohanz ha scritto:Per quanto rigurada NetworkManager devi solo rendere eseguibile lo script di avvio e aggiungere il tuo account al gruppo "netdev"

Lo script e' eseguibile, e sono nel gruppo netdev.
Il prob penso sia un'altro...
Non viene avviato wpa_supplicant, la conf in
/usr/share/dbus-1/services/fi.epitest.hostap.WPASupplicant.service non esegue il supplicatore. idee in merito?

Ho risolto comunque mettendo nel rc.networkmanager l'avvio (wpa_supplicant -u -p $WPA_PIDFILE) e il kill nello stop.

Questione tool amministrazione.
gohanz ha scritto:Per i tool di amministrazione, un minimo di debug di puo avere da shell.

Codice: Seleziona tutto
cd /usr/share/system-tools-backends-2.0/scripts/

Codice: Seleziona tutto
perl SystemToolsBackends.pl --module UsersConfig --verbose


Ho provato ad eseguire lo script da shell come root, e questo e' il suo output:

Codice: Seleziona tutto
 /usr/bin/perl /usr/share/system-tools-backends-2.0/scripts/SystemToolsBackends.pl --module UsersConfig --verbose
begin::Start of work report.
file_locate_tool_success::Found tool [uname].
file_run_pipe_success::Piping command [LC_ALL=C PATH=$PATH:/sbin:/usr/sbin /bin/uname -s 2> /dev/null |] for reading.
file_locate_tool_success::Found tool [usermod].
file_locate_tool_success::Found tool [userdel].
file_locate_tool_success::Found tool [useradd].
file_locate_tool_success::Found tool [adduser].
file_locate_tool_failed::Couldn't find tool [deluser].
file_locate_tool_success::Found tool [chfn].
file_locate_tool_failed::Couldn't find tool [pw].
coucou!
coucou!

Che e' quel coucou?? mi pare il berlusca che sfotte la Merkel :D
Poi ho lanciato users-admin da utente ed il SystemToolsBackends.pl ha sputato fuori:
Codice: Seleziona tutto
file_open_read_failed::Could not open [/etc/pam.d/passwd] for reading.
file_open_read_success::Reading options from [/etc/login.defs].
file_open_read_success::Reading options from [/etc/passwd].
file_open_read_success::Reading options from [/etc/shadow].
file_open_read_success::Reading options from [/etc/shells].


Mentre sulla shell dove lancio users-admin:
Codice: Seleziona tutto
** (users-admin:26046): CRITICAL **: Unable to lookup session information for process '26046'


Grazie ancora
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » mer mag 13, 2009 19:20

Mkto per NetworkManager lo potresti lanciare da shell senza usare lo script di avvio? Così per avre un po di messaggi di debug

Codice: Seleziona tutto
NetworkManager --no-daemon


Per i tool di amministrazione a me sembra che non diano messaggi di errore. Ma da root funzionano?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » mer mag 13, 2009 21:25

gohanz ha scritto:Mkto per NetworkManager lo potresti lanciare da shell senza usare lo script di avvio? Così per avre un po di messaggi di debug

Codice: Seleziona tutto
NetworkManager --no-daemon


allora, se lo avvio da shell, le prime righe riportano:
Codice: Seleziona tutto
NetworkManager: <info>  starting...
-- Error received: File exists
-- Original message: type=0x14 length=56 flags=<REQUEST,ACK,ATOMIC> sequence-nr=1242246113 pid=4216382
NetworkManager: <WARN>  nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():
Sucess

NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/dell_wlan_switch
NetworkManager: <info>  (eth0): new Ethernet device (driver: 'tg3')
NetworkManager: <info>  (eth0): exported as /org/freedesktop/Hal/devices/net_00_14_22_c4_dc_c8
NetworkManager: <info>  (eth1): driver supports SSID scans (scan_capa 0x21).
NetworkManager: <info>  (eth1): new 802.11 WiFi device (driver: 'ipw2200')
NetworkManager: <info>  (eth1): exported as /org/freedesktop/Hal/devices/net_00_16_6f_60_b3_8a
NetworkManager: <info>  (ttyS0): ignoring due to lack of mobile broadband capabilties
NetworkManager: <WARN>  killswitch_getpower_reply(): Error getting killswitch power: Rejected send message, 1 matched rules; type="method_call", sender=":1.67" (uid=0 pid=22078 comm="NetworkManager --no-daemon ") interface="org.freedesktop.Hal.Device.KillSwitch" member="GetPower" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=2663 comm="/usr/sbin/hald --daemon=yes ")).

ma scusa... il prob non e' di wpa_supplicant o di chi deve avviarlo, che non lo fa' correttamente?

gohanz ha scritto:Per i tool di amministrazione a me sembra che non diano messaggi di errore. Ma da root funzionano?


aime' anche da root non posso modificare nulla :|
che abbia scazzato qualcosa durante l'installazione?

grazie ancora :D
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda slucky » gio mag 14, 2009 21:30

mkt0 puoi anche bypassare n-m ed usare la rete con i normali strumenti di Slackware ;)
io ho solo configurato e lanciato il supplicant da terminale al primo tentativo di connessione e poi caricato il driver del mio pennino zd1211rw al boot del sistema, per la configurazione ti basta settare rc.inet1.conf è al plug and play del pennino la rete si attiva :)
prova....se anche così non va allora bisogna capire dov'è il problema......... :-k
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2379
Iscritto il: mar mag 01, 2007 14:30
Slackware: 14.1
Kernel: default
Desktop: xfce

PrecedenteProssimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron