Repository 32bit  Forum
Repository 64bit  Wiki

Rilasciato GNOME-2.26.0!

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » gio mag 14, 2009 22:59

Ah guarda il problema NetworkManager e' gia' bello e risolto.

La questione e' di wpa_supplicant che non viene avviato correttamente da:
/usr/share/dbus-1/services/fi.epitest.hostap.WPASupplicant.service
cosa che ora fa' l'rc di networkmanager.

Ovviamente anche senza network-manager riuscivo a collegarmi senza problemi.
Il fatto e' che un portatile, fatto per esser portato in giro, ha per forza bisogno di un tool pratico per connettersi su qualsiasi rete, da configurare al volo senza modificare nulla... altrimenti si, vado di shell.
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda slucky » ven mag 15, 2009 17:13

sarà....ma n-m ancora oggi resta incompleto e mal-funzionante, nei tab di configurazione si può solo scegliere tra Modo: Infrastruttura o Ad-Hoc...restano tagliati fuori Managed o modalità Master e continua ad aver problemi con gli IP statici...insomma anche sul nuovo gslacky ho provato ad usarlo ma senza successo....mentre invece configurando la connessione da rc.inet1 va subito come un treno :)
"...and what exactly is a dream....and what exactly is a joke."

"Jugband Blues" ( Syd Barrett )
Avatar utente
slucky
Iper Master
Iper Master
 
Messaggi: 2377
Iscritto il: mar mag 01, 2007 14:30
Slackware: 12.0 / 14.1
Kernel: default
Desktop: gslacky / xfce

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » ven mag 15, 2009 18:33

Ma il problema con l'esecuzione di wpa_supplicanrt si presenta solo con Mkt0?

Sul mio pc, NetworkManager prova ad avviare supplicant. Ora non avendo il wireless non ho modo di testare. Però l'esecuzione avviene correttamente.

Codice: Seleziona tutto
NetworkManager: <info>  Trying to start the supplicant...
NetworkManager: <info>  (eth0): carrier now ON (device state 1)
NetworkManager: <info>  (eth0): device state change: 1 -> 2
NetworkManager: <info>  (eth0): preparing device.
NetworkManager: <info>  (eth0): deactivating device (reason: 2).


Io ho il sospetto che sul pc di Mkt0 ci sia un problema con dbus. Infatti anche gli strumenti di amministrazione danno problemi.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Rilasciato GNOME-2.26.0!

Messaggioda mkt0 » dom mag 17, 2009 9:25

Che NetworkManager sia ancora incompleto, e' fuori discussione. Ce ne vuole ancora per diventare un tool completo, pero' per fare le due/tre cose piu' comuni ed usuali va decentemente.

Gohanz come possiamo fugare ogni dubbio su dbus?

Questi i pkg installati:

-rw-r--r-- 1 root root 3214 2009-05-09 18:58 /var/log/packages/dbus-1.2.12-i686-2261gslacky
-rw-r--r-- 1 root root 2883 2009-05-09 18:59 /var/log/packages/dbus-glib-0.80-i686-2261gslacky
-rw-r--r-- 1 root root 4819 2009-05-09 18:59 /var/log/packages/dbus-python-0.83.0-i686-2261gslacky
-rw-r--r-- 1 root root 922 2009-05-08 15:57 /var/log/packages/dbus-qt3-0.70-i486-2

Grazie ancora!
Avatar utente
mkt0
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: mer mar 10, 2004 0:00
Località: Bologna
Slackware: 13
Kernel: 2.6.32.2 lvm+luks
Desktop: Fluxbox

Re: Rilasciato GNOME-2.26.0!

Messaggioda gohanz » dom mag 17, 2009 11:11

Una volta ho avuto problemi con i gnome-system-tool. La causa era dovuta ad una corruzione dei file di configurazione.
Io proverei a cancellare
Codice: Seleziona tutto
/etc/dbus-1/session.conf
e
Codice: Seleziona tutto
 /etc/dbus-1/system.conf

Poi dovresti reinstallare dbus. I pacchetti li trovi in /packages/devlib.
Quindi
Codice: Seleziona tutto
 upgradepkg --reinstall dbus*
.
Una volta reinstallati riavvii il pc. Apri due terminali e da una parte lanci dbus-monitor e dall'altro lanci users-admin ad esempio.
Così se ancora non funziona, vediamo se dbus-monitor da qualche indicazione.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Precedente

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti