Repository 32bit  Forum
Repository 64bit  Wiki

Layout tastiera

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Layout tastiera

Messaggioda Blizzard » mar giu 16, 2009 10:34

Probabilmente lo segnalo a Pat.
Ogni volta che avvio la 64 devo reimpostare il layout tastiera ad it perchè ritorna ad US.
Il problema è che alcune volte dal pannello di controllo la lingua è settata ad it e devo rimuoverla e reinserirla.

Non riesco a capire se è un problema di KDE4 o altro.

ciao
Gio
Avatar utente
Blizzard
Master
Master
 
Messaggi: 1509
Iscritto il: mar gen 02, 2007 22:53
Nome Cognome: Giovanni Santostefano
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: Fluxbox

Re: Layout tastiera

Messaggioda conraid » mar giu 16, 2009 10:56

Blizzard ha scritto:Probabilmente lo segnalo a Pat.
Ogni volta che avvio la 64 devo reimpostare il layout tastiera ad it perchè ritorna ad US.
Il problema è che alcune volte dal pannello di controllo la lingua è settata ad it e devo rimuoverla e reinserirla.

Non riesco a capire se è un problema di KDE4 o altro.

ciao
Gio


Ma da che init parti?
dove l'hai configurata? xorg.conf o hal?
quali driver usi?
è un po' troppo generica come descrizione del problema
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12019
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Layout tastiera

Messaggioda Blizzard » mar giu 16, 2009 11:12

conraid ha scritto:Ma da che init parti?

3

conraid ha scritto:dove l'hai configurata? xorg.conf o hal?

ho una tastiera ps2 e l'ha riconosciuta automaticamente
Codice: Seleziona tutto
root@darkstar:~# lshal | grep kbd
  info.linux.driver = 'i8042 kbd'  (string)
  info.linux.driver = 'atkbd'  (string)

penso hal se kbd non è tutt'altro. Come faccio a saperlo?

Il layout l'ho settato in KDE come facevo quando avevo il 3

conraid ha scritto:quali driver usi?

sorry non so proprio dirtelo se non sono quelli elencati da lshal :cry:

puoi dirmi qualcosa di più se questi dati sono giusti?

Gio
Avatar utente
Blizzard
Master
Master
 
Messaggi: 1509
Iscritto il: mar gen 02, 2007 22:53
Nome Cognome: Giovanni Santostefano
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: Fluxbox

Re: Layout tastiera

Messaggioda conraid » mar giu 16, 2009 11:20

IMHO, lascia perdere la configurazione tramite kde (metti niente nel centro di controllo) e lascia perdere il riconoscimento fuori X (visto che stai parlando di KDE)
comunque per fuori x è interessato il file /etc/rc.d/rc.keymap

Per X nella current o usi kbd o usi evdev, il secondo è automatico se non hai niente in xorg.conf
Nel primo caso configuri xorg.conf nel solito modo
Codice: Seleziona tutto
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"     
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "it" 
EndSection

Nel secondo (che poi nel nuovo xorg è quello di default, quindi anche se hai quella sezione se trova un file di hal usa quello, e hal di default è configurato in inglese) copia il file /usr/hal/fdi/policy/10osvendor/10-keymap.fdi in /etc/hal/fdi/policy/10osvendor/10-keymap.fdi

Codice: Seleziona tutto
# cat /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi > /etc/hal/fdi/policy/10osvendor/10-keymap.fdi

e dopo cambia us con it, deve venire un file così:
Codice: Seleziona tutto
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <!-- Restore Ctrl-Alt-Bksp Xserver Zapping -->
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

      <merge key="input.xkb.layout" type="string">it</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>



comunque nella discussione sul nuovo Xorg ne è stato già parlato

Dimmi se così funziona
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12019
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Layout tastiera

Messaggioda Blizzard » mar giu 16, 2009 12:07

Risolto configurando hal! :thumbright:

per precisazione in caso qualcuno avrà lo stesso problema, il path del file è

/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi

Grazie mille Corrado (effettivamente non mi ero filato troppo il topic sul nuovo X :oops: )

Gio
Avatar utente
Blizzard
Master
Master
 
Messaggi: 1509
Iscritto il: mar gen 02, 2007 22:53
Nome Cognome: Giovanni Santostefano
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: Fluxbox

Re: Layout tastiera

Messaggioda conraid » mar giu 16, 2009 12:11

comunque ho detto una cavolata, non è evdev che carica hal ma viceversa, alla fine quel che conta è che se c'è un file di configurazione (in usr/share/hal o in /etc/hal) hal prende il sopravvento

p.s.
corretto il path
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12019
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current


Torna a Slackware64

Chi c’è in linea

Visitano il forum: sunreal e 2 ospiti