Repository 32bit  Forum
Repository 64bit  Wiki

Server

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Server

Messaggioda alternico » mar mar 22, 2005 7:59

editato dall'autore...
Ultima modifica di alternico il mar lug 13, 2010 13:38, modificato 2 volte in totale.
alternico
Linux 1.0
Linux 1.0
 
Messaggi: 4
Iscritto il: lun mar 21, 2005 0:00

Server web = SICUREZZA

Messaggioda Michele84 » mar mar 22, 2005 13:28

Ciao, <BR>per la stabilità ti consiglio un kernel 2.4.X mentre se vuoi un kernel veloce ma ancora (o quasi) in fase di sviluppo installa pure il 2.6.X <BR>Se vuoi un consiglio, usa i pacchetti di apache sql php ecc quelli che trovi gia pacchettizzati in questo sito oppure da linuxpackages.net. <BR>Se invece hai bisogno di particolari apllicazioni con apache (tipo far girare pagine asp, asp.NET ecc), sarebbe meglio installare tutto da sorgenti. <BR> <BR>Ciauz!!! <br>
Michele84
Linux 2.4
Linux 2.4
 
Messaggi: 267
Iscritto il: mer dic 17, 2003 0:00

Server web = SICUREZZA

Messaggioda DaNiMoTh » mar mar 22, 2005 14:36

Beh, è ovvio che se compili i pacchetti questi verranno ottimizzati per la tua macchina ( ed andranno molto più veloci ). Se invece installi i tgz, sono programmi compilati su altre macchine e quindi non prestanti come se compilassi tu. <BR> <BR>Per la sicurezza e tutto il resto... alla fine è lo stesso pacchetto, di differenze non ce ne sono ( a parità di versioni ). <BR> <BR> <BR>ciao!<br>
Avatar utente
DaNiMoTh
Linux 2.6
Linux 2.6
 
Messaggi: 941
Iscritto il: mar nov 30, 2004 0:00
Località: irc.syrolnet.org /// #slackware

Server web = SICUREZZA

Messaggioda Loris » mar mar 22, 2005 20:17

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>Per la sicurezza e tutto il resto... alla fine è lo stesso pacchetto, di differenze non ce ne sono ( a parità di versioni ).</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR>DaNiMoTh, però Alternico installa da sorgenti senza usare SlackBuild... almeno credo... quindi una compilazione casalinga non prevede certe pratiche, vedi lo strip dei binari... questo genera un binario completamente diverso dagli altri, quindi meno soggetto da cattivi exploit, a mio avviso i TGZ precompilati sono più sicuri, senza contare che sono anche più comodi e immediati.<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Server web = SICUREZZA

Messaggioda alternico » mar mar 22, 2005 23:07

editato dall'autore...
Ultima modifica di alternico il mar lug 13, 2010 13:39, modificato 1 volta in totale.
alternico
Linux 1.0
Linux 1.0
 
Messaggi: 4
Iscritto il: lun mar 21, 2005 0:00

Server web = SICUREZZA

Messaggioda useless » ven mar 25, 2005 10:30

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR> 22-03-2005 alle ore 14:36, DaNiMoTh : <BR>Beh, è ovvio che se compili i pacchetti questi verranno ottimizzati per la tua macchina ( ed andranno molto più veloci ). Se invece installi i tgz, sono programmi compilati su altre macchine e quindi non prestanti come se compilassi tu <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>questo non è strettamente corretto, dipende tutto da come sono stati impostati i C(XX)FLAGS. è ovvio che i pkg ufficiali debbano essere poco ottimizzati, dato che devono potenzialmente girare su qualsiasi macchina dai 486 in su (almeno, pat vuole così). <BR>se decidi di ricompilare vedi di impostare questi flag al meglio (usa almeno -march). <BR> <BR>quanto alle domande: <BR>1. pat (e molti con lui, me compreso) è convinto che il ramo 1 di apache sia ancora il migliore, e quella presente tra i pkg ufficiali slack è appunto l´ultima versione di questo ramo. personalmente non ho nemmeno un´idea precisa di cos´abbia in + il ramo 2, fatto sta che con l´1 non sento la mancanza di niente. comunque pkg precompilati del 2 dovresti trovarli in giro. <BR>2. l´ultima che trovi qua. mysql non ti piace? quello c´è anche ufficiale. <BR>3. dipende ancora dai C(XX)FLAGS. se non usi -march troppo spinte (ad esempio non quelle che forzano le SSE2, che sugli amd non ci sono!) non dovresti avere problemi. in ogni caso sugli amd con il -march appropriato i programmi guadagnano spesso assai. <BR>4. ah ok! 8-) <BR> <BR>solo una nota in + sui tgz precompilati: anche a me piacciono, ma proprio xké sono stati creati da chissà chi, potrebbero contenere backdoor o robe del genere, quindi meglio tenere gli occhi aperti, fidandoci solo di pat, slacky, e pochi altri! :-] <br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite