Repository 32bit  Forum
Repository 64bit  Wiki

Slackware64 e modulo iwlagn

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Slackware64 e modulo iwlagn

Messaggioda Vito » mer set 02, 2009 16:54

Segnalo che ho un problema con la scheda di rete wireless (una intel che appunto utilizza il modulo iwlagn).
La connessione spesso cade e sono costretto a riconnettermi.
L'errore è rilevabile in dmesg ed è il seguente:

Codice: Seleziona tutto
iwlagn 0000:0b:00.0: Microcode SW error detected.  Restarting 0x82000000.


Sto utilizzando il kernel 2.6.30.5 con delle ottimizzazioni fatte da me.
Il problema era presente anche col kernel 2.6.29.6 generic di Slackware64 13.0 .
Con Slackware 12.2 e con il kernel 2.6.30.5 questo problema non era presente.

Sto tentando di informarmi tramite google.

Può mai essere un bug dei driver?
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4122
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Slackware64 e modulo iwlagn

Messaggioda ponce » mer set 02, 2009 19:16

la butto li' (uso anch'io quel modulo su una 4965), col kernel 2.6.30.5 dentro testing funziona?
Avatar utente
ponce
Linux 3.x
Linux 3.x
 
Messaggi: 1458
Iscritto il: mer mar 05, 2008 16:45
Località: limbo
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.16-rc4
Desktop: lxde

Re: Slackware64 e modulo iwlagn

Messaggioda Vito » mer set 02, 2009 19:26

ponce ha scritto:la butto li' (uso anch'io quel modulo su una 4965), col kernel 2.6.30.5 dentro testing funziona?


No, almeno su quello che sto usando io non funziona..
Provo ad installare quel kernel dato che il mio è modificato.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4122
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Slackware64 e modulo iwlagn

Messaggioda Vito » mer set 02, 2009 20:35

Il problema persiste anche col kernel 2.6.30.5 generic di Slackware..
veramente ho le mani nei capelli in questo momento..
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4122
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Slackware64 e modulo iwlagn

Messaggioda ponce » mer set 02, 2009 23:56

dai un'occhiata qui (e qui).
Avatar utente
ponce
Linux 3.x
Linux 3.x
 
Messaggi: 1458
Iscritto il: mer mar 05, 2008 16:45
Località: limbo
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.16-rc4
Desktop: lxde

Re: Slackware64 e modulo iwlagn

Messaggioda Vito » gio set 03, 2009 10:34

Ho letto già il secondo link ma non mi fa fare il secondo comando
Codice: Seleziona tutto
echo 8 > /sys/bus/pci/drivers/iwlagn/0000\:06\:00.0/power_level


Mi dice che l'imput non è corretto.
Piuttosto ho notato la segnalazione del mio problema q qui e la sto segnalando, mi hanno chiesto di fornirgli ulteriori dettagli.
Quindi da quel che noto questo è una specie di bug noto agli sviluppatori dei driver intel.
Il primo link non l'ho ancora letto,
appena finisco di studiare,verso ora di pranzo, gli do un'occhiatina.
Grazie mille!
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4122
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Slackware64 e modulo iwlagn

Messaggioda Vito » gio set 03, 2009 10:59

Mi hanno chiesto di fare un call trace, qualcuno sa spiegarmi come farlo?
Grazie mille.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4122
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Slackware64 e modulo iwlagn

Messaggioda Vito » ven set 04, 2009 14:06

Ho fatto un downgrade del firmware a quello di Slackware 12.2.
Per adesso non ho problemi...
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4122
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Slackware64 e modulo iwlagn

Messaggioda m0rdr3d » lun set 07, 2009 14:32

Strano, a me la 4965 funziona molto meglio ora con la 13.0 e con il 2.6.30.5 che con la 12.2

A parte ovviamente wicd, che col le reti nascoste proprio non ce la fa...
Avatar utente
m0rdr3d
Linux 2.4
Linux 2.4
 
Messaggi: 404
Iscritto il: dom dic 24, 2006 13:40
Slackware: Slackware64-current
Kernel: 3.4.*
Desktop: KDE 4.8.2


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti