Repository 32bit  Forum
Repository 64bit  Wiki

OpenOffice [RISOLTO], wine [NON RISOLTO] bloccano X

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

OpenOffice [RISOLTO], wine [NON RISOLTO] bloccano X

Messaggioda 414N » lun set 07, 2009 12:35

Hola a todos!

Scrivo per chiedere consiglio a chi, forse, ha già affrontato questo problema e l'ha risolto.
Dunque, ho installato la Slackware64 13.0 sul mio PC dotato di Athlon 64 FX 55 e ATI Radeon X800 XT PE (AGP) e, dato che di serie c'è il kernel 2.29.6 e non m'andava di tornare almeno al 2.6.28.x solo per usare i driver proprietari di AMD (congelati per la mia scheda ai Catalyst 9.3), ho deciso di mettere alla prova i driver radeon open-source. Funzionano meglio del previsto, anche se non privi di "minor glitches", soprattutto a compositing attivato.
Tuttavia, il motivo per il quale ho aperto il thread è il seguente: ho installato OpenOffice (sia utilizzando uno SlackBuild prelevato da slackbuilds.org, sia utilizzando l'ottimo auto-builder creato da submax82) e, al momento del primo lancio di uno qualsiasi dei programmi della suite, mi appare la solita schermata di benvenuto (ho cancellato i file del vecchio profilo dalla mia home tanto per fare pulizia).
Il problema è che mi si "blocca" X: il puntatore del mouse rimane "vivo" (ma non reagisce a nessun click da nessuna parte) e non riesco a spostarmi su nessuna tty tramite CTRL+ALT+Fn.
Il sistema rimane comunque attivo, tant'è vero che riesco a loggarmi da remoto tramite ssh e, da lì, a vedere con top che X sta utilizzando il 99% di CPU. Se lancio il reset o l'halt da remoto, la schermata sul PC non cambia finché la macchina non si spegne o resetta.
Ho fatto varie prove con OpenOffice: il blocco succede indipendentemente dall'impostazione di compositing del Desktop.
Per verificare che non fosse un problema di KDE, ho avviato una sessione in TWM da KDM (sono in runlevel 4) e lanciato swriter da lì, ma si presenta lo stesso problema.
A volte il problema mi capita appena premo il tasto avanti per procedere ad inserire il mio nome e cognome, altre volte non appena compaiono le caselle di testo per inserire nome e cognome.
Non è solo OpenOffice a farmi questo scherzetto: anche alcuni giochi (con grafica 3D abbastanza moderna) che tento di fare andare con Wine causano lo stesso blocco, con la sola differenza che, trattandosi di giochi, ho modo di verificare che l'audio non si blocca.
I giochi arcade, invece, mi girano tranquillamente su SDLMame (anche uno 3D), e non mi hanno mai causato un blocco di X di questo tipo.
Per il resto, il sistema si comporta benone, andando anche più spedito di prima (Slamd64 12.2 e fglrx 9.3).
L'unico intervento che ho eseguito sulla configurazione di X che l'autorilevamento di HAL non impostava correttamente è stato l'abilitazione dell'accelerazione EXA al posto di XAA, perché nel log di Xorg compariva un messaggio riguardante il fatto che non era possibile utilizzare l'accelerazione xv se non attivando EXA.
Per completezza posto le righe aggiunte:
Codice: Seleziona tutto
Section "Device"
        Identifier      "ATI Radeon X800 XT PE"
        Driver          "radeon"
#        Option          "EnablePageFlip"        "true"
        Option          "AccelMethod"           "EXA"
EndSection

Ho provato a cambiare le impostazione di page flipping ma non ho notato alcun cambiamento.
Idee, consigli?
Ultima modifica di 414N il gio set 10, 2009 17:36, modificato 1 volta in totale.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: OpenOffice, wine bloccano X

Messaggioda ponce » lun set 07, 2009 18:49

puoi provare con la versione 9.8 dei driver proprietari, funzionano anche col 2.6.30 :)
Avatar utente
ponce
Master
Master
 
Messaggi: 1514
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.18-rc2
Desktop: lxde

Re: OpenOffice, wine bloccano X

Messaggioda Vic Steele » lun set 07, 2009 20:31

Ha una delle tante schede con i Catalyst fermi alla 9.3 .
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: OpenOffice, wine bloccano X

Messaggioda ponce » lun set 07, 2009 20:37

ah, scusa, mi era sfuggito :oops:

comunque qui, sperando ti possa servire, c'e' l'xorg.conf che metto quando uso i radeon, ma ho una HD3450: se mi ricordo bene, tranne qualche piccola correzione, l'ho generato con un "X -configure".
Avatar utente
ponce
Master
Master
 
Messaggi: 1514
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.18-rc2
Desktop: lxde

Re: OpenOffice, wine bloccano X

Messaggioda 414N » mar set 08, 2009 10:56

Ho trovato un bug report già risolto di un caso molto simile al mio e ho riaperto il bug.
Mò vediamo cosa mi dicono.
Nel frattempo, ho disattivato il DRI in xorg.conf e sono riuscito a completare la registrazione di OpenOffice (quindi OpenOffice non dovrebbe più bloccare X ora, anche se riattivo il DRI).
Resta il problema con wine, però.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: OpenOffice, wine bloccano X

Messaggioda 414N » mar set 08, 2009 16:36

Ho aperto un nuovo bug report su freedesktop.org qui segnalando il mio problema.
Ho provato ad aprire un programma della suite di openoffice, ma se non tengo il DRI disabilitato qua continua a bloccarsi tutto.
Mah...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: OpenOffice, wine bloccano X

Messaggioda 414N » mar set 08, 2009 17:43

Risolto il problema di openoffice applicando la patch (che allego) al kernel tramite
Codice: Seleziona tutto
cd /usr/src/linux
patch -p1 < radeon-dri.patch

Il problema con wine rimane, però.
Pensate sia il caso di segnalarlo a Pat?
Allegati
radeon-dri.patch.txt
Patch per il driver radeon
(1.94 KiB) Scaricato 19 volte
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite