Repository 32bit  Forum
Repository 64bit  Wiki

ancora libflashplayer

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ancora libflashplayer

Messaggioda danix » lun set 14, 2009 16:23

ciao a tutti, ho installato ieri la slackware64 13.0 e ho iniziato a metterci mano per vedere che lavoro hanno fatto gli sviluppatori... Niente da eccepire, si tratta di una gran distro.

Un po' di problemi li sto avendo solo con il flash player su firefox, ieri ho sbattuto un po' la testa per installarlo, di solito copiavo semplicemente il file libflashplayer.so nella directory /usr/lib/mozilla/plugins, questa volta invece dopo averlo messo in /usr/lib64/mozilla/plugins non lo prendeva e in about:plugins non usciva fuori nulla... ho preso allora lo slackbuild di PJV dal dvd e l'ho installato. Ha funzionato per tutto ieri, ma oggi senza aver cambiato nulla nelle pagine al posto di flash mi appare un desolante vuoto, ad esempio su youtube al posto del video mi appare uno spazio vuoto grande quanto il player... ho provato anche su altri siti e succede la stessa cosa... Invece con konqueror si vede tutto bene...

Qualcuno ha idea di cosa sia potuto succedere??


Grazie mille in anticipo per le eventuali risposte ;)
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: ancora libflashplayer

Messaggioda targzeta » lun set 14, 2009 16:42

Tanto per dire una cosa banale, ma usi il flash player a 64 bit vero? Io uso quello scaricato da qui:
http://labs.adobe.com/downloads/flashplayer10.html
Il file lo metto in
Codice: Seleziona tutto
/usr/lib64/mozilla/plugins/libflashplayer.so
e tutto funziona alla perfezione.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6189
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ancora libflashplayer

Messaggioda navajo » lun set 14, 2009 16:45

confermo.
anche io ho fatto come spina. Tutto ok
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3808
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: ancora libflashplayer

Messaggioda metrofox » lun set 14, 2009 17:34

Visto che con konqueror funziona tutto bene significa che avrà preso la versione a 64bit, del resto copia il plugin in:

Codice: Seleziona tutto
/usr/lib64/mozilla/plugins/libflashplayer.so


come ha detto spina :)
Avatar utente
metrofox
Linux 2.6
Linux 2.6
 
Messaggi: 758
Iscritto il: gio ago 07, 2008 11:29
Slackware: slackware64-current
Kernel: 3.4.4-ck3
Desktop: FluxBox-1.3.1
Distribuzione: FreeBSD-8.1(amd64)

Re: ancora libflashplayer

Messaggioda roberto67 » lun set 14, 2009 18:07

Ciao a tutti, intanto un grazie ai creatori di slacky.eu. Sono passato definitivamente a slakware da 2 mesi \:D/

anch'io uso slackware64 e ho installato il flashplayer da qui http://labs.adobe.com/downloads/flashplayer10.html. Purtroppo a volte crasha sia firefox che konqueror con un errore in nspluginviewer (vedere ad esempio questo sito www.usopen.org), tant'è che ora sto usando firefox su wine.
Nessuno ha registrato problemi? Qualche problemino è da mettere in conto essendo ancora una prerelease?
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: ancora libflashplayer

Messaggioda targzeta » lun set 14, 2009 18:58

Preciso che non faccio uso di altri plugin di supporto. In particolare nelle mie estensioni di firefox, alla voce plugin ho:
  • default plugin
  • scalable vector graphics
  • shockwave flash
  • silverlight plug-in
i primi due se non erro sono di defaul con firefox, il terzo è quello in oggetto, mentre il quarto me lo ha installato l'estensione novell moonlight, ed infatti quest'ultimo è nella mia directory ~/.mozilla/firefox.
Ho visto i video segnalati da roberto67 e non ho avuto nessun crash. Anzi, da quando ho installato anche l'estensione moonlight ormai posso navigare tranquillamente in tutto il web (almeno quello che io conosco) senza nessun problema. Solo che penso che moolight andrebbe installato come libreria sul PC senza fare uso dell'estensione per firefox, ma questa è altra storia, come direbbe Lucarelli.

Emanuele

Offtopic: Io tifo da sempre Djoković, ma quello che ha fatto Federer con la palla in mezzo alle gambe è qualcosa di strepitoso :)
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6189
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ancora libflashplayer

Messaggioda targzeta » lun set 14, 2009 19:05

Tra l'altro, se non ricordo male, nsplugin era il wrapper che serviva a far girare i plugin a 32 bit su distro a 64 bit. Visto che la versione di flash player linkata è già a 64 bit, nsplugin non dovrebbe essere più necessario, o meglio non lo è, visto che io non lo uso e funziona tutto bene.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6189
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ancora libflashplayer

Messaggioda roberto67 » lun set 14, 2009 19:54

può darsi che sia allora nspluginwrapper... sai per caso come si disintalla? da una rapida ricerca non ne ho ricavato niente...

Offtopic: Povero novak :roll:
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: ancora libflashplayer

Messaggioda metrofox » lun set 14, 2009 23:43

Altra domanda, ma hai usato qualche slackbuild oppure hai usato direttamente lo script nell'archivio del sito d'adobe? :-k
Avatar utente
metrofox
Linux 2.6
Linux 2.6
 
Messaggi: 758
Iscritto il: gio ago 07, 2008 11:29
Slackware: slackware64-current
Kernel: 3.4.4-ck3
Desktop: FluxBox-1.3.1
Distribuzione: FreeBSD-8.1(amd64)

Re: ancora libflashplayer

Messaggioda targzeta » mar set 15, 2009 5:49

roberto67 ha scritto:può darsi che sia allora nspluginwrapper... sai per caso come si disintalla? da una rapida ricerca non ne ho ricavato niente..
Ma sei sicuro di averlo installato nspluginwrapper? Perchè se ce l'hai installato è strano che tu non sappia disinstallarlo. Oltra al pacchetto nspluginwrapper dovresti aver installato anche un bel pò di librerie a 32 bit. Per capirci, ad esempio sulla Slackware64 non c'è il pacchetto, o almeno io non l'ho trovato.
Lo trovi tra i plugin di firefox?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6189
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ancora libflashplayer

Messaggioda targzeta » mar set 15, 2009 5:53

metrofox ha scritto:Altra domanda, ma hai usato qualche slackbuild oppure hai usato direttamente lo script nell'archivio del sito d'adobe? :-k
Se la domanda era riferita a me, ho un mio SlackBuild, ma non fa molto, in pratica si limita a creare la directory e copiarci dentro il file. D'altronde non c'è da compilare molto :)

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6189
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ancora libflashplayer

Messaggioda danix » mar set 15, 2009 8:56

il primo tentativo che ho fatto è stato con quello scaricabile da qui http://labs.adobe.com/downloads/flashplayer10.html, firefox non lo prendeva e allora ho usato lo slackbuild che si trova in extra/ sul dvd, ho creato il pacchetto (ma a dire il vero non ho investigato più di tanto sullo slackbuild), installato funzionava tutto perfettamente. Spento il pc e riacceso il giorno dopo non funzionava più nulla, ora ho riprovato con lo stesso plugin sempre preso da http://labs.adobe.com/downloads/flashplayer10.html, copiato nella solita directory e adesso sembra funzionare, ma a questo punto aspetterò domani per mettere il risolto :lol:

In ogni caso grazie a tutti gli intervenuti ;)
ciau...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: ancora libflashplayer

Messaggioda Blallo » mar set 15, 2009 9:00

per sicurezza linkati la libflash in /usr/lib64/firefox-3.5.2/plugins
io ho fatto così
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3241
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: ancora libflashplayer

Messaggioda roberto67 » mar set 15, 2009 13:54

spina ha scritto:Ma sei sicuro di averlo installato nspluginwrapper? Perchè se ce l'hai installato è strano che tu non sappia disinstallarlo. Oltra al pacchetto nspluginwrapper dovresti aver installato anche un bel pò di librerie a 32 bit. Per capirci, ad esempio sulla Slackware64 non c'è il pacchetto, o almeno io non l'ho trovato.Lo trovi tra i plugin di firefox? Emanuele


tra i pacchetti installati non c'è e nemmeno tra i plugin di firefox. Ma ricordo che inizialmente compariva una messaggio popup che mi dava il crash di nspluginviewer, anche con konqueror, messaggio che adesso non mi si presenta più.

comunque grazie
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti