Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Niente audio sugli speaker

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Niente audio sugli speaker

Messaggioda maso » sab ott 24, 2009 16:22

Come da topic il problema è questo: gli speaker del mio laptop sono muti con gnome.
Ma l'audio c'è e la scheda è rilevata, infatti se inserisco degli auricolari si sente tutto, e comunque su xfce ho tolto il muto dagli speaker e si sentono.
Il problema è lo stesso analizzato in QUESTO TOPIC, dove tra l'altro è stato risolto, ma lì eravamo in KDE. Vi cito il post in cui avevo risolto il problema:

maso ha scritto: :geniale: Ho risolto, Luci0 avevi ragione, era il mixer di KDE!!! Sono andato in KMixer--->mostra la finestra del mixer--->mixer--->impostazioni--->configura canali, ed ho clkkato su Speaker, così è spuntato lo speaker che era muto \:D/
YuYevon prova anche tu!!!

Grazie a tutti dell'interesse (in particolare Luci0 che ha inquadrato il problema), siete sempre disponibilissimi. Spero di poter anche a iutare io voi non appena mi inespertirò un po' :mille:


Purtroppo su gnome non c'è KMixer, ma GStreamer...non trovo un "configura canali" dove posso configurare lo speaker...che faccio??
Ultima modifica di maso il dom ott 25, 2009 10:08, modificato 1 volta in totale.
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

Re: Niente audio sugli speaker

Messaggioda phobos3576 » sab ott 24, 2009 17:14

Se l'audio c'è ma non si sente, evidentemente è impostato a zero il volume principale; dalle cuffie si sente perché in quel caso il volume credo sia fisso.

Hai provato da root ad eseguire alsamixer da un terminale?
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

[RISOLTO] Re: Niente audio sugli speaker

Messaggioda maso » dom ott 25, 2009 10:07

Ho risolto proprio con alsamixer...ho scoperto che il mixer principale di gnome (gstreamer), di xfce (xfce-mixer) ecc sono direttamente correlati ad alsamixer, infatti tenendo aperta una finestra di terminale (in cui avevo dato il comando alsamixer) e contemporaneamente xfce-mixer e abbassando il volume di xfce-mixer di abbassava anche quello di alsa-mixer e viceversa...con kde questo non succedeva: kmixer ed alsamixer erano indipendenti (mi pare) :thumbright:
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

Re: [RISOLTO] Re: Niente audio sugli speaker

Messaggioda phobos3576 » dom ott 25, 2009 18:42

maso ha scritto:Ho risolto proprio con alsamixer...ho scoperto che il mixer principale di gnome (gstreamer), di xfce (xfce-mixer) ecc sono direttamente correlati ad alsamixer, infatti tenendo aperta una finestra di terminale (in cui avevo dato il comando alsamixer) e contemporaneamente xfce-mixer e abbassando il volume di xfce-mixer di abbassava anche quello di alsa-mixer e viceversa...con kde questo non succedeva: kmixer ed alsamixer erano indipendenti (mi pare) :thumbright:


Nelle applicazioni multimediali devi impostare il mixer software; in questo modo, le applicazioni stesse possono regolare il volume indipendentemente l'una dall'altra.
Il mixer hardware, invece, agisce direttamente sulla scheda audio e le modifiche si ripercuotono su tutte le applicazioni multimediali.

P.S. Una volta che hai impostato i volumi con alsamixer, devi salvare tutto con il comando alsactl store.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3


Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 0 ospiti