Impostare codifica utf-8 alle partizioni ntfs

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Blallo
Packager
Packager
Messaggi: 3259
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox
Località: Torino / Torremaggiore (FG)
Contatta:

Impostare codifica utf-8 alle partizioni ntfs

Messaggioda Blallo » dom nov 01, 2009 19:01

Montando in automatico un HD esterno in ntfs, mi appaiono le famose lettere strane in vece delle normali accentate, poichè non lo monta con la codifica utf8
come faccio ad impostargliela?
Ultima modifica di conraid il lun nov 02, 2009 11:02, modificato 1 volta in totale.
Motivazione: almeno per i titoli stiamo attenti agli errori di battitura
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Impostare codifica utf-8 alle aprtizioni ntfs

Messaggioda phobos3576 » dom nov 01, 2009 19:34


Avatar utente
Blallo
Packager
Packager
Messaggi: 3259
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Impostare codifica utf-8 alle aprtizioni ntfs

Messaggioda Blallo » dom nov 01, 2009 23:47

come glielo imposto in fstab? Essendo un hd esterno non l'ho messo in fstab
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Impostare codifica utf-8 alle aprtizioni ntfs

Messaggioda phobos3576 » lun nov 02, 2009 0:01

jimmy_page_89 ha scritto:come glielo imposto in fstab? Essendo un hd esterno non l'ho messo in fstab


Se si tratta di un HD esterno USB, non devi impostare nulla in /etc/fstab; fa tutto in automatico NTFS-3G.

Avatar utente
Blallo
Packager
Packager
Messaggi: 3259
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Impostare codifica utf-8 alle aprtizioni ntfs

Messaggioda Blallo » lun nov 02, 2009 0:03

phobos3576 ha scritto:
jimmy_page_89 ha scritto:come glielo imposto in fstab? Essendo un hd esterno non l'ho messo in fstab


Se si tratta di un HD esterno USB, non devi impostare nulla in /etc/fstab; fa tutto in automatico NTFS-3G.

beh...è proprio quello il problema...non lo fa...cioè trova le accentazioni ma le rende con i caratteri strambi (es à diventa A con la tilde sopra)
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Impostare codifica utf-8 alle aprtizioni ntfs

Messaggioda phobos3576 » lun nov 02, 2009 0:19

Mi sembra strano.

Hai impostato it_IT.UTF-8 in quei due file e riavviato il computer?

Se c'è un qualche riferimento all'HD esterno in fstab lo devi eliminare.

Avatar utente
sardylan
Linux 2.6
Linux 2.6
Messaggi: 993
Iscritto il: mar apr 24, 2007 9:21
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.14
Distribuzione: Debian - CLFS
Località: Cagliari
Contatta:

Re: Impostare codifica utf-8 alle partizioni ntfs

Messaggioda sardylan » gio nov 05, 2009 2:27

Non consiglierei mai di usare UTF-8 su NTFS o FAT32 o FAT16... Per il semplice motivo che il FileSystem diventerebbe Case sensitive, cosa non molto gradita da Windows... A meno che NTFS-3G non abbia un modo di correggere la cosa direttamente...

Avatar utente
Blallo
Packager
Packager
Messaggi: 3259
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Impostare codifica utf-8 alle partizioni ntfs

Messaggioda Blallo » gio nov 05, 2009 11:13

niente...non funziona lo stesso
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!

Avatar utente
Blallo
Packager
Packager
Messaggi: 3259
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Impostare codifica utf-8 alle partizioni ntfs

Messaggioda Blallo » ven nov 06, 2009 15:09

non solo...non funziona più wicd!

Codice: Seleziona tutto

unknown locale: it_IT@UTF-8
Default locale unavailable, falling back to en_US
Traceback (most recent call last):
  File "/usr/lib64/wicd/wicd-client.py", line 60, in <module>
    from wicd import gui
  File "/usr/lib64/python2.6/site-packages/wicd/gui.py", line 38, in <module>
    from wicd import prefs
  File "/usr/lib64/python2.6/site-packages/wicd/prefs.py", line 42, in <module>
    from translations import language
  File "/usr/lib64/python2.6/site-packages/wicd/translations.py", line 59, in <module>
    _ = get_gettext()
  File "/usr/lib64/python2.6/site-packages/wicd/translations.py", line 50, in get_gettext
    if (lc):
UnboundLocalError: local variable 'lc' referenced before assignment
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!


Torna a “Slackware64”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti