Filezilla?

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Filezilla?

Messaggioda sunreal » mer nov 11, 2009 1:02

Ho fatto l'upgrade di filezilla con il nuovo pacchetto uscito or ora, ma una volta fatto non si avvia più il programma. Il pacchetto risulta installato, ma è scomparso dal menu applpicazioni/internet e da konsole il comando filezilla da command not found. Ho provato anche a disinstallarlo e a reinstallarlo, previo nuovo download, nulla!!!! Che ..... è successo? Aiuto, mi serve per caricare file sul mio sito ed oramai senza mi sento monco.....

PS Mi sembra un po' pochino un pacchetto della dimensione di 1,4 kb, mentre la versione per la 12.2 era di 3.6M, intano ho installato questa ultima versione (quella per la 12.2 e cioè 3.2.6.1) e funziona, in attesa di news..... Ciao.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Filezilla?

Messaggioda gohanz » mer nov 11, 2009 8:41

Hai ragione quel pacchetto non contiene niente. :-k Forse ci sara' stato quelche problema. Nei sorgenti ho notato che il tarball contiene binari pronti, mentre lo SlackBuild cerca i sorgenti per la compilazione. :-k

albatrosla
Packager
Packager
Messaggi: 1294
Iscritto il: sab mar 27, 2004 0:00
Slackware: current
Desktop: fluxbox.git
Località: Bressa - Friuli / Torino
Contatta:

Re: Filezilla?

Messaggioda albatrosla » mer nov 11, 2009 9:11

Aggiungo che non so come mai sia stato reso disponibile, visto che richiede delle gnutls di versione superiore a quelle disponibili nella slackware 13.0. Rispettando la filosofia del resto del repository, all'uscita della nuova release non era stato aggiornato a versioni più recenti, e dunque era rimasto fermo alla 3.2.6.1, almeno fino ad ora.

Avatar utente
Burroughs
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: mer dic 15, 2004 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Lago Patria (NA)
Contatta:

Re: Filezilla?

Messaggioda Burroughs » mer nov 11, 2009 9:26

albatrosla ha scritto:Aggiungo che non so come mai sia stato reso disponibile, visto che richiede delle gnutls di versione superiore a quelle disponibili nella slackware 13.0. Rispettando la filosofia del resto del repository, all'uscita della nuova release non era stato aggiornato a versioni più recenti, e dunque era rimasto fermo alla 3.2.6.1, almeno fino ad ora.

No, era stato aggiornato alla 3.2.8.1...

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

albatrosla
Packager
Packager
Messaggi: 1294
Iscritto il: sab mar 27, 2004 0:00
Slackware: current
Desktop: fluxbox.git
Località: Bressa - Friuli / Torino
Contatta:

Re: Filezilla?

Messaggioda albatrosla » mer nov 11, 2009 9:36

Quindi passando al binario con gnutls compilato staticamente?

Avatar utente
Burroughs
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: mer dic 15, 2004 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Lago Patria (NA)
Contatta:

Re: Filezilla?

Messaggioda Burroughs » mer nov 11, 2009 9:56

albatrosla ha scritto:Quindi passando al binario con gnutls compilato staticamente?

Di filezilla si erano compilati i sorgenti, mentre la versione di gnutls era quella di recente aggiornata come patch.

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Filezilla?

Messaggioda sunreal » mer nov 11, 2009 14:15

Io ieri sera (notte) ho fatto anche la prova di scaricare il contenuto della directory /src e ho fatto il pacchetto, ottenendo lo stesso risultato. Tanto per la cronaca. Ciao

Avatar utente
Burroughs
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: mer dic 15, 2004 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Lago Patria (NA)
Contatta:

Re: Filezilla?

Messaggioda Burroughs » mer nov 11, 2009 16:06

Mah, ho appena ricompilato il pacchetto (fra poco lo carico sul server FTP)...
L'errore consisteva banalmente nell'utilizzare il binario di Filezilla invece dei sorgenti.

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Filezilla?

Messaggioda phobos3576 » mer nov 11, 2009 18:33

Ho ricompilato Filezilla 3.3 da sorgente usando il vecchio SlackBuild (mettendo l'opzione set -e) e tutto sembra funzionare senza problemi; c'è solo una finestra di warning ("assert "size.x <= maxWidth" failed in WrapRecursive()") quando vado su "Modifica" - "Impostazioni".

Il problema è sempre il solito: nello SlackBuild di Slacky manca l'opzione set -e e quindi la creazione del package va a buon fine nonostante la presenza di errori; probabilmente, come segnalato da albatrosla, l'errore è legato alla versione delle gnutls.

Io le gnutls le ho aggiornate da diverso tempo visto che quelle presenti sulla 13 sono fallate; bisognerebbe segnalare questo aspetto a Pat.

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6362
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: Filezilla?

Messaggioda targzeta » mer nov 11, 2009 18:51

phobos3576 ha scritto:...
Io le gnutls le ho aggiornate da diverso tempo visto che quelle presenti sulla 13 sono fallate; bisognerebbe segnalare questo aspetto a Pat.

Non so se ti riferisci a questo, però il 17 ottobre scorso, nel ChangeLog della Slackware si legge:
n/gnutls-2.8.4-i486-1.txz: Upgraded.
This contains a correct fix for the NUL in CN/SAN SSL vulnerability.
For more information, see:
http://cve.mitre.org/cgi-bin/cvename.cg ... -2009-2730
(* Security fix *)


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

Avatar utente
Burroughs
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: mer dic 15, 2004 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Lago Patria (NA)
Contatta:

Re: Filezilla?

Messaggioda Burroughs » mer nov 11, 2009 18:58

Bah, a me, senza l'opzione set -e, la compilazione va a buon fine e non si verifica l'errore nella GUI cui accennava phobos.
Chi vuole, può controllare il pacchetto sul nostro server FTP.

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Filezilla?

Messaggioda phobos3576 » mer nov 11, 2009 22:09

Avevo aggiornato da tempo gnutls-2.8.4-i486-1 e non avevo visto l'update messo da Pat.

Comunque, prima intendevo dire che probabilmente, chi ha fatto il package di Filezilla senza l'opzione set -e, non aveva aggiornato gnutls e senza accorgersene ha ottenuto un package inutilizzabile (proprio perché l'errore non viene segnalato).

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Filezilla?

Messaggioda sunreal » gio nov 12, 2009 0:51

Comunque il pacchetto del repository è sempre quello ""sbagliato"", giusto?

Avatar utente
Burroughs
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: mer dic 15, 2004 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Lago Patria (NA)
Contatta:

Re: Filezilla?

Messaggioda Burroughs » gio nov 12, 2009 9:02

sunreal ha scritto:Comunque il pacchetto del repository è sempre quello ""sbagliato"", giusto?

Sì, finché Loris non sblocca, pubblicandolo, quello aggiornato.

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
Loris
Admin
Admin
Messaggi: 7666
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5
Località: Gradisca D'Isonzo
Contatta:

Re: Filezilla?

Messaggioda Loris » gio nov 12, 2009 13:45

Se riesco lo faccio questa sera... sono, e sarò senza ADSL fino a fine Dicembre #-o
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite