Repository 32bit  Forum
Repository 64bit  Wiki

Non si spegne il portatile

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 15:41

Ho un acer extensa, slackware 13 64bit, kernel come da profilo
quando spengo il computer il sistema spegne il monitor ma non si spegne del tutto, resta la luce di accensione attiva e devo forzare lo spegnimento premendo per 5 sec il tasto di accensione
Può essere un problema di mancato/errato smontaggio della partizione di root? perchè tale errore non lo fa con il kernel di default della Slackware, ma dal ramo 2.6.31 in poi, anche a parità di .config, lo fa
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda shock » ven nov 20, 2009 15:45

Ciao, potresti essere piu chiaro? Usi la shell per spegnerlo? oppure da X stesso?

Se usi la shell...io ho sempre usato "shutdown -h now" all'inizio, quando non mi partiva ancora X
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 15:50

uso xfce, e lo spengo dall'interfaccia
ma sia con pressione diretta del tasto che con shutdown -h now niente :(
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda shock » ven nov 20, 2009 15:57

Sarebbe d'aiuto che descrivessi per bene il tutto...cioe passo passo cosa fai.

Non ti esce alcun messaggio d'errore?

Si spegne solo e direttamente lo schermo?
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 16:03

si, solo lo schermo e non appare nulla...
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda shock » ven nov 20, 2009 16:05

Ma questo problema telo sta dando solo ora? Cosa hai fatto prima che cio accadesse?
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Messaggioda Akito » ven nov 20, 2009 16:11

Offtopic: Curiosità mia:
ho un Acer Extensa 5635Z; premesso che non ho problemi con lo spegnimento (anche se una volta l'ho trovato bloccato dopo che aveva smontato la root) volevo chiederti se riesci ad usare il cpu scaling. Questi sono i moduli che trovo all'avvio:

Codice: Seleziona tutto
root@data:~# lsmod | grep cpu
cpufreq_ondemand        7400  0
freq_table              3804  1 cpufreq_ondemand
root@data:~# lsmod | grep processor
processor              35884  2
thermal_sys            16068  3 video,processor,thermal
root@data:~# lsmod | grep speed
speedstep_lib           3968  0



Ed ecco cosa ottengo se provo con:
Codice: Seleziona tutto
root@data:~# modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.31.5-1ab/kernel/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device


Ecco le caratteristiche del processore, l'ultima riga vuota è inquietante
Codice: Seleziona tutto
                                                                                           
root@data:~# cat /proc/cpuinfo                                                                                                 
processor       : 0                                                                                                           
vendor_id       : GenuineIntel                                                                                                 
cpu family      : 6                                                                                                           
model           : 23                                                                                                           
model name      : Pentium(R) Dual-Core CPU       T4300  @ 2.10GHz                                                             
stepping        : 10                                                                                                           
cpu MHz         : 2094.815                                                                                                     
cache size      : 1024 KB                                                                                                     
physical id     : 0                                                                                                           
siblings        : 2                                                                                                           
core id         : 0                                                                                                           
cpu cores       : 2                                                                                                           
apicid          : 0                                                                                                           
initial apicid  : 0                                                                                                           
fdiv_bug        : no                                                                                                           
hlt_bug         : no                                                                                                           
f00f_bug        : no                                                                                                           
coma_bug        : no                                                                                                           
fpu             : yes                                                                                                         
fpu_exception   : yes                                                                                                         
cpuid level     : 13                                                                                                           
wp              : yes                                                                                                         
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm       
bogomips        : 4189.63                                                                                                     
clflush size    : 64                                                                                                           
power management:                                                                                                             

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Pentium(R) Dual-Core CPU       T4300  @ 2.10GHz
stepping        : 10
cpu MHz         : 2094.815
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm
bogomips        : 4189.30
clflush size    : 64
power management:
:

La cosa mi interessa perché ho la ventola che si accende ogni 1-2 minuti facendo un discreto rumore. La temperatura che leggo in /proc/acpi è di circa 41-42 gradi, appena supera i 42 parte la ventola. Sto cercando di capire se posso intervenire sulla ventola stessa (insomma la cpu non è al 100% e nemmeno è troppo calda, basterebbe che la ventola si azionasse sui 50 gradi.
Akito
Linux 2.4
Linux 2.4
 
Messaggi: 285
Iscritto il: dom set 03, 2006 12:12
Località: Limite sull'Arno (FI)
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE

Re: Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 16:49

Fino alla serie 2.6.30.X del kernel funziona alla perfezione, dalla 2.6.31 non si spegne più per bene
Ho usato il config di Pat senza modifiche per testare e presenta il problema comunque
Offtopic: Hai il kernel di deafult o ricompilato?
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda Akito » ven nov 20, 2009 17:39

Offtopic: 2.6.31.6 ricompilato con config di Slackware 13.0, ho aggiunto solo ext4/ext3 statico e scelto come processore Core2/ecc...
Quello di default mi manda in tilt la scheda di rete che compare/scompare da lspci e non funziona.
Akito
Linux 2.4
Linux 2.4
 
Messaggi: 285
Iscritto il: dom set 03, 2006 12:12
Località: Limite sull'Arno (FI)
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE

Re: Non si spegne il portatile

Messaggioda phobos3576 » ven nov 20, 2009 18:38

Jimmy_page_89, controlla nel configure la sezione ACPI e assicurati che sia abilitato (y) CONFIG_ACPI_BUTTON.

Questi problemi dipendono sicuramente dalla configurazione dell'ACPI.

CONFIG_ACPI_BUTTON

This driver handles events on the power, sleep and lid buttons. A daemon reads /proc/acpi/event and perform user-defined actions such as shutting down the system. This is necessary for software controlled poweroff.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Non si spegne il portatile

Messaggioda Akito » ven nov 20, 2009 18:51

Offtopic: Un'ultima richiesta e poi valuto se aprire una discussione a parte:
potresti riportare il tuo /proc/cpuinfo se hai un processore simile al mio??

Grazie
Akito
Linux 2.4
Linux 2.4
 
Messaggi: 285
Iscritto il: dom set 03, 2006 12:12
Località: Limite sull'Arno (FI)
Nome Cognome: Alessandro Bianconi
Slackware: 13.1
Desktop: XFCE

Re: Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 20:03

Offtopic:
Codice: Seleziona tutto
processor   : 0
vendor_id   : GenuineIntel
cpu family   : 6
model      : 15
model name   : Intel(R) Pentium(R) Dual  CPU  T2330  @ 1.60GHz
stepping   : 13
cpu MHz      : 1600.000
cache size   : 1024 KB
physical id   : 0
siblings   : 2
core id      : 0
cpu cores   : 2
apicid      : 0
initial apicid   : 0
fpu      : yes
fpu_exception   : yes
cpuid level   : 10
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips   : 3192.55
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family   : 6
model      : 15
model name   : Intel(R) Pentium(R) Dual  CPU  T2330  @ 1.60GHz
stepping   : 13
cpu MHz      : 1600.000
cache size   : 1024 KB
physical id   : 0
siblings   : 2
core id      : 1
cpu cores   : 2
apicid      : 1
initial apicid   : 1
fpu      : yes
fpu_exception   : yes
cpuid level   : 10
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips   : 3192.22
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 20:04

@phobos3576
effettivamente è come modulo e non statico
proverò a ricompilare e vedrò se da risultati (speriamo [-o< )
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda Mario Vanoni » ven nov 20, 2009 21:26

Misteri dell'informatica!

Ho due desktop con
- HW identica, stessa data d'acquisto
- SW identica, vedi profilo
- ambedue su una sola UPS
- stesso tempo di accensione/spegnimento

Unica differenza:
- macchina 1 collegamento USB alla UPS, molto attiva/usata
- macchina 2 collegamento ethernet alla UPS via macchina 1, spesso idle

Regola da mesi facendo "halt"
- macchina 1 si spegne lo schermo e la macchina
- macchina 2 si spegne lo schermo, ma non la macchina
ultima ratio, pigiare per 4 secondi l'interruttore e si spegne

Notato che succede dai kernel 2.6.31 ...
Mario Vanoni
Iper Master
Iper Master
 
Messaggi: 3174
Iscritto il: lun set 03, 2007 20:20
Località: Cuasso al Monte (VA)
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey

Re: Non si spegne il portatile

Messaggioda phobos3576 » ven nov 20, 2009 22:18

Mario Vanoni ha scritto:Regola da mesi facendo "halt"
- macchina 1 si spegne lo schermo e la macchina
- macchina 2 si spegne lo schermo, ma non la macchina
ultima ratio, pigiare per 4 secondi l'interruttore e si spegne

Notato che succede dai kernel 2.6.31 ...

Controlla se le due macchine hanno anche la stessa versione del BIOS.
Gli ultimi kernel hanno posto fine alla compatibilità con i BIOS meno recenti.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Prossimo

Torna a Laptop

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite