Repository 32bit  Forum
Repository 64bit  Wiki

Non si spegne il portatile

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Non si spegne il portatile

Messaggioda Blallo » ven nov 20, 2009 22:39

forse dovrei upgradare il bios, ma aggioranre il bios per un semplice spegnimento...
è un'operazione che non farei proprio volentieri... :(
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3213
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda phobos3576 » sab nov 21, 2009 0:18

Ma scusa, che bisogno hai di usare il 2.6.32 rc5?

Potresti fare un downgrade al 2.6.30.

In alternativa, prova ad aggiungere "force-acpi" nelle opzioni di Lilo:
Codice: Seleziona tutto
append="acpi=force"

Quella opzione è necessaria per i vecchi BIOS.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Non si spegne il portatile

Messaggioda Blallo » sab nov 21, 2009 0:21

la cosa non cambia
ho un 2.6.31.6 e fa lo stesso problema
ma devo ancora ricompilare il kernel (non l'ho fatto causa consulenza sul C :D ) quindi è presto per trarre conclusioni...
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3213
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Non si spegne il portatile

Messaggioda Mario Vanoni » sab nov 21, 2009 10:42

phobos3576 ha scritto:
Mario Vanoni ha scritto:Regola da mesi facendo "halt"
- macchina 1 si spegne lo schermo e la macchina
- macchina 2 si spegne lo schermo, ma non la macchina
ultima ratio, pigiare per 4 secondi l'interruttore e si spegne

Notato che succede dai kernel 2.6.31 ...

Controlla se le due macchine hanno anche la stessa versione del BIOS.
Gli ultimi kernel hanno posto fine alla compatibilità con i BIOS meno recenti.


Grazie, i BIOS (Intel) sono identici, ma del 2006.
Ma mi hai ricordato i problemi con lm-sensors sulla macchina 3,

viewtopic.php?f=2&t=30227

Aggiungendo in lilo
append=" vt.default_utf8=1 acpi_enforce_resources=no"
sulle macchine 1 e 2, "halt" ora funziona perfettamente,
sulla macchina 3 con lo stesso kernel da un mese fa`.
Mario Vanoni
Iper Master
Iper Master
 
Messaggi: 3174
Iscritto il: lun set 03, 2007 20:20
Località: Cuasso al Monte (VA)
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey

Precedente

Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite