Repository 32bit  Forum
Repository 64bit  Wiki

Problema iPod 4a generazione

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema iPod 4a generazione

Messaggioda Super_Ale46 » sab dic 05, 2009 19:32

Salve a tutti, ho un problema con il mio ipod nano 8gb 4a generazione.
slack mi riconosce la periferica, me la mostra e mi mostra anche il contenuto...ma quando provo ad avviare gtkpod, mi da un errore nel caricamento del database.
Qualcuno saprebbe aiutarmi?
grazie anticipatamente per eventuali risposte
Super_Ale46
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: sab nov 15, 2008 22:17
Nome Cognome: Alessandro
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde 3.5.9

Re: Problema iPod 4a generazione

Messaggioda JohnnyMnemonic » sab dic 05, 2009 19:39

Super_Ale46 ha scritto:...ma quando provo ad avviare gtkpod, mi da un errore nel caricamento del database.


Ehm... che errore?
Avatar utente
JohnnyMnemonic
Staff
Staff
 
Messaggi: 2733
Iscritto il: sab set 04, 2004 23:00
Località: Bologna
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos

Re: Problema iPod 4a generazione

Messaggioda Super_Ale46 » sab dic 05, 2009 20:12

Allora con precisione mi dice:

Extended info will not be used.
iPod Database import Failed:
'illegal seek to offset 0 (length 4)
in file '/media/ipod/iPod_Control/iTunes/iTunesDB'.'
Super_Ale46
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: sab nov 15, 2008 22:17
Nome Cognome: Alessandro
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde 3.5.9

Re: Problema iPod 4a generazione

Messaggioda stan » sab dic 05, 2009 20:35

Avatar utente
stan
Linux 2.6
Linux 2.6
 
Messaggi: 524
Iscritto il: lun dic 25, 2006 11:55
Località: Bs
Slackware: 12.1
Kernel: 2.6.xx
Desktop: Kde3

Re: Problema iPod 4a generazione

Messaggioda Super_Ale46 » sab dic 05, 2009 22:16

Avevo cercato su google ma senza risultati.. nonostante non ho molta confidenza con l'inglese... (lo mastico pochissimo),
ho capito che devo intallare gnupod...ora pero' mi sorge una domanda...come lo installo?
Vado sul sito ufficiale scarico i sorgenti, apro il readme e mi dice di eseguire i seguenti comandi:
./configure
./make install

Ora pero' mi sorge un' altra domanda.. ma se non c'e' il file configure... cosa lancio?
ho anche provato a lanciare il file confiugure.ac all'interno del tar.gz... ma non risolvo nulla....qualcuno sa come fare?
grazie anticipatamente.

P.S. Ho provato anche installando la versione gnupod per slackware 12.2 ma nulla da fare...
Super_Ale46
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: sab nov 15, 2008 22:17
Nome Cognome: Alessandro
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde 3.5.9

Re: Problema iPod 4a generazione

Messaggioda stan » dom dic 06, 2009 9:29

Io mi riferivo al post di ~Cristopher. Dice di provare a cliccare "check ipod's files" nel menu music, lasciarlo elaborare (dura molto), chiudere gtkpod, riaprirlo e poi selezionare "read".
Non ho un ipod quindi non ho provato. comunque eventualmente traduci il link tramite il traduttore di google.
Avatar utente
stan
Linux 2.6
Linux 2.6
 
Messaggi: 524
Iscritto il: lun dic 25, 2006 11:55
Località: Bs
Slackware: 12.1
Kernel: 2.6.xx
Desktop: Kde3

Re: Problema iPod 4a generazione

Messaggioda manublade » dom dic 06, 2009 11:32

http://gtkpod.wikispaces.com/Sysinfo+File

so che non capisci l'inglese... ma è il massimo che posso fare.... :-) come ti è stato detto prova con traduttori on-line (tipo google)
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21

Re: Problema iPod 4a generazione

Messaggioda Super_Ale46 » dom dic 06, 2009 15:10

Eccomi qui... allora in realta' il problema era che il database scritto do windows, non veniva "capito", dai programmi per linux...
in compenso ho sfruttato un programma per la gestione degl' ipod (floola), per riparare il dispositivo... ovvero credo che sia piu o meno una formattazione una volta formattato l' ipod potevo vederlo con gtkpod, atualmente sto trasferendo dei file non so se funziona perfettamente.
Anche se da quello che ho capito non e' una vera e propria formattazione perche' i file mi sa che rimangono all'interno dell ipod, quelli inseriti da windows intendo.
Vi aggiorno appena ho terminato la sincronizzazione.
Super_Ale46
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: sab nov 15, 2008 22:17
Nome Cognome: Alessandro
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde 3.5.9

Re: Problema iPod 4a generazione

Messaggioda Super_Ale46 » dom dic 06, 2009 18:42

Allora adesso mi fa il trasferimento dei file.-...ma c'e' un problema... li trasferisce ma aquando scollego l'ipod... i file nell' ipod non ci sono...
Qualc' uno che m'illumini!?
Super_Ale46
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: sab nov 15, 2008 22:17
Nome Cognome: Alessandro
Slackware: 12.1
Kernel: 2.6.24.5-smp
Desktop: kde 3.5.9

Re: Problema iPod 4a generazione

Messaggioda manublade » dom dic 06, 2009 18:58

Il fatto è che la libreria delli'ipod è criptata. Devi quindi seguire quanto ti ho indicato nel mio precedente post (creare il file Sysinfo) e poi anche il SysinfoExtended, come descritto nella sezione "The Classic and Nano3g".
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21


Torna a Hardware

Chi c’è in linea

Visitano il forum: Majestic-12 [Bot] e 1 ospite