Repository 32bit  Forum
Repository 64bit  Wiki

Problemi con Arduiino su Slackware64-13.0 [risolto]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi con Arduiino su Slackware64-13.0 [risolto]

Messaggioda Simoleso » dom dic 06, 2009 15:55

Ciao a tutti,
ho cercato di installare Arduino su Slackware 13.0 a 64BIT. Purtroppo il risultato è questo:
Codice: Seleziona tutto
]eso@alnitak ~/arduino-0017 $ ./arduino
java.lang.UnsatisfiedLinkError: /home/leso/arduino-0017/lib/librxtxSerial.so: /home/leso/arduino-0017/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch) thrown while loading gnu.io.RXTXCommDriver
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/leso/arduino-0017/lib/librxtxSerial.so: /home/leso/arduino-0017/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(Unknown Source)
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
        at processing.app.Editor.populateSerialMenu(Editor.java:911)
        at processing.app.Editor.buildToolsMenu(Editor.java:641)
        at processing.app.Editor.buildMenuBar(Editor.java:434)
        at processing.app.Editor.<init>(Editor.java:181)
        at processing.app.Base.handleOpen(Base.java:739)
        at processing.app.Base.handleOpen(Base.java:709)
        at processing.app.Base.handleNew(Base.java:606)
        at processing.app.Base.<init>(Base.java:346)
        at processing.app.Base.main(Base.java:239)

Ho provato a cercare la libreria librxtx-java come suggerito qui:
http://www.arduino.cc/playground/Learning/Linux
ma non sono riuscito a trovare nulla.

Qualcuno è riuscito a far andare l'IDE di Arduino su Slackware64?

Grazie per l'attenzione,
Simoleso
---
Mess with the best, die like the rest.
Ultima modifica di Simoleso il mar dic 08, 2009 1:34, modificato 1 volta in totale.
Avatar utente
Simoleso
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: sab dic 11, 2004 0:00
Slackware: 13.0 64Bit
Kernel: 2.6.26.9
Desktop: KDE

Re: Problemi con Arduiino su Slackware64-13.0

Messaggioda 414N » dom dic 06, 2009 16:42

Ma hai provato ad estrarre il file librxtxSerial.so (la librerie a 64 bit sotto la directory x86_64-unknown-linux-gnu) contenuta nel file inidicato su quella pagina ( rxtx-2.2pre2-bins.zip) all'interno della directory /home/leso/arduino-0017/lib/ ?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problemi con Arduiino su Slackware64-13.0

Messaggioda Simoleso » lun dic 07, 2009 9:53

414N ha scritto:Ma hai provato ad estrarre il file librxtxSerial.so (la librerie a 64 bit sotto la directory x86_64-unknown-linux-gnu) contenuta nel file inidicato su quella pagina ( rxtx-2.2pre2-bins.zip) all'interno della directory /home/leso/arduino-0017/lib/ ?

gh
Che superniubbo che sono, in effetti adesso l'IDE parte solo che ho un problema con avr-gcc, devo ricompilarlo.
Una domanda, ho seguito un howto per aggiungere librerei a 32 bit, visto che arduino è precompilato a 32 bit, sarà necessario compilare avr-gcc a 32 bit pure lui? Oppure vado liscio a 64? :oops:

Simoleso
Avatar utente
Simoleso
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: sab dic 11, 2004 0:00
Slackware: 13.0 64Bit
Kernel: 2.6.26.9
Desktop: KDE

Re: Problemi con Arduiino su Slackware64-13.0 [risolto]

Messaggioda Simoleso » mar dic 08, 2009 1:34

Bene, ho risolto: ho seguito questo howto
http://www.arduino.cc/playground/Linux/Slackware
modificando però la variabile PREFIX in
Codice: Seleziona tutto
export PREFIX=/usr/local/avr

exportando presso l'utente (non root) il percorso /usr/local/avr/bin l'IDE di Arduino compila correttamente il codice.

Simone
Avatar utente
Simoleso
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: sab dic 11, 2004 0:00
Slackware: 13.0 64Bit
Kernel: 2.6.26.9
Desktop: KDE

Re: Problemi con Arduiino su Slackware64-13.0 [risolto]

Messaggioda Simoleso » mar dic 08, 2009 20:36

Aggiungo inoltre che per permettere ad Arduino di programmare correttamente la schedina DUEMILANOVE si devono aggiungere questi due passi:

Leso
Avatar utente
Simoleso
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: sab dic 11, 2004 0:00
Slackware: 13.0 64Bit
Kernel: 2.6.26.9
Desktop: KDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 1 ospite