Repository 32bit  Forum
Repository 64bit  Wiki

Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda jena » gio feb 11, 2010 0:32

Ciao a tutti!!!
Vorrei chiedervi un consiglio su una stampante multifunzione che vorrei comprare...
Sono indeciso tra queste hp e canon :
http://www.epto.it/hp-hewlett-packard-h ... 8433B.html
http://www.epto.it/canon-pixma-mp270-p-3744B009.html
La canon pixma mp270 è compatibile...i driver sono disponibili dal sito http://software.canon-europe.com/products/0010753.asp
Mentre io vorrei prendere l'hp photosmart Q8433B però non trovato la compatibilità su openprinting ma se cerco i driver dal sito dell'hp vengo portato su hplip http://hplipopensource.com/hplip-web/index.html

Qualcuno ha mai usato questa stampante o ha mai usato hplip?Credete che sia compatibile?
Quale mi consigliate di prendere?
Grazie!!!
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda odiusseus » gio feb 11, 2010 0:47

sulla hp vai tranquillo..vedi questo sito..è molto affidabile..vendono solo roba GNU/Linux e compatibili
http://shop.mambasoft.it/stampanti-e-multifunzione/inkjet?price=2%2C50&manufacturer=50
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda jena » gio feb 11, 2010 12:42

Sembra compatibile...è presente a questa pagina...http://shop.mambasoft.it/hp-photosmart- ... 4-pcs.html
Grazie mille!!!
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda odiusseus » gio feb 11, 2010 12:47

non c'è di che..
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda jena » mer mar 03, 2010 1:51

Ciao a tutti!!!
Ho provato ad installare la stampante multifunzione hp q8433b con l'ultima versione di hplip-3.10.2
Dopo aver avviato hp-setup ho selezionato usb come interfaccia ma nella gui ricevo l'errore no device found e nella shell che rimane aperta ricevo lo stesso errore scritto in rosso:
Codice: Seleziona tutto
HP Linux Imaging and Printing System (ver. 3.10.2)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

Allora ho deciso di installarla tramite cupsd e sembra funzionare...
Questo potrebbe essere dovuto al fatto che il supporto non è ancora stato aggiunto in hplip?
Vorrei chiedervi quale differenza c'è tra hplip e cupsd...cioè hplip è uno strumento sviluppato da hp che mi avrebbe permesso di utilizzare anche lo scanner integrato mentra cupsd mi permette soltanto di utilizzare la stampante?
Quale conviene utilizzare hplip o cupsd?
Grazie!!!
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda cyme » mer mar 03, 2010 9:59

Anch'io ho avuto qualche problema installando una inkjet usb:
hplip non la vedeva, cups stampava ma con delle riserve (stampa solo a colori, blocco della stampante alla modifica di alcuni settaggi...)
Se non ricordo male, ho risolto aggiungendo il mio utente al gruppo "lp" e hplip ora funziona perfettamente.
Ciao
cyme
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: mar nov 08, 2005 22:33
Slackware: 64current
Kernel: 2.6.32.7
Desktop: Kde

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda jena » mer mar 03, 2010 16:32

Grazie mille della risposta!!!
Ho aggiunto l'utente al gruppo lp con il comanda gpasswd e controllando il file /etc/group l'utente è presente:
Codice: Seleziona tutto
lp:x:7:nome utente

Ho dato il comando hp-check e alla fine ricevo un messaggio di errore dove la stampante viene rilevata ma mi dice unsupported model:
Codice: Seleziona tutto
----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0x7a11 at 001:007:
    Device URI: hp:/usb/Photosmart_B109a-m?serial=CN998000000000
error: Unsupported model: Photosmart_B109a-m

Sembra che il modello non è ancora supportato...cosa ne pensate?
Inoltre hp-check alla voce installed cups printers queues dice:
Codice: Seleziona tutto
---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
hpq8433b
--------
Type: Unknown
Device URI: usb://HP/Photosmart%20B109a-m?serial=CN998000000000
PPD: /etc/cups/ppd/hpq8433b.ppd                               
PPD Description: HP Photosmart b109a Series, hpcups 3.10.2     
Printer status: la stampante hpq8433b è in attesa.  Abilitata da mer 03 mar 2010 16:24:02 CET
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.

Non capisco cosa significa l'ultima frase ''warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.''
Ho sbagliato qualcosa durante l'installazione con cupsd?
Grazie!!!
Ultima modifica di jena il gio mar 04, 2010 20:05, modificato 2 volte in totale.
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda cyme » mer mar 03, 2010 20:26

Spulciando qui sul forum ho trovato questo.
Può essere che l'installazione della stampante sotto cups non piaccia a HPLIP, infatti secondo quanto ti dice il warning
dovresti accedere alla stampante con "hp://..." o "hpfax://..." mentre il tuo Device Uri è "usb://..."
Prova a rimuovere la stampante da cups e a ripetere hp-setup, come indicato nel post che ho segnalato.
Da quello che ho visto sul sito degli HPLIP, se non ho sbagliato il modello, la tua stampante dovrebbe essere
pienamente supportata.
Ciao!
cyme
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: mar nov 08, 2005 22:33
Slackware: 64current
Kernel: 2.6.32.7
Desktop: Kde

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda jena » gio mar 04, 2010 20:26

Grazie dell'aiuto!!!
Ho seguito il tuo consiglio e ho eliminato tutte le stampanti da cups poi ho rieseguito hp-setup e dando hp-check la sezione di cups dice:
Codice: Seleziona tutto
---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
lpstat
------
Type: Unknown
Device URI: No destinations added.

Mentre la sezione usb dice:
Codice: Seleziona tutto
-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0x7a11 at 001:004:
    Device URI: hp:/usb/Photosmart_B109a-m?serial=CN998000000000
error: Unsupported model: Photosmart_B109a-m

---------------
| USER GROUPS |
---------------

alex adm lp dialout cdrom plugdev lpadmin admin sambashare


-----------
| SUMMARY |
-----------

No errors or warnings.

Quindi continua a dirmi che il modello non è supportato...e ricevo la notifica anche dell'hplip status service in basso a destra Immagine
Ma non è cosi infatti è come dicevi tu...il mio modello cioè il b109a-m secondo il sito hplip è pienamente supportato http://hplipopensource.com/hplip-web/mo ... eries.html
Dopo l'hp-check che ho riportato si è aperta questa finestra...Immagine
La frase finale che dice:
Note: only device installed with hp: or hpfax: cups backend will appera in the hp device manager

Cioè solo le stampanti installate con backedn di cupd hp: o hpfax: appariranno nell'hp device manager...giusto?
Allora ho installato la stampante tramite cups scegliendo manualmente l'url del dispositivo Immagine
Ma ricevo sempre lo stesso errore...il problema è qui:
Codice: Seleziona tutto
-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0x7a11 at 001:004:
    Device URI: hp:/usb/Photosmart_B109a-m?serial=CN998000000000
error: Unsupported model: Photosmart_B109a-m

Non capisco se è un problema di permessi oppure se la stampante viene mappata in maniera sbagliata...
Che cosa ne pensi?
Grazie!!!
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda cyme » gio mar 04, 2010 21:26

Da quello che posso vedere la procedura che hai seguito sembra corretta, ho verificato sulla
mia installazione e anch'io ho un dispositivo sotto cups con Device Uri hp:/usb/...

Ho provato a verificare con hp-check, ma purtroppo non ho la sezione "Usb I/O Setup"
(sto usando gli hplip-3.9.12 , probabilmente è per quello o perchè al momento non ho la
stampante collegata...)

Per quanto riguarda i permessi, i gruppi che credo interessati dovrebbero essere lp e plugdev e ci sono anche da te...

Spero che altri possano darti qualche suggerimento, comincio a essere a corto di idee... :(

PS: non è strano che indichi
Codice: Seleziona tutto
-----------
| SUMMARY |
-----------

No errors or warnings.

quando poche righe prima hai
Codice: Seleziona tutto
error: Unsupported model: Photosmart_B109a-m

:?: :-k
cyme
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: mar nov 08, 2005 22:33
Slackware: 64current
Kernel: 2.6.32.7
Desktop: Kde

Re: Consiglio stampante hp photosmart Q8433B o canon pixma mp270

Messaggioda jena » ven mar 05, 2010 18:06

Speriamo che qualcuno possa darmi qualche consiglio...
Io ho provato ad installarla su debian e dopo aver installato solo alcune dipendenze...ho installato l'ultima versione di hplip ma sembra che anche qui la stampante non venga riconosciuta...
Questo è hp-check:
Codice: Seleziona tutto
HP Linux Imaging and Printing System (ver. 3.10.2)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Saving output in log file: hp-check.log

Initializing. Please wait...
 
---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux debian 2.6.26-2-686 #1 SMP Sat Dec 26 09:01:51 UTC 2009 i686 GNU/Linux

Distribution:
debian 5.0.4

Checking Python version...
OK, version 2.5.2 installed

Checking PyQt 4.x version...
OK, version 4.4.2 installed.

Checking for CUPS...
Status: la stampa programmata è in esecuzione
Version: 1.3.8
error_log is set to level: warn

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.82.4


------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
OK, found.

Checking for dependency: CUPS image - CUPS image development files...
OK, found.

Checking for dependency: DBus - Message bus system...
OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency: libjpeg - JPEG library...
OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
OK, found.

Checking for dependency: libusb - USB library...
OK, found.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python devel - Python development files...
OK, found.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
OK, found.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.


----------------------
| HPLIP INSTALLATION |
----------------------


Currently installed HPLIP version...
HPLIP 3.10.2 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.10.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.10.2
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=no
cups-drv-install=no
cups-ppd-install=no
internal-tag=3.10.2rc1.9
restricted-build=no
ui-toolkit=no
qt3=no
qt4=no
policy-kit=no
hpijs-only-build=no
lite-build=no
udev-acl-rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
# hplip.state - HPLIP runtime persistent variables.

[plugin]
installed=0
eula=0



Current contents of '~/.hplip/hplip.conf' file:
[installation]
version = 2.8.6.20b
date_time = 03/05/10 16:53:30



--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Photosmart_B109a-m
------------------
Type: Unknown
Device URI: usb://HP/Photosmart%20B109a-m?serial=CN998750W905C7
PPD: /etc/cups/ppd/Photosmart_B109a-m.ppd
PPD Description: HP Photosmart b109a Series hpijs, 3.10.2rc1.9
Printer Filter "foomatic-rip-hplip" for printer "Photosmart_B109a-m" not available: No such file or directory
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.


----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...
 
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.


 
-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0x7a11 at 001:002:
    Device URI: hp:/usb/Photosmart_B109a-m?serial=CN99000000000
error: Unsupported model: Photosmart_B109a-m

---------------
| USER GROUPS |
---------------

root


-----------
| SUMMARY |
-----------

error: 4 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html


Done.

Ci sono 4 errori di cui 3 sono di dipendenze mancanti che non sono riuscito a trovare...sono linbetsnmp-devel policykit e pyqt 4 dbus...sapete in quali pacchetti sono contenuti?
Però alla fine cè sempre il solito errore...error: Unsupported model: Photosmart_B109a-m ma non riesco a capire se è dovuto alle dipendenze mancanti oppure perchè la stampante non è supportata...
Qualche consiglio?
Grazie!!!
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma m

Messaggioda jena » lun mar 29, 2010 16:15

Ho aperto un bug su hplip https://bugs.launchpad.net/hplip/+bug/535056
Questo sembra risolvere:
Open /usr/share/hplip/data/models/models.dat as root(sudo)
replace photosmart_b109a_series with photosmart_b109a-m
jena
Linux 2.0
Linux 2.0
 
Messaggi: 130
Iscritto il: gio gen 03, 2008 17:02

Re: Consiglio stampante hp photosmart Q8433B o canon pixma m

Messaggioda navajo » lun mar 29, 2010 20:07

prova a installare la stampante da riga di comando con
Codice: Seleziona tutto
# hp-setup -i

vedi che ti dice
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3780
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite