Repository 32bit  Forum
Repository 64bit  Wiki

Problema GNOME Login

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema GNOME Login

Messaggioda dexter » mer mar 24, 2010 15:59

Dopo aver installato di nuovo slack 12.2 con gnome 2.26.3 (per problemi con la 13) quando vado ad effettuare il login all'inizio si vede che il sistema comincia a caricare tutti i componenti poi mi redirige all'area di login.

Avete idea di che cosa possa essere?

Slack 12.2 vergine, l'utente sta nei gruppi consigliati da gslacky in fase di installazione e anche in altri come: audio, video, wheel, power, ecc
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda gohanz » mer mar 24, 2010 20:00

Quando esegui startx ti segnala la mancanza di qualche libreria? Questo sempre se avvii in init3. In ogni caso controlla l'md5 dell'iso e prova anche a riavviare il sistema. Spero inoltre che l'installazione della 13 sia completa.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Problema GNOME Login

Messaggioda dexter » mer mar 24, 2010 22:25

Sono in init 4, comunque ho provato anche da init 3 ma non mi segnala niente. comunque utilizzo la 12.2 e si ho fatto l'installazione full
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda dexter » mer mar 24, 2010 23:26

anche l'md5 sulla iso è corretto
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda gohanz » gio mar 25, 2010 8:49

Hai usato install.sh per effettuare l'installazione? Hai controllato lo spazio libero del disco rigido?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Problema GNOME Login

Messaggioda dexter » gio mar 25, 2010 9:33

si ho utilizzato l'install.sh, comunque di spazio ce ne parecchio ho un harddisk da 100 giga la partizione è da 70 giga. Ho fatto un'installazione formattando questa partizione. Quindi non credo proprio che sia un problema di spazio.
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda dexter » gio mar 25, 2010 10:14

Non so come sia successo ma adesso funziona. Gnome parte senza problemi.
L'unica cosa che ho fatto è installare i driver ati dal file.run. Facendo l'installazione però non è stato abiliata l'accellerazione 3d. infatti se faccio modprobe fglrx non trova il modulo. Non capisco perchè non lo trova. Ho eseguito il file .run poi ho modificato xorg.conf aggiungendo section dri. Ma non trova il modulo. Ho sbagliato qualcosa?
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda dexter » gio mar 25, 2010 11:30

Il mio xorg.conf

Codice: Seleziona tutto
Section "ServerLayout"

# The Identifier line must be present
# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens.  The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen.  In this example, screen 2 is located to the
# right of screen 1.
# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used.  Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".
   Identifier     "Simple Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
   InputDevice    "Mouse1" "CorePointer"
   InputDevice    "Keyboard1" "CoreKeyboard"
   Option       "AIGLX" "true"
EndSection

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
# If you don't have a floating point coprocessor and emacs, Mosaic or other
# programs take long to start up, try moving the Type1 and Speedo directory
# to the end of this list (or comment them out).
#
# ModulePath can be used to set a search path for the X server modules.
# The default path is shown here.
#    ModulePath "/usr/lib/xorg/modules"
   RgbPath      "/usr/share/X11/rgb"
   FontPath     "/usr/share/fonts/local/"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/CID/"
   FontPath     "/usr/share/fonts/Speedo/"
   FontPath     "/usr/share/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/75dpi/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/cyrillic/"
EndSection

Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
# This loads the GLX module
   Load  "dbe"     # Double buffer extension
   SubSection "extmod"
      Option       "omit xfree86-dga"   # don't initialise the DGA extension
   EndSubSection
   Load  "type1"
   Load  "freetype"
    #Load        "speedo"
   Load  "glx"
   Load  "dri"
EndSection

Section "InputDevice"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.
#    Option     "Protocol"      "Xqueue"
# Set the keyboard auto repeat parameters.  Not all platforms implement
# this.
#    Option     "AutoRepeat"    "500 5"
# Specifiy which keyboard LEDs can be user-controlled (eg, with xset(1)).
#    Option     "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#    Option     "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a European
# keyboard, you will probably want to use one of:
#
#    Option     "XkbModel"      "pc102"
#    Option     "XkbModel"      "pc105"
#
# If you have a Microsoft Natural keyboard, you can use:
#
#    Option     "XkbModel"      "microsoft"
#
# If you have a US "windows" keyboard you will want:
#
#    Option     "XkbModel"      "pc104"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#
# or:
#
#    Option     "XkbLayout"     "de"
#    Option     "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#
#    Option     "XkbOptions"    "ctrl:swapcaps"
# These are the default XKB settings for X.Org
#
#    Option     "XkbRules"      "xorg"
#    Option     "XkbModel"      "pc105"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""
   Identifier  "Keyboard1"
   Driver      "kbd"
   Option       "XkbLayout" "it"
#
EndSection

Section "InputDevice"

# Identifier and driver
# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:
#    Option     "Protocol"      "Auto"
# The available mouse protocols types that you can set below are:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
# which is usually a symbolic link to the real device.
#   Option "Device"      "/dev/ttyS0"
#   Option "Device"      "/dev/ttyS1"
# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
#    Option "Protocol"   "Xqueue"
# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
#    Option "BaudRate"      "9600"
#    Option "SampleRate"   "150"
# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"
# ChordMiddle is an option for some 3-button Logitech mice
#    Option "ChordMiddle"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2"
   Option       "ZAxisMapping" "4 5"
   Option       "Emulate3Buttons" "no"
# The mouse device.  The device is normally set to /dev/mouse,
   Option       "Device" "/dev/mouse"
#   Option "Device"      "/dev/psaux"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   Option       "XAANoOffscreenPixmaps" "true"
   Option       "DRI" "true"
   BusID       "PCI:1:5:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda odiusseus » gio mar 25, 2010 15:45

dopo aver installato i drivers ati hai fatto
aticonfig --initial -f
in questo modo vengono abilitati i drivers ati attraverso xorg.conf
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: Problema GNOME Login

Messaggioda dexter » gio mar 25, 2010 18:32

si
poi ho visto che non andava e ho dato aticonfig --initial --input=/etc/X11/xorg.conf
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda odiusseus » gio mar 25, 2010 18:59

che kernel hai? prova a vedere se dmesg ti dice qualche cosa oppure
Codice: Seleziona tutto
tail /usr/share/ati/fglrx-install.log

e vedi se ti dice che è tutto a posto
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: Problema GNOME Login

Messaggioda dexter » gio mar 25, 2010 19:07

kernel: 2.6.27.7-smp (sarebbe quello fornito da slack 12.2)

il tail che mi hai dato mi da:
Codice: Seleziona tutto
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4082: error: too many arguments to function 'smp_call_function'
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5774: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5800: warning: initialization from incompatible pointer type
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.27.7'
make: *** [kmod_build] Error 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.


forse qualche problema c'è..... :(
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda odiusseus » gio mar 25, 2010 19:29

devi trovare una versione più vecchia dei drivers oppure compilare un kernel più aggiornato
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: Problema GNOME Login

Messaggioda dexter » gio mar 25, 2010 19:33

mi ricordo che avevo installato proprio questo driver e funzionava.
comunque se installo l'ultima versione del kernel 2.6.33 non ci dovrebbero essere problemi. Giusto?
dexter
Linux 2.4
Linux 2.4
 
Messaggi: 396
Iscritto il: mar giu 01, 2004 23:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3

Re: Problema GNOME Login

Messaggioda odiusseus » gio mar 25, 2010 19:36

a me l'ultimo kernel dava dei problemi con i drivers ati 10.2..tutto funziona bene (almeno a me) con kernel 2.6.32.8. D'altronde forse è più facile aggiornare il kernel che impazzire con i drivers.
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite