Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO}lettore floppy

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO}lettore floppy

Messaggioda cdx1968 » dom apr 04, 2010 10:02

Ciao a tutti volevo porvi un problema (credo ) che mi è successoi sulla mia ubuntu karmik 64 bit .
penso sia stato dopo l'aggiornamento del kernel alla versione 2.6.31-21-generic
il quesito è questo:
se decommento la riga seguente nel file /etc/fstab :/dev/fd0 /media/floppy0 vfat rw,noauto,user 0 0
il floppy non si monta ,nemmeno da root e dmesg mi dice che c'i sono degli errori
se commento la riga in questione posso accedere alla periferica e quindi montarla almeno come admin.
precedentemente avevo impostato il file per eseguirlo da utente normale e andava.
qualcuno potrebbe gentilmente spiegarmi perche :in rete non ho trovato niente su questa cosa.
penso sia un problema di udev e sto cercando di capire come scrivere qualche regola che ni consenta di nontare la periferica da utente normale.
grazie per un eventuale risposta.
Ultima modifica di cdx1968 il dom apr 04, 2010 22:41, modificato 1 volta in totale.
cdx1968
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: sab apr 04, 2009 21:41
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: kde 4.8.5

Re: lettore floppy

Messaggioda kanzy » dom apr 04, 2010 12:33

cdx1968 ha scritto:il floppy non si monta ,nemmeno da root


Succede anche a me lo stesso. Ho risistemato un vecchio PC (con 1 floppy + 1 LS120) su cui ho caricato i primi due CD della 13.0.
In precedenza girava la 12.2 senza problemi. Può essere che il supporto ai FDD sia stato disattivato nel kernel?.. (terra misteriosa :-D )
l'uomo ha bisogno di cibo rifugio e storie
Avatar utente
kanzy
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: sab mag 10, 2008 14:02
Località: Godiasco PV
Nome Cognome: Franz Fricker
Slackware: 14.0-x86_64
Kernel: 3.2.29
Desktop: kde

Re: lettore floppy

Messaggioda Kristos » dom apr 04, 2010 12:45

kanzy ha scritto:
Succede anche a me lo stesso. Ho risistemato un vecchio PC (con 1 floppy + 1 LS120) su cui ho caricato i primi due CD della 13.0.
In precedenza girava la 12.2 senza problemi. Può essere che il supporto ai FDD sia stato disattivato nel kernel?.. (terra misteriosa :-D )


Ho idea che sia proprio così anch'io, a quanto pare potrebbe essere stato un omissione nella ricompilazione/aggiornamento del kernel omettendo l'FDD. :-k
Avatar utente
Kristos
Packager
Packager
 
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: lettore floppy

Messaggioda robbybby » dom apr 04, 2010 14:11

1. Hai controllato se /dev/fd0 e /media/floppy0 esistono?
2. Commenta la riga, monta il floppy, e posta l'output di mount, almeno vediamo dove lo monta, e con che filesystem.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1177
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: lettore floppy

Messaggioda cdx1968 » dom apr 04, 2010 16:37

su slackware funziona ,anche dopo l'aggiornamento del kernel 2.6.33 ho usato il config del 2.6.32.
il modulo floppy è caricato l'ho aggiunto per sicurezza in /etc/modules ,il device fd0 c'e ,il link alla directory floppy c'e;per precisare c'e un link nominato floppy con collegamento alla directory floppy0 con permessi di rwx a turtti gli utenti,sono nel gruppo floppy .non capisco dove c'e l'errore.
mount non da nessun errore e questo il fatto.
dopo aver decommentato la riga eseguo sudo mount -t auto /dev/fd0 /media/floppy trita un po ma non mi dice niente.
in mtab non c'e traccia del floppy.
commentando la riga ed eseguendo lo stesso comando il il floppy è usabile solo da utente privilegiato in mtab compare questa
/dev/fd0 /media/floppy0 vfat rw 0 0
ho provato a vedere i parametri del modulo ma nisba questo è l'output di modinfo floppy
filename: /lib/modules/2.6.31-21-generic/kernel/drivers/block/floppy.ko
alias: block-major-2-*
license: GPL
author: Alain L. Knaff
srcversion: 990A2DEE987DAE8458B41C7
alias: acpi*:PNP0700:*
alias: pnp:dPNP0700*
depends:
vermagic: 2.6.31-21-generic SMP mod_unload modversions
parm: floppy:charp
parm: FLOPPY_IRQ:int
parm: FLOPPY_DMA:int
puo essere un problema di udev ?
cdx1968
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: sab apr 04, 2009 21:41
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: kde 4.8.5

Re: lettore floppy

Messaggioda cdx1968 » dom apr 04, 2010 22:42

problema risolto ho installato il pacchetto pmount :il quale come dice la spiegazione consente di montare i device senza usare l'utente privilegiato.
non ho inserito nessuna riga in /etc/fstab .
ovviamente non funziona da nautilus cosi ho creato un piccolo script per montarlo
ciao
cdx1968
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: sab apr 04, 2009 21:41
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: kde 4.8.5

Re: [RISOLTO}lettore floppy

Messaggioda sardylan » lun apr 05, 2010 0:11

Per poter montare un device anche da utente, in fstab di solito aggiungo il parametro users...

Codice: Seleziona tutto
/dev/cdrom      /mnt/cdrom      iso9660,udf      noauto,users,ro   0 0
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Re: [RISOLTO}lettore floppy

Messaggioda cdx1968 » lun apr 05, 2010 8:58

non funziona :ti posto il mio file fstab con ubuntu:
Codice: Seleziona tutto
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda2 during installation
UUID=b8f8c8c6-6458-48a2-8be7-b7db6d1938f2 /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
UUID=82da40a4-d338-416a-8070-78c7dda8ff3c none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/sda5       /media/dati        auto     noauto,users          0      0
#/dev/fd0        /media/floppy     vfat      rw,noauto,user     0      0
come vedi ho dovuto commentare la riga relativa al floppy
comunque da nautilus non funziona lo stesso ho dovuto creare un piccolo scripts per poterlo eseguire.
per usare il cd rom su slack mi è bastato aggiungere l'utente ai gruppi interessati
per il floppy ho modificato il file fstab 
/dev/hda1        swap             swap        defaults         0   0
/dev/hda2        /                ext3        defaults         1   1
/dev/hda3        /home            ext3        defaults         1   2
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      vfat        noauto,users     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
 

poi ho usato kwidisk .
anche kde 4 da i numeri col floppy
cdx1968
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: sab apr 04, 2009 21:41
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: kde 4.8.5

Re: [RISOLTO}lettore floppy

Messaggioda sardylan » lun apr 05, 2010 18:48

MA /dev/fd0 esiste o no?
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Re: [RISOLTO}lettore floppy

Messaggioda cdx1968 » mar apr 06, 2010 9:20

si /dev/fd0 esiste altrimenti non potrei accedere al floppy neanche da root
cdx1968
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: sab apr 04, 2009 21:41
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: kde 4.8.5

Re: [RISOLTO}lettore floppy

Messaggioda sardylan » mar apr 06, 2010 10:35

Boh?? Molto strano.. Vabbe... L'importante è che hai risolto con lo scriptino...
Curiosità... Non è che devi stare nel gruppo "floppy" per poterlo usare?
Avatar utente
sardylan
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: mar apr 24, 2007 8:21
Località: Cagliari
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.5.5
Distribuzione: Debian - CLFS

Re: [RISOLTO}lettore floppy

Messaggioda cdx1968 » mar apr 06, 2010 11:56

si ero gia nel gruppo floppy e ho provato a rimetterlo ,senza alcun risultato.
lo scriptino è una cazzulata:
testo
#! /bin/sh
pmount /dev/fd0 /media/floppy0
pero funziona mi permette di accedere in lettura e scrittura alla periferica
per smontare pumount /dev/fd0
leggi qui:
http://packages.debian.org/it/sid/pmount
cdx1968
Linux 1.0
Linux 1.0
 
Messaggi: 44
Iscritto il: sab apr 04, 2009 21:41
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: kde 4.8.5


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite