strano comportamento wifi

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

strano comportamento wifi

Messaggioda odiusseus » mar giu 08, 2010 14:07

Salve ragazzi, ho uno strano problema con una scheda wifi del portatile (HP dv6-1108sl) della mia ragazza. Sul portatile c'è Slackware 13.1. La scheda wifi è una broadcom bcm4312. Ho installato i driver hybrid-XXX. Con Slackware13.0 nessun problema. Il punto è che la scheda funziona bene ma ogni tanto (diciamo ogni volta che il pc si spegne) il nome della scheda cambia una volta è eth0 poi eth1 poi wlan0 e poi di nuovo eth0...insomma wicd ad ogni accensione va riconfigurato. Come mai questo strano comportamento? c'è una modo tramite qualche regola di udev per evitare questo fastidioso problema? ..anche perché fino a quando ci sono io...pazienza ma quando non ci sono io..beh è dura fare assistenza telefonica!!! :D

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2698
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.8.11-ck8
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: strano comportamento wifi

Messaggioda Ansa89 » mar giu 08, 2010 14:18

È sicuramente colpa di udev, a meno che non ci sia qualche altro software incaricato del riconoscimento hardware (ma non mi pare).
Purtroppo sono totalmente ignorante sulle regole di udev :( .

Avatar utente
conraid
Staff
Staff
Messaggi: 12801
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: strano comportamento wifi

Messaggioda conraid » mar giu 08, 2010 15:01

Dovresti cancellare le regole di udev e vedere di ricrearla, guarda la documentazione della Slackware

Comunque perché usi quei driver, dovrebbero essere nel kernel adesso i driver per quella scheda, c'è un motivo particolare?

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: strano comportamento wifi

Messaggioda odiusseus » mar giu 08, 2010 19:37

no il kernel non la supporta ancora...però sono drivers vecchi anche se compilati con una patch.Non so ma è fastidioso

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: strano comportamento wifi

Messaggioda odiusseus » mar giu 08, 2010 19:57

mi auto correggo..si è supportato ma non ho idea del perchè non va con il kernel!!!!

Avatar utente
conraid
Staff
Staff
Messaggi: 12801
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: strano comportamento wifi

Messaggioda conraid » mar giu 08, 2010 20:23

hai installato il firware?

comunque
http://wireless.kernel.org/en/users/Drivers/b43

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: strano comportamento wifi

Messaggioda odiusseus » mar giu 08, 2010 22:38

ok..fatto..ma non so ancora come va al riavvio. l'unica cosa è che come succede ad un'altro utente
http://www.slacky.eu/forum/viewtopic.php?p=281965#p281965
con questi drivers la scheda non si "accende" all'avvio. Per baipassare il problema ho messo in rc.local

Codice: Seleziona tutto

ifconfig wlan0 up

ovvimante è un "trucco" mica è normale sta cosa!!!!


Torna a “Hardware”

Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti