slack 13.1 non avvia scheda wifi

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
red
Linux 2.6
Linux 2.6
Messaggi: 791
Iscritto il: gio gen 20, 2005 0:00
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox
Località: Verona
Contatta:

slack 13.1 non avvia scheda wifi

Messaggioda red » mar giu 08, 2010 19:43

Ciao a tutti,
sto provando la 13.1 a 32 bit.
Dopo un'installazione pulita, installo wicd e al successivo riavvio il wireless non viene abilitato (non si accende la spia del portatile).

rc.wicd è eseguibile, ma un ifconfig conferma che la wlan0 è down.

Se faccio

Codice: Seleziona tutto

ifconfig wlan0 up

la scheda si avvia, ma pur essendo il demone wicd in esecuzione, wicd-client non trova le reti wireless, mentre

Codice: Seleziona tutto

iwlist wlan0 scanning

le trova tranquillamente.

Tutto questo usando root.

Che succede secondo voi?

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2683
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.7.3-ck4
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda Ansa89 » mar giu 08, 2010 20:47

Come già detto in altri topic: wicd mi ha dato più problemi che altro, quindi lo sconsiglio.
Se fossi in te userei "/etc/rc.d/rc.inet1.conf" per le configurazioni e poi lasciare il compito a "/etc/rc.d/rc.inet1" di impostare i parametri direttamente all'avvio (sempre che tu non abbia esigenze particolari).

Avatar utente
Toni
Linux 2.6
Linux 2.6
Messaggi: 995
Iscritto il: lun gen 30, 2006 22:08
Slackware: slackware-14
Kernel: 3.10.5
Desktop: i3
Località: milano

Re: slack 13.1 non avvia scheda wifi

Messaggioda Toni » mar giu 08, 2010 21:10

hai controllato tra le preferenze di wicd se tutto è settato correttamente?

Avatar utente
red
Linux 2.6
Linux 2.6
Messaggi: 791
Iscritto il: gio gen 20, 2005 0:00
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox
Località: Verona
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda red » mar giu 08, 2010 22:33

@ansa89: a me in realtà non ne aveva mai dati, infatti sono stupito che passando dalla 13.0 alla 13.1 di avere tutti questi problemi. Comunque il comportamento è davvero strano.
@Toni: le preferenze base son sempre quelle. Sulle singole reti poi, non è possibile settare nulla perché come detto non le trova neppure.

Caspita, questa versione dà veramente un sacco di grattacapi... mi sa che mi tengo la 13.0 che va ottimamente.

Avatar utente
j0kers
Linux 2.4
Linux 2.4
Messaggi: 418
Iscritto il: dom lug 22, 2007 1:31
Slackware: 13
Kernel: 2.6.32
Desktop: xfce4

Re: slack 13.1 non avvia scheda wifi

Messaggioda j0kers » mer giu 09, 2010 0:26

Io sono sempre per le configurazioni primitive ancora da terminale :D :D :D :D

Avatar utente
red
Linux 2.6
Linux 2.6
Messaggi: 791
Iscritto il: gio gen 20, 2005 0:00
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox
Località: Verona
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda red » mer giu 09, 2010 9:38

j0kers ha scritto:Io sono sempre per le configurazioni primitive ancora da terminale :D :D :D :D

In generale anche io, per questo uso Fluxbox e tutti programmi da riga di comando.
Però devo ammettere che spostandosi da casa, all'università, ad hotspot pubblici eccetera, un programma come wicd è davvero utile.

Come dicevo, aspetterò fiducioso la prossima relase :).

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2683
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.7.3-ck4
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda Ansa89 » mer giu 09, 2010 10:23

Gli hot spot sono sempre gli stessi?
Perché anche io mi sposto tra casa, università, morosa, amici e ognuno ha la sua rete wireless, quindi mi sono fatto cinque o sei "/etc/rc.d/rc.inet1.conf_NOME" (eventualmente corredati di "wpa_supplicant.conf_NOME") con le varie impostazioni e mi basta rinominare quel file (insieme all'eventuale "wpa_supplicant.conf_NOME") e lanciare "/etc/rc.d/rc.inet1 restart".
Per automatizzare ancora di più, mi sono fatto uno script da lanciare da root che fa tutto in automatico.

Avatar utente
osser
Linux 1.0
Linux 1.0
Messaggi: 74
Iscritto il: mer ott 03, 2007 16:31
Slackware: 13.37
Kernel: 2.6.38.7
Desktop: openbox

Re: slack 13.1 non avvia scheda wifi

Messaggioda osser » mer giu 09, 2010 14:04

Ansa89 ha scritto:Gli hot spot sono sempre gli stessi?
cut... cinque o sei "/etc/rc.d/rc.inet1.conf_NOME" (eventualmente corredati di "wpa_supplicant.conf_NOME") con le varie impostazioni e mi basta rinominare quel file (insieme all'eventuale "wpa_supplicant.conf_NOME") e lanciare "/etc/rc.d/rc.inet1 restart".
Per automatizzare ancora di più, mi sono fatto uno script da lanciare da root che fa tutto in automatico.

Per favore potresti condividere (anche in PM) un tuo rc.inet1.conf_NOME con wpa_supplicant.conf_NOME e lo script da lanciare da root che fa tutto in automatico. Grazie.

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2683
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.7.3-ck4
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda Ansa89 » mer giu 09, 2010 14:36

Lo script lo posso condividere, ma le configurazioni no (soprattutto /etc/wpa_supplicant.conf), anche perché delle configurazioni ci interessa solo il nome.
Ad esempio:

Codice: Seleziona tutto

$ ls /etc/rc.d/rc.inet1.conf*
/etc/rc.d/rc.inet1.conf
/etc/rc.d/rc.inet1.conf_NOME1
/etc/rc.d/rc.inet1.conf_NOME2
/etc/rc.d/rc.inet1.conf_NOME3
/etc/rc.d/rc.inet1.conf_NOME4

$ ls /etc/wpa_supplicant.conf*
/etc/wpa_supplicant.conf
/etc/wpa_supplicant.conf_NOME2
/etc/wpa_supplicant.conf_NOME4

In questo esempio abbiamo quattro configurazioni per "/etc/rc.d/rc.inet1" e solo due configurazioni per "wpa_supplicant" (nel senso che "rc.inet1.conf_NOME1" e "rc.inet1.conf_NOME3" non hanno bisogno di wpa_supplicant, quindi non fanno uso della configurazione di "wpa_supplicant").

Per scegliere la configurazione "NOME1" con lo script basta fare:

Codice: Seleziona tutto

# set_wifi.sh NOME1
** WARNING **
No wpa_supplicant configuration for NOME1
(This may be normal so we continue without errors)

Per la configurazione "NOME4":

Codice: Seleziona tutto

# set_wifi.sh NOME4



Di seguito il codice dello script:

Codice: Seleziona tutto

#!/bin/bash

# Controllo se sei root
if [ "$(whoami)" != "root" ]; then
        echo "** ERROR **"
        echo "You are not root"
        exit 1
fi
# Controllo l'argomento passato
if [ "$1" == "" ]; then
        echo "** ERROR **"
        echo "No argument given"
        exit 1
fi

# Controllo se esiste la configurazione per rc.inet1
if [ -e /etc/rc.d/rc.inet1.conf_$1 ]; then
        cp /etc/rc.d/rc.inet1.conf_$1 /etc/rc.d/rc.inet1.conf
else
        echo "** ERROR **"
        echo "No rc.inet1 configuration for $1"
        exit 1
fi

# Controllo se esiste la configurazione per wpa_supplicant
if [ -e /etc/wpa_supplicant_$1 ]; then
        cp /etc/wpa_supplicant.conf_$1 /etc/wpa_supplicant
else
        echo "** WARNING **"
        echo "No wpa_supplicant configuration for $1"
        echo "(This may be normal so we continue without errors)"
fi

# Riavvio il servizio solo se ha i permessi di esecuzione
if [ -x /etc/rc.d/rc.inet1 ]; then
        /etc/rc.d/rc.inet1 restart
fi
#EOF

Se qualcosa non è chiaro chiedete pure.
Se avete proposte per miglioramenti/correzioni mandatemi un pm o aprite un altro topic (metodo consigliato).

Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
Messaggi: 175
Iscritto il: lun ago 18, 2008 11:00
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox
Località: Rome

Re: slack 13.1 non avvia scheda wifi

Messaggioda NetNightmare » mer giu 09, 2010 17:03

Ansa89 ha scritto:Gli hot spot sono sempre gli stessi?
Perché anche io mi sposto tra casa, università, morosa, amici e ognuno ha la sua rete wireless, quindi mi sono fatto cinque o sei "/etc/rc.d/rc.inet1.conf_NOME" (eventualmente corredati di "wpa_supplicant.conf_NOME") con le varie impostazioni e mi basta rinominare quel file (insieme all'eventuale "wpa_supplicant.conf_NOME") e lanciare "/etc/rc.d/rc.inet1 restart".
Per automatizzare ancora di più, mi sono fatto uno script da lanciare da root che fa tutto in automatico.


Scusa se mi intrometto , ma questa risposta mi incuriosisce parecchio ..... che problema avevi con utilizzare il file rc.inet1.conf abilitando wap_supplicant e inserire in wpa_supplicant.conf "tutte le reti a cui ti colleghi" , non riesco a capire questa necessita di creare vari file di configurazione ........ io ho circa 20 reti wireless configurate in wpa_supplicant.conf ( puoi anche settare un ordine di preferenza ) e mi basta lanciare

Codice: Seleziona tutto

/etc/rc.d/rc.inet1 wlan0_restart


ammesso e non concesso che alcune delle reti wireless che utilizzi non abbiano un DHCP posso anche al limite capire avere + rc.inet1.conf ma perche avere + wpa_supplicant.conf ?? #-o #-o #-o #-o

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2683
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.7.3-ck4
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda Ansa89 » gio giu 10, 2010 0:07

Ti do ragione, in effetti in wpa_supplicant.conf si possono inserire tutte le reti e sarà lui a decidere a quale collegarsi.
Il problema è che tempo ebbi dei problemi proprio a causa delle reti multiple dentro wpa_supplicant.conf: io gli dicevo che volevo una rete (con "iwconfig wlan0 essid ASD"), ma pi lui cercava di connettersi ad un'altra.
Inizialmente pensavo fosse dovuto al fatto che in casa ho due reti wireless (che arrivano fino a quattro nei giorni di smanettamenti), ma questo fastidioso inconveniente era cominciato a capitare anche lontano da casa (es: all'università).
Da qui l'idea di mettere ogni rete in un file a parte.
Non voglio incoraggiare questa filosofia, anzi, se agli altri funziona con tutte le reti dentro un unico file, tanto meglio per loro.

Comunque il mio script funziona anche solo per gestire più configurazioni di "rc.inet1", basta ignorare il "warning". In pratica diventa un modo veloce per cambiare configurazione alla scheda wireless :) .

Avatar utente
conraid
Staff
Staff
Messaggi: 12773
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda conraid » gio giu 10, 2010 8:58

beh, ma se tu metti l'essid in rc.inet1.conf wpa_supplicant dovrebbe usare quella rete, non altre... in teoria :-)

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2683
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.7.3-ck4
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda Ansa89 » gio giu 10, 2010 9:59

conraid ha scritto:beh, ma se tu metti l'essid in rc.inet1.conf wpa_supplicant dovrebbe usare quella rete, non altre... in teoria :-)

È quello che pensavo anche io, infatti quella fu una delle tante prove per cercare di forzare wpa_supplicant a connettersi alla rete che volevo io.
Ovviamente il tentativo fallì :doubt: .

Non per fare il moderatore, ma credo che stiamo finendo OT :roll: .

Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
Messaggi: 175
Iscritto il: lun ago 18, 2008 11:00
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox
Località: Rome

Re: slack 13.1 non avvia scheda wifi

Messaggioda NetNightmare » gio giu 10, 2010 15:39

conraid ha scritto:beh, ma se tu metti l'essid in rc.inet1.conf wpa_supplicant dovrebbe usare quella rete, non altre... in teoria :-)


mmmm non credo

questi parametri :

Codice: Seleziona tutto

#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"


Non hanno niente a che fare con WPA_Supplicant , ma con rc.wireless ( deprecato ) se setti la tua rete cosi' puoi anche evitare di abilitare il supporto WPA di WPA_supplicant ma se invece abiliti il supporto WPA :

Codice: Seleziona tutto

WLAN_WPA[4]="wpa_supplicant"   # Run wpa_supplicant for WPA support
richiami l'avvio di WPA_Supplicant ,

i parametri inclusi in rc.inet1.conf relativi sono solo appunto :

Codice: Seleziona tutto

#WLAN_WPA[4]="wpa_supplicant"   # Run wpa_supplicant for WPA support
#WLAN_WPADRIVER[4]="ndiswrapper"# Tell wpa_supplicant to specifically use the
                                # ndiswrapper driver (if you leave this empty
                                # the 'wext' driver is used by default)
#WLAN_WPAWAIT[4]=30             # In case it takes long for the WPA association
                                # to finish, you can increase the wait time
                                # (defaults to 10 seconds)


Il resto sono contenuti in wpa_supplicant.conf , i paramentri che ti possono essere utili quando configuri molte reti wireless sono

Codice: Seleziona tutto

priority={number}
per determinare l'ordine in cui deve essere tentata la connessione e

Codice: Seleziona tutto

   disabled=0\1
per abilitare o meno quella rete .... e comunque e' vero siamo OT

Bye

Avatar utente
conraid
Staff
Staff
Messaggi: 12773
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: slack 13.1 non avvia scheda wifi

Messaggioda conraid » gio giu 10, 2010 15:50

Hai ragione su essid, ma tanto per la cronaca rc.wireless non è dreprecato, è sempre questo script a richiamare i vari comandi (del resto mica è obbligatorio usare wpa_supplicant, e comunque è sempre rc.wireless a lanciarlo), quel che è deprecato è la configurazione tramite rc.wireless.conf


Torna a “Slackware”

Chi c’è in linea

Visitano il forum: Majestic-12 [Bot] e 4 ospiti