Repository 32bit  Forum
Repository 64bit  Wiki

kdenlive

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

kdenlive

Messaggioda odiusseus » mar giu 22, 2010 9:43

salve ragazzi ho installato kdenlive ma credo che abbia qualche problema .Il programma ad ogni video che inserisco o acquisisco mi restituisce un errore :
Codice: Seleziona tutto
File.avi oppure File.mpg è inutilizzabile o mancante, rimuoverlo dal progetto.

non so..
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: kdenlive

Messaggioda gohanz » mar giu 22, 2010 10:58

Il problema e' che Kdenlive ed il suo motore Mlt sono stati compilati con la versione 0.5.2 di FFmpeg. Lo stesso giorno della pubblicazione e' stato aggiornato anche FFmpeg alla versione 0.6. Avevo lasciato la versione precendete di FFmpeg, in caso di problemi, ma e' stata tolta.
La soluzione e' ricompilare Mlt con FFmpeg 0.6. Oppure dobbiamo aspettare che Loris rimetta a disposizione la versione 0.5.2 di FFmpeg.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: kdenlive

Messaggioda gohanz » mar giu 22, 2010 11:16

Ho aggiornato Mlt alla versione 0.5.6, ricompilato con la versione 0.6 di FFmpeg. Adesso Kdenlive funziona correttamente. Il pacchetto e' stato caricato, ma occorre aspettare Loris che lo metta a disposizione.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: kdenlive

Messaggioda odiusseus » mar giu 22, 2010 11:24

ok..grazie mille!!!!Aspetterò
odiusseus
Linux 2.4
Linux 2.4
 
Messaggi: 352
Iscritto il: sab giu 30, 2007 13:09
Località: roma/vibo valentia
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde

Re: kdenlive

Messaggioda daniele50 » dom ott 17, 2010 2:34

Ciao a tutti!
Ho appena installato kdenlive sul slackware-current 64bit, ho scaricato i seguenti pacchetti da http://www.mlange.dds.nl/ :

kdenlive-0.7.8-1-x86_64_MDG.txz
mlt-0.5.10-1-x86_64_MDG.tgz
frei0r-20100913-1-x86_64_MDG.tgz

Quando parte kdenlive mi dice che non c'è FFmpeg, nonostante abbia installato il pacchetto ffmpeg-0.6-x86_64-1sl.txz scaricato dal repository 64bit di slacky.
Ho provato anche a sostituire il pacchetto mlt con mlt-0.5.4-x86_64-1sl.txz scaricato dal repository 64bit di slacky, ma è peggio perché in questo caso kdenlive non trova mlt.

Qualcuno usa kdenlive su 64bit current?
Se sì, con quali pacchetti?

Grazie
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 928
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.2.29
Desktop: Xfce 4.10

Re: kdenlive

Messaggioda zevin » dom ott 17, 2010 8:45

In effetti FFmpeg 1.0 da problemi con kdenlive. Devi ricompilarti la versione 0.5.

Ciao
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: kdenlive

Messaggioda mimmoforlug » mer nov 03, 2010 13:06

Attenzione che kdenlive non funziona con la versione ffmpeg 6.1
credo che sarebbe necessario dare l'opportunità di scaricare la 6.0

Il problema è che kdenlive va in crash al caricamento di qualsiasi clip.
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox

Re: kdenlive

Messaggioda gohanz » mer nov 03, 2010 20:01

Mimmo a me funziona senza problemi. Parlo del pacchetto a 32 bit.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: kdenlive

Messaggioda mimmoforlug » gio nov 04, 2010 17:12

Anche io ho tutto a 32 bit ma con ffmpeg 0.6.1 o svn (insieme alla ricompilazione della
x264, di kdenlive e mlt) non c'è stato verso di farlo andare. L'errore sembra essere
riferito alla libswscale e in effetti non appena si cerca di caricare una qualunque clip
kdenlive va in crash. Ho rimediato utilizzando la versione 0.6 di ffmpeg e così kdenlive
funziona perfettamente. Comunque, grazie per l'attenzione.
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox

Re: kdenlive

Messaggioda Matrix86 » dom gen 02, 2011 17:39

Salve anche io ho il problema che quando cerco di caricare una clip mi va in crash con i pacchetti presi da slacky.eu. Ho provato a ricompilare ffmpeg 6.0 e mlt, ma non sembra esserci verso...consigli??

P.s.: ho appena provato a installare anche Kino e openshot e tutti crashano dopo aver provato a caricare un video. Su shell mi viene restituito un "Illegal Instruction".
P.s2.: l'errore illegal instruction mi è dato da mlt , infatti dando melt file.dv mi restituisce l'errore. Ho rimosso ffmpeg ed è andato...ora kdenlive mi inserisce i video ma non ho + ffmpeg...(io esco matto)


Inizio a tirare testate al muro?
Avatar utente
Matrix86
Linux 1.0
Linux 1.0
 
Messaggi: 14
Iscritto il: sab set 08, 2007 18:41
Slackware: 13.1
Desktop: KDE4

Re: kdenlive

Messaggioda Matrix86 » dom gen 02, 2011 21:41

ho iniziato le prime testate.

Da come sembra è FFMPEG che rompe, però io l'ho ricompilato da me, pure kdenlive e mlt....tutto andato a buon fine...che potrebbe essere??
Avatar utente
Matrix86
Linux 1.0
Linux 1.0
 
Messaggi: 14
Iscritto il: sab set 08, 2007 18:41
Slackware: 13.1
Desktop: KDE4

Re: kdenlive

Messaggioda mimmoforlug » mer mar 02, 2011 19:33

Niente di nuovo! Neanche con l'ultimo upgrade a:

ffmpeg-0.6.1-i686-5sl.txz
libva-0.32.0_sds2-i486-3sl.txz
libvpx-0.9.5-i486-1sl.txz

ripristinando le vecchie versioni:

ffmpeg-0.6-i686-1sl.txz
libvpx-0.9.1-i486-1sl.txz
libva-0.31.1+sds4-i486-3sl.txz

tutto ritorna al suo posto e kdenlive
funziona alla perfezione.


Gli errori restituiti da kdenlive con i pacchetti aggiornati sono:
Application: Kdenlive (kdenlive), signal: Illegal instruction
Traceback (most recent call last):
File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.2200.5-gdb.py", line 9, in <module>
from gobject import register
File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
import gdb.backtrace
ImportError: No module named backtrace
[Current thread is 1 (Thread 0xb50f9710 (LWP 14108))]

Thread 3 (Thread 0xb05ccb70 (LWP 14131)):
#0 0xb68b7528 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0xb787f8c9 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
#2 0x00000000 in ?? ()

Thread 2 (Thread 0xb0dccb70 (LWP 14132)):
#0 0xb68b7210 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0xb22e1a4f in ?? () from /usr/lib/mlt/libmltsdl.so
.......

Thread 1 (Thread 0xb50f9710 (LWP 14108)):
[KCrash Handler]
#5 0xb2e1961b in ?? () from /usr/lib/libswscale.so.0
Avatar utente
mimmoforlug
Packager
Packager
 
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Località: Caserta
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron