Repository 32bit  Forum
Repository 64bit  Wiki

Avant Window Navigator e dipendenze

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Avant Window Navigator e dipendenze

Messaggioda anycolouryoulike » ven lug 16, 2010 13:07

Thraphyx ha scritto:@ anycolouryoulike
Aspetta... ma stai usando la Slack 13.1? Dal profilo leggo 12.2, non so se non è aggiornato o cosa..
No, non ho aggiornato, ma i pacchetti li sto provando su una 13.1.
Se con AWN riesco a creare un DE decente che sostituisca KDE 4 potrei anche aggiornare...
Sei sicuro che li hai compilati su una Slackware64 13.1 pulita?
Potresti controllare gli slack-required, se li hai fatti...
Avatar utente
anycolouryoulike
Packager
Packager
 
Messaggi: 1158
Iscritto il: gio ago 09, 2007 23:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » ven lug 16, 2010 13:40

Certo, come ho scritto ho compilato tutto su una 13.1 64bit pulita e con le patch di sicurezza.
Gli slack-required sono tutti nei pacchetti, prova a vedere se hai tutto, al limite dai un ldd sia su avant-window-navigator che su libdesktop-agnostic, almeno vediamo di capire qualcosa in più :-k
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda 6C33C » ven lug 16, 2010 17:53

Thraphyx ha scritto:@ anycolouryoulike
Aspetta... ma stai usando la Slack 13.1? Dal profilo leggo 12.2, non so se non è aggiornato o cosa..

6C33C ha scritto:
Thraphyx ha scritto:Non saprei, probabilmente hai mancato qualcosa durante le varie ricompilazioni.. in ogni caso, ho aggiunto al primo post i link per i pacchetti a 32bit (ho messo sù anche un chroot a 32bit :lol: ).
Magari provali e fammi sapere :thumbright:

I Pacchetti li provo grazie.
Ma voglio capire cosa non è andato per il verso giusto.
Non è che mi puoi dare l'ordine di compilazione ? :D

L'ho scritto nel primo post, te le riscrivo
Codice: Seleziona tutto
gconf
orbit
gobject-introspection
gir-repository
vala
libdesktop-agnostic
pyxdg
libgtop
bazaar
avant-window-navigator

Scusa Thraphyx non avevo capito che quello era l' ordine di compilazione. :oops:
Grazie ancora per la risposta.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Avant Window Navigator e dipendenze

Messaggioda 6C33C » ven lug 16, 2010 18:48

Ho fatto delle prove ma se compilo AWN mi da sempre quell' errore. :|
e usando i tuoi pacchetti mi da l'errore :
bash-4.1$ avant-window-navigator &
[1] 9457
bash-4.1$ **
ERROR:default/libdesktop-agnostic/module.c:336:desktop_agnostic_module_loader_guess_module: assertion failed: (self->priv->module_guesser != NULL)

[1]+ Abortito avant-window-navigator

Praticamente come anycolouryoulike.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » ven lug 16, 2010 19:54

Per la compilazione onestamente non so perchè fallisce.. Io l'ho compilata su una slack vergine, magari è colpa di qualche pacchetto che ti manca..

Per l'errore, come ho detto a anycolouryoulike, prova a dare
Codice: Seleziona tutto
ldd /usr/lib/libdesktop-agnostic.so
ldd /usr/bin/avant-window-navigator
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda anycolouryoulike » sab lug 17, 2010 2:09

Ecco qua:
Codice: Seleziona tutto
$ ldd /usr/lib/libdesktop-agnostic.so
ldd: /usr/lib/libdesktop-agnostic.so: No such file or directory
$ ldd /usr/lib64/libdesktop-agnostic.so
ldd: warning: you do not have execution permission for `/usr/lib64/libdesktop-agnostic.so'
        linux-vdso.so.1 =>  (0x00007fff619ff000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f8b0ed1e000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f8b0ea73000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f8b0e857000)
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f8b0e64b000)
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f8b0e402000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f8b0e18b000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f8b0df48000)
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f8b0dd45000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f8b0da64000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f8b0d6ef000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f8b0d4c7000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f8b0d1b7000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f8b0cfb5000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f8b0cda6000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f8b0cb9d000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f8b0c993000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f8b0c791000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f8b0c57e000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f8b0c37c000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f8b0c177000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f8b0bf1e000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f8b0bcea000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f8b0ba64000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f8b0b840000)
        libpng14.so.14 => /usr/lib64/libpng14.so.14 (0x00007f8b0b61b000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f8b0b412000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00007f8b0b1fd000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f8b0aec5000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f8b0acaa000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f8b0aaa6000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f8b0a8a1000)
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007f8b0a5fc000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f8b0a3e2000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f8b0a1de000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f8b0f1d1000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f8b09fc7000)
$ ldd /usr/bin/avant-window-navigator
        linux-vdso.so.1 =>  (0x00007fffe4dff000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007fd6b8606000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007fd6b8401000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007fd6b81f8000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fd6b7ec0000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fd6b7cae000)
        libawn.so.1 => /usr/lib64/libawn.so.1 (0x00007fd6b7a6b000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fd6b77e8000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fd6b75cb000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fd6b7256000)
        libgthread-2.0.so.0 => /usr/lib64/libgthread-2.0.so.0 (0x00007fd6b7052000)
        libdesktop-agnostic.so.0 => /usr/lib64/libdesktop-agnostic.so.0 (0x00007fd6b6e4b000)
        libdesktop-agnostic-vfs.so.0 => /usr/lib64/libdesktop-agnostic-vfs.so.0 (0x00007fd6b6c3f000)
        libdesktop-agnostic-cfg.so.0 => /usr/lib64/libdesktop-agnostic-cfg.so.0 (0x00007fd6b6a27000)
        libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007fd6b642d000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007fd6b6182000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007fd6b5f67000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007fd6b5cf1000)
        libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007fd6b5acf000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007fd6b588c000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007fd6b55ac000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fd6b5391000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fd6b518d000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fd6b4f8a000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fd6b4d85000)
        libdesktop-agnostic-fdo.so.0 => /usr/lib64/libdesktop-agnostic-fdo.so.0 (0x00007fd6b4b81000)
        libdesktop-agnostic-ui.so.0 => /usr/lib64/libdesktop-agnostic-ui.so.0 (0x00007fd6b4973000)
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007fd6b4753000)
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007fd6b44ae000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007fd6b4286000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fd6b4000000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007fd6b3dcc000)
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007fd6b3bc0000)
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007fd6b3977000)
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007fd6b3774000)
        libdbus-1.so.3 => /usr/lib64/libdbus-1.so.3 (0x00007fd6b3535000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fd6b332d000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fd6b8808000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007fd6b312b000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007fd6b2f1c000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007fd6b2d14000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007fd6b2b0a000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fd6b27fb000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007fd6b25f9000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007fd6b23a1000)
        libpng14.so.14 => /usr/lib64/libpng14.so.14 (0x00007fd6b217c000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fd6b1f63000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00007fd6b1d4f000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007fd6b1b2c000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007fd6b1916000)
Grazie del lavoro e dell'aiuto!
Avatar utente
anycolouryoulike
Packager
Packager
 
Messaggi: 1158
Iscritto il: gio ago 09, 2007 23:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » sab lug 17, 2010 22:11

Ho messo su una macchina virtuale slack64 e ho constatato effettivamente il vostro problema.
Allora, il problema era che avevo scritto male una parte dello slackbuild di libdesktop-agnostic (ma non ho idea del perchè sulla mia macchina funzionava e sulle altre no :lol: ). Anche in quello di avant-window-navigator mancava una cosa (nel doinst.sh più precisamente).

Insomma, ho rifatto i due pacchetti sovracitati, sia i486 sia x86_64 (però ho testato solo x86_64, ma gli altri non dovrebbero essere diversi). Ho aggiornato i link nel primo post di questi due pacchetti.

Adesso, sulla macchina virtuale, funzionano perfettamente :thumbright:
Fatemi sapere! :D
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda 6C33C » sab lug 17, 2010 22:17

Dopo li provo e ti faccio sapere :p
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Avant Window Navigator e dipendenze

Messaggioda 6C33C » dom lug 18, 2010 7:44

Ok ora funziona ! (uso la 32 ) :)
Però ho dovuto riavviare, per vederlo funzionare alrimenti mi segnalava ancora :
bash-4.1$ **
ERROR:default/libdesktop-agnostic/module.c:336:desktop_agnostic_module_loader_guess_module: assertion failed: (self->priv->module_guesser != NULL)
Grazie ancora dei pacchetti. :thumbright:
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » dom lug 18, 2010 12:23

Perfetto! :thumbright:
Attendo un responso sui 64bit :)
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda anycolouryoulike » mar lug 20, 2010 1:29

Anche sulla 64 sono ok!
Quindi li inserirai nel repository di Slacky?
Avatar utente
anycolouryoulike
Packager
Packager
 
Messaggi: 1158
Iscritto il: gio ago 09, 2007 23:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » ven lug 23, 2010 20:45

Loris non mi ha fatto sapere ancora nulla.. Se accetta li metto sul repo.
Comunque ho fatto anche il pacchetto di awn-extras, quello con le varie applet, e devo dire che è una figata :D
Adesso la sto usando a mò di pannello (ho tolto quelli di gnome) :D

Dopo lo uppo e lo posto.

EDIT
caricato. messi i link nel primo post

Ecco come si presenta adesso il mio gnomo :D
http://img197.imageshack.us/i/schermatab.jpg/
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda 6C33C » sab lug 24, 2010 8:15

Thraphyx ha scritto:Loris non mi ha fatto sapere ancora nulla.. Se accetta li metto sul repo.
Comunque ho fatto anche il pacchetto di awn-extras, quello con le varie applet, e devo dire che è una figata :D
Adesso la sto usando a mò di pannello (ho tolto quelli di gnome) :D

Dopo lo uppo e lo posto.

EDIT
caricato. messi i link nel primo post

Ecco come si presenta adesso il mio gnomo :D
http://img197.imageshack.us/i/schermatab.jpg/

Come mia piccolissima esperienza (1 pacchetto) posso dire che se Loris li ritiene validi li pubblica.
Provo anche awn-extras grazie. :D
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Avant Window Navigator e dipendenze

Messaggioda brainvision » mer ago 04, 2010 19:16

accidenti ma davvero lo hai fatto anche tu?? ma avevi controllato su asche?? io il 4 agosto ho prenotato awn, awn-extras, psyco, libdesktop-agnostic, gnome-desktop-extras, gnome-python etc etc!! Un bordello di roba, maledizione!!
ora devo solo compilarli su macchina i485 e sono pronti, ma se non mi sbaglio tu hai anche quelli per la 64bit? magari ce li dividiamo in questo modo: 486 io e 64bit li metti tu..

io ho anche preparato cairo-dock e cairo-dock-plugins, che all'inizio sempra un tantino più caciaro, ma secondo me forse alla fin fine ha più applet rispetto ad awn!

ultima preghiera: per favore appena si vuole fare un pacchetto lo si prenota prima, altrimenti ecco cosa succede!, francamente non è una cosa bella vedere che abbiamo fatto lo stesso lavoro: con lo stesso tempo ci si poteva dedicare a cose differenti in modo da avere più pacchetti immagazzinati.. o non gred??
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » mer ago 04, 2010 23:42

Ma che... :shock:
Guarda, non essendo abilitato come packager non ho accesso alla pagina di asche, quindi non ho potuto controllare..
Semplicemente, visto che volevo provare AWN e non c'erano i pacchetti sul repo, l'ho compilato e ho messo a disposizione i pacchetti per chi li volesse provare.

Ho fatto un pò di tempo fa a Loris la richiesta, ma non mi mi ha fatto sapere più nulla. Anche se comunque adesso non potrei compilare lo stesso (pc rotto, netbook di riserva con internet key visto che sono in vacanza).

In ogni caso, per me non ci sono assolutamente problemi se metti tu i pacchetti a 32bit, anche perchè io non posso mica :lol: . E comunque sono pienamente d'accordo sul discorso prenotazioni, ma ripeto, non ne ho avuto la possibilità.

PS.
brainvision ha scritto: io il 4 agosto ho prenotato awn, awn-extras, psyco, libdesktop-agnostic, gnome-desktop-extras, gnome-python etc etc!!

Volevi dire luglio?
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

PrecedenteProssimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 2 ospiti