Repository 32bit  Forum
Repository 64bit  Wiki

Problema primo avvio - caricamento myslq

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema primo avvio - caricamento myslq

Messaggioda nospda » ven lug 23, 2010 21:10

Ciao a tutti, sono nuovo del forum. Ho provato a installare slackware 13.1 su virtualbox in ubuntu 10.04, durante l'installazione ho richiesto l'installazione dei servizi per il web quali server web, mysql, php ecc... all'avvio fa continuamente il restart di mysql. Prima di riformattare e reinstallare il tutto vorrei capire dove sta l'errore...
Vi ringrazio...
P.S. Vi allego lo screenshot del problema

slackware.png
Errore avvio - mysql
slackware.png (46.46 KiB) Osservato 511 volte
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Re: Problema primo avvio - caricamento myslq

Messaggioda neongen » sab lug 24, 2010 18:43

se apri il file /etc/rc.d/rc.mysql nei commenti trovi alcune cose da fare...
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: Problema primo avvio - caricamento myslq

Messaggioda nospda » sab lug 24, 2010 18:56

Grazie neongen per la rapida risposta...
...se il sistema non si avvia proprio come posso fare ad accedere al file?
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Re: Problema primo avvio - caricamento myslq

Messaggioda neongen » dom lug 25, 2010 1:22

avviare la macchina virtuale su cui hai messo slackware con un cd o iso live (va bene anche quello stesso che hai usato per installare slackware), accedere al filesystem della macchina, togliere il permesso di esecuzione al file /etc/rc.d/rc.mysqld e riavviare.
Comunque le istruzioni nel file sono
Codice: Seleziona tutto
# To start MySQL automatically at boot, be sure this script is executable:
# chmod 755 /etc/rc.d/rc.mysqld

# Before you can run MySQL, you must have a database.  To install an initial
# database, do this as root:
#
#   mysql_install_db --user=mysql
#
# Note that the mysql user must exist in /etc/passwd, and the created files
# will be owned by this dedicated user.  This is important, or else mysql
# (which runs as user "mysql") will not be able to write to the database
# later (this can be fixed with 'chown -R mysql.mysql /var/lib/mysql').
#
# To increase system security, consider using "mysql_secure_installation"
# as well.  For more information on this tool, please read:
#   man mysql_secure_installation
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: Problema primo avvio - caricamento myslq

Messaggioda hashbang » dom lug 25, 2010 14:42

nospda ha scritto:Grazie neongen per la rapida risposta...
...se il sistema non si avvia proprio come posso fare ad accedere al file?

mmmm...in breve è ciò che ti ho detto su facebook: un problema relativo al database di mysql. Comunque, benvenuto su Slacky.eu ;)

Comunque se è come per il bluetooth il comando da dare dovrebbe essere:
Codice: Seleziona tutto
# sh /etc/rc.d/mysql.d stop


Luca
Ultima modifica di hashbang il dom lug 25, 2010 14:53, modificato 1 volta in totale.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1823
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema primo avvio - caricamento myslq

Messaggioda Ansa89 » dom lug 25, 2010 14:50

atomix600 ha scritto:
Codice: Seleziona tutto
# sh /etc/rc.d/mysql.d stop

Quel file non esiste, tu intendevi dire
Codice: Seleziona tutto
#sh /etc/rc.d/rc.mysqld stop
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2620
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.7-ck1
Desktop: XFCE 4.6.1

Re: Problema primo avvio - caricamento myslq

Messaggioda hashbang » dom lug 25, 2010 14:54

sisi è vero ho messo un punto in più e neanche me ne sono accorto :)
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1823
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema primo avvio - caricamento myslq

Messaggioda nospda » lun lug 26, 2010 13:55

Grazie mille a tutti... proverò subito a seguire i vostri consigli...
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Re: Problema primo avvio - caricamento myslq

Messaggioda nospda » lun lug 26, 2010 14:05

Allora... ho provato fare ciò che mi avete detto, cioè ho provato a dare il chmod 755 a rc.mysqld ma il problema è che in rd.d non esiste rc.mysqld, secondo voi per quale motivo?
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Re: Problema primo avvio - caricamento myslq

Messaggioda Ansa89 » lun lug 26, 2010 15:02

La directory è "/etc/rc.d"; invece "/etc/rd.d" non esiste.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2620
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.7-ck1
Desktop: XFCE 4.6.1

Re: Problema primo avvio - caricamento myslq

Messaggioda nospda » lun lug 26, 2010 17:13

E' chiaro che ho fatto un errore nella digitazione quando ho scritto il post :-)... comunque nella directory /etc/rc.d ho :
rc.S
rc.dropbear
rc.ieee1394
rc.inet1
rc.pcmcia
rc.udev
rc.usb
quindi rc.mysqld non compare e quindi non posso proseguire come voi mi avete detto...
non so come fare...
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Re: Problema primo avvio - caricamento myslq

Messaggioda Ansa89 » lun lug 26, 2010 17:17

Posta l'output di:
Codice: Seleziona tutto
$ls /var/log/packages/mysql*
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2620
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.7-ck1
Desktop: XFCE 4.6.1

Re: Problema primo avvio - caricamento myslq

Messaggioda nospda » lun lug 26, 2010 17:33

Ansa89 ha scritto:Posta l'output di:
Codice: Seleziona tutto
$ls /var/log/packages/mysql*


Questo è l'output
Codice: Seleziona tutto
root@slackware:/# ls/var/log/packages/mysql*
/bin/ls: cannot access /var/log/packages/mysql*: No such file or directory
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Re: Problema primo avvio - caricamento myslq

Messaggioda Ansa89 » lun lug 26, 2010 17:52

Non hai installato il pacchetto mysql, quindi non hai neanche lo script per avviarlo (come è normale che sia).
La soluzione più rapida è installare il pacchetto direttamente dal cd/dvd di slackware, oppure prenderlo da un mirror online.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2620
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.7-ck1
Desktop: XFCE 4.6.1

Re: Problema primo avvio - caricamento myslq

Messaggioda nospda » lun lug 26, 2010 17:57

Perfetto... ora allora vedo di trovare il modo di installare mysql... all'inizio mi è venuto anche a me questo dubbio ma dato che io avevo richiesto l'installazione di mysql in fase di setup non credevo ci fossero di questi problemi...
comunque vi faccio sapere se risolvo
grazie ancora
nospda
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: ven lug 23, 2010 21:03
Slackware: 13.1
Desktop: gnome
Distribuzione: ubuntu 10.04 32bit

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti