Repository 32bit  Forum
Repository 64bit  Wiki

Rallentamento senza motivo

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Rallentamento senza motivo

Messaggioda RedSkull92 » mer ago 18, 2010 12:59

Salve, ho bisogno di alcuni consigli.
Settimana scorsa ho utilizzato correttamente la slack per poi spegnere e andarmene in vacanza 3/4 giorni.
L'altro ieri al ritorno accendendo il pc ho notato che sullo schermo non compariva niente, allora facendo alcune prove e sudate varie ho smontato un pò i vari pezzi per poi rimontarli...
Oggi il pc è ripartito.
Ma il boot è rallentato in una maniera assurda, circa 2 minuti.
In oltre adesso è rallentato il tutto, magari qualche problema alla ram o agli hd...
Qualcuno ha qualche suggerimento ?
Scusate ma di hardware ne capisco davvero poco.
questo è il log di lshw http://sprunge.us/GJeC
Questo è il dmesg : http://sprunge.us/KdFX
appena raggiunge "sda"
il boot si ferma quasi del tutto rallentando parecchio.
Non è un problema di slackware visto che il sistema funziona (sto scrivendo da li), dev'essere qualche tipo di problema hardware o magari di impostazioni sbagliate nel bios (ho tolto la batteria reimpostando le opzioni di default)
Grazie per qualsiasi aiuto.
Se avete bisogno di altro basta chiedere.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Rallentamento senza motivo

Messaggioda slux » mer ago 18, 2010 13:23

Il sistema è rallentato perchè il disco è entrato in modalità PIO mode 4,in soldoni una schifezza.Questo è sintomo di un'imminente guasto del disco.
Prova da console ad eseguire questo comando:
Codice: Seleziona tutto
smartctl --all /dev/sda
da utente root.
Poi posta il risultato.
Ah mi sembra superfluo dirtelo: fai un backup il prima possibile.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: Rallentamento senza motivo

Messaggioda RedSkull92 » mer ago 18, 2010 13:50

questo è l'output di /dev/sda : http://sprunge.us/LLKL
e questo di /dev/sdb : http://sprunge.us/RQZj
ora provvedo per il backup.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Rallentamento senza motivo

Messaggioda RedSkull92 » mer ago 18, 2010 15:21

ho attivato smart con -s on
questi sono gli output.
sda: http://sprunge.us/hTdQ
sdb: http://sprunge.us/WeNP
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Rallentamento senza motivo

Messaggioda slux » mer ago 18, 2010 17:16

Il disco sdb è messo davvero male.
Puoi provare il sistema senza sdb ?
Anche sda ha avuto un problema ,ma è solo un errore.
Diciamo che è meglio se li cambi entrambi, se vuoi affidabilità.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: Rallentamento senza motivo

Messaggioda RedSkull92 » mer ago 18, 2010 17:51

sdb è il disco più vecchio, è quello dove risiede Slackware.
Sarei curioso di sapere da dove hai notato certe cose, so praticamente nulla di queste cose e mi piacerebbe capire.
Esiste un qualche tool o un'altra soluzione per levarlo dalla modalità PIO 4 ?
Posso provare a scambiare i cavetti, magari è messo sbagliato e da questo problema.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Rallentamento senza motivo

Messaggioda erio » mer ago 18, 2010 18:26

se sono sata guarda la plastica sopra i pin del cavo sata a volte si bomba e perde il contatto,io ho il pc aperto e rimedio subito,gli errori che dà sono random a volte il boot non lo fà a volte si blocca,il più delle volte e il cavo sata messo male che crea falsi contatti,almeno a me.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1064
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Rallentamento senza motivo

Messaggioda slux » mer ago 18, 2010 18:41

Il pio mode 4 viene selezionato da kernel perchè non riesce a mantenere una velocità di comunicazione più alta con il disco(il disco non sta al passo).
Gli errori a cui mi riferisco sono scritti nei log che hai postato.
Nel log di sdb si legge :

ATA Error Count: 565 (device log contains only the most recent five errors)


565 errori !!!!
e poi successivamente ci sono i dettagli degl'ultimi 5 errori.
Se hai un sistema dual-boot con windows, e credo proprio di sì,scarica questa utility : http://crystalmark.info/software/CrystalDiskInfo/index-e.html
Altrimenti esiste gsmartcontrol per linux : http://slackbuilds.org/repository/13.1/system/gsmartcontrol/
Comunque sia ,se vuoi ricontrollare i cavetti ed i jumper,quello non ti costa nulla.Immagino che il vecchio disco ed il lettore cd siano sullo stesso canale ide,controlla bene i jumper.Il disco come master ed il lettore come slave.Prova anche a scollegare il lettore cd non si sa mai,magari disturba il canale.Come ultima prova cambierei anche la piattina ide anche se non sicuro che possa darti aiuto.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: Rallentamento senza motivo

Messaggioda RedSkull92 » gio ago 19, 2010 21:04

Proverò a cercare di smanettare con i fili.
Perchè la situazione non è cambiata (entrambi i controlli non mi hanno dato errori)
Non esistono altre soluzioni a parte sostituire il disco ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite