Repository 32bit  Forum
Repository 64bit  Wiki

Avant Window Navigator e dipendenze

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Avant Window Navigator e dipendenze

Messaggioda gigiobagiano » gio set 09, 2010 15:50

Oddio non so, io mi riferisco a questa parte:
Codice: Seleziona tutto
# Handle the schemas and such (hopefully) properly
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults"
for RAWNAME in $(find $PKG/etc/gconf/schemas -name "*.schemas") ; do
  SCHEMA=$(basename $RAWNAME)
  cat << EOF >> $PKG/install/doinst.sh
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
chroot . gconftool-2 --makefile-install-rule /etc/gconf/schemas/$SCHEMA 1>/dev/null
EOF
done
for RAWNAME in $(find $PKG/etc/gconf/schemas -name "*.entries") ; do
  ENTRY=$(basename $RAWNAME)
  cat << EOF >> $PKG/install/doinst.sh
GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
chroot . gconftool-2 --direct \
  --config-source=$GCONF_CONFIG_SOURCE \
  --load /etc/gconf/schemas/$ENTRY 1>/dev/null
EOF
done
unset GCONF_CONFIG_SOURCE

e non c'è nel tuo slackbuild, orbit e gconf gli avevo già installati, poi non so non mi sono addentrato più di tanto nella compilazione di awn, quindi non so se ti posso essere d'aiuto... ;)

Che librerie di gnome servono? dai messaggi del terminale non ne ho cavato molto...
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 504
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » gio set 09, 2010 16:17

Se noti bene, quella parte dello slackbuild non fa altro che copiare dei comandi all'interno del doinst.sh.
Quella parte è gia integrata nel doinst.sh del mio pacchetto (non proprio uguale, diciamo che mi sono ispirato).

Ho controllato il pacchetto a 32bit, sembra che ci voglia gnome-menus, che pare non avere altre dipendenze. Strano, io ricordavo molte più librerie da dover compilare :-k
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda tom » lun set 27, 2010 23:33

Thraphyx ha scritto:Buongiorno slackers!
Ieri, preso da una voglia irrefrenabile di abbellire il desktop, ho compilato AWN e dipendenze, visto che non l'ho trovata nel repo (neanche in quello della 13.0)
Per chi non lo conoscesse, http://it.wikipedia.org/wiki/Avant_Window_Navigator .

I programmi necessari, sono
Codice: Seleziona tutto
gconf
orbit
gobject-introspection
gir-repository
vala
libdesktop-agnostic
pyxdg
libgtop
bazaar
avant-window-navigator

[ sono in ordine di compilazione, per la semplice installazione basta metterli tutti]

Sono tutti x86_64 e compilati sulla 13.1.
GConf, ORbit e pyxdg li ho presi dal repo.
GObject e Vala li ho ricompilati perchè sono solo sul repo 32bit.
Per il resto ho creato slackbuilds e pacchetti.
Ovviamente, tutti i pacchetti sono stati compilati sulla slack full pulita ;)
Io la sto testando sulla mia installazione, con GNOME, quindi vorrei sapere come si comporta con gli altri DE. :D

Spero che a qualcuno interessi, infondo è comoda :D
Questo è uno screenshot del mio desktop con AWN attiva
http://img684.imageshack.us/img684/3258/schermatay.jpg

Un "paio" di righe di spiegazione di tutte queste dipendenze per una cavolo di dock :lol:
Codice: Seleziona tutto
libdesktop-agnostic:
Dalla nuova versione di AWN, la 0.4.0 che ho compilato, è una dipendenza necessaria.

GObject-introspection:
Dipendenza di libdesktop-agnostic.

gir-repository:
Librerie extra per GObject. Senza, libdesktop-agnostic non compila.

GConf:
Per libdesktop-agnostic GConf è opzionale, tuttavia senza GConf AWN non compila.
Quindi ho compilato libdesktop-agnostic (e di conseguenza anche AWN) col supporto a GConf.Spero che a qualcuno interessi, infondo è comoda :D
Questo è uno screenshot del mio desktop con AWN attiva
libdesktop-agnostic si può ricompilare anche senza avere GCconf installato, qualora servisse per altro, ma se si installa come dipendenza di AWN, GConf è necessario.

ORbit:
Dipendenza di GConf

Vala:
Per AWN vala è opzionale, serve per le applets, mentre per libdesktop-agnostic,
nonostante requirebuilder non lo segnali come dipendenza, è necessario
affinchè la compilazione vada a buon fine.
In ogni caso è utile per eventuali applets di AWN.

Bazaar:
Sul wiki di AWN dicono che Bazaar serve solo per i developers, ma senza di esso, awm-setting, il gestore delle impostazioni di AWN, non si avvia.

pyxdg:
Dipendenza di AWN

libgtop:
Dipendenza di AWN



Io ieri ho scritto a Loris, magari se mi abilita , li metto sul repo.
Altrimenti dopo le uppo da qualche parte e posto i link :D

EDIT
Li ho uppati, ecco i link per il download dei pacchetti
-----Tutti i pacchetti a 32 bit adesso sono presenti sul repo 64 bit -----

EDIT2
Ho compilato anche i pacchetti a 32bit non presenti sul repo:
-----Tutti i pacchetti a 32 bit adesso sono presenti sul repo 32 bit -----

Ho aggiornato il link a bazaar.. la versione 64bit in realtà era una mezza i486 :lol: Ho rifatto il pacchetto

EDIT3
Rifatti i pacchetti di libdesktop-agnostic e avant-window-navigator per i486 e x86_64.
Aggiornati i link.

EDIT4
Pacchettizzato anche awn-extras, le applet per awn (versione a 32 bit sul repo)
---- Versione a 64bit presente sul repo ----

Questo è compilato senza libgnome e quindi senza le applet del menu. Se vi interessa ho anche la versione col supporto a libgnome (però è fatta sulla mia installazione personalizzata, quindi non è "degna del repository" :lol: ).
Per alcune applet, come ad esempio i feedreader, servono moduli python aggiuntivi che non ho ancora compilato. Le applet vengono comunque installate, solo che per avviarle ci vogliono gli eventuali moduli extra, che vengono segnalati dalla stessa applicazione.

EDIT5
TUTTI I PACCHETTI A 32 BIT ADESSO SONO STATI MESSI SUL REPO.

EDIT6
TUTTI I PACCHETTI A 64 BIT ADESSO SONO STATI MESSI SUL REPO.

Il programma avant-window-navigator non funziona. Inoltre il pacchetto nel repo (parlo del repo di slacky.eu) sembra avere molte meno dipendenze di quelle di cui tu parli. Ti consiglio di ridargli un'occhiata.
tom
Packager
Packager
 
Messaggi: 407
Iscritto il: dom nov 01, 2009 12:53
Nome Cognome: Tommaso D'Anna
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: xfce

Re: Avant Window Navigator e dipendenze

Messaggioda sunreal » lun set 27, 2010 23:49

Io sono ancora al punto di qualche post fa:
(avant-window-navigator:4557): GConf-CRITICAL **: gconf_value_get_list: assertion `value != NULL' failed

** ERROR **: No panels to create!
** Please check that the gconf-schema is installed.
** You might also try to run `killall gconfd-2`.
aborting...
Abortito

posso dire che ho provato AWN su slack64 e funziona discretamente.

PS Rileggendo la discussione mi sono accorto che non avevo dato seguito alle risposte al mio primo post, quindi, il mio problema è su slack 32bit, e si ho installato tutte le dipendenze di slack-required più bzr e pyxdg.

PS2 Ho anche disinstallato il pacchetto did slacky e ricompilato e creato il pacchetto ovviamente con lo slackbuild di slacky ma l'errore è lo stesso
Ultima modifica di sunreal il mar set 28, 2010 7:24, modificato 1 volta in totale.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Avant Window Navigator e dipendenze

Messaggioda brainvision » mar set 28, 2010 7:18

sunreal ha scritto:Io sono ancora al punto di qualche post fa:
(avant-window-navigator:4557): GConf-CRITICAL **: gconf_value_get_list: assertion `value != NULL' failed

** ERROR **: No panels to create!
** Please check that the gconf-schema is installed.
** You might also try to run `killall gconfd-2`.
aborting...
Abortito

posso dire che ho provato AWN su slack64 e funziona discretamente.

PS Rileggendo la discussione mi sono accorto che non avevo dato seguito alle risposte al mio primo post, quindi, il mio problema è su slack 32bit, e si ho installato tutte le dipendenze di slack-required più bzr e pyxdg.


ciao sunreal..

allora, per quanto riguarda il pacchetto (anzi i pacchetti) a 32 bit, li ho fatti io e quindi la responsabilità della mancanza nello slackbuild per awn è ovviamente mia.. purtroppo, non avendo l'abitudine di andare a vedere gli slackbuild degli altri prima di fare i miei, non avevo visto questa cosa di gconf.. ed inoltre, stranamente, a me funziona davvero bene: non riesco a far funzionare solo l'applet Pandora, che richiede una dipendenza assurda, che non ho mai sentito e che non riesco a trovare..
eppure mi sembra strano che il problema si presenti solo con gconf in gnome.. non so dire di più, al riguardo, per ora, almeno.

inoltre ti confesso che avevo letto l'avviso nel package report e qui sul forum già da un paio di settimane, ma in questo periodo ho avuto davvero pochissimo tempo perché mi sto trasferendo ed ho avuto un casino di cose da fare. ora, non appena avrò un paio di giorni liberi, prometto di rifare i pacchetti e di inserire la parte mancante.. giuro!!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Avant Window Navigator e dipendenze

Messaggioda sunreal » mar set 28, 2010 7:28

brainvision ha scritto:ma in questo periodo ho avuto davvero pochissimo tempo perché mi sto trasferendo ed ho avuto un casino di cose da fare. ora, non appena avrò un paio di giorni liberi, prometto di rifare i pacchetti e di inserire la parte mancante.. giuro!!

Non so se il mio post suonasse come una lamentela, ma non lo era assolutamente, era solo il mio contributo alla discussione, per renderti-vi partecipi delle mie problematiche. Se poi tra un po' di tempo il pacchetto dovesse funzionare ovvio che ne sarò contento, tranquillo. Ciao e buon trasloco.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Avant Window Navigator e dipendenze

Messaggioda brainvision » mar set 28, 2010 8:38

sunreal ha scritto:Non so se il mio post suonasse come una lamentela, ma non lo era assolutamente, era solo il mio contributo alla discussione, per renderti-vi partecipi delle mie problematiche. Se poi tra un po' di tempo il pacchetto dovesse funzionare ovvio che ne sarò contento, tranquillo. Ciao e buon trasloco.


ma no figurati!, non ti preoccupare di questo!! :D
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Avant Window Navigator e dipendenze

Messaggioda Ansa89 » mar set 28, 2010 9:04

sunreal ha scritto:Io sono ancora al punto di qualche post fa:
(avant-window-navigator:4557): GConf-CRITICAL **: gconf_value_get_list: assertion `value != NULL' failed

** ERROR **: No panels to create!
** Please check that the gconf-schema is installed.
** You might also try to run `killall gconfd-2`.
aborting...
Abortito


Come già detto, quel problema è noto e la soluzione migliore sarebbe una nuova release di awn con supporto per il nuovo libdesktop-agnostic.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2626
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.18.0-ck1
Desktop: XFCE 4.6.1

Re: Avant Window Navigator e dipendenze

Messaggioda sunreal » mar set 28, 2010 11:06

Ansa89 ha scritto:Come già detto, quel problema è noto e la soluzione migliore sarebbe una nuova release di awn con supporto per il nuovo libdesktop-agnostic.

Ma allora non dovrebbe funzionare neanche a 64bit, o sbaglio?
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Avant Window Navigator e dipendenze

Messaggioda Ansa89 » mar set 28, 2010 11:13

Non lo so, io parlo per la versione a 32 bit.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2626
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.18.0-ck1
Desktop: XFCE 4.6.1

Re: Avant Window Navigator e dipendenze

Messaggioda LoneStar » mar set 28, 2010 13:23

Ciao,

già da qualche mese mi sono compilato awn 0.4.0 e lo uso con successo sia su slack32 che su slack64

magari a qualcuno possono essere d'aiuto queste brevi indicazioni:
http://www.lonestar.it/2010/05/informatica/avant-window-navigator-awn-040-su-slackware64/

sicuramente ci sono mancanze ed errori, siate comprensivi ;)
Avatar utente
LoneStar
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: ven ago 15, 2008 10:10
Località: Ragusa
Slackware: current 32 & 64
Kernel: 3.4.2
Desktop: KDE4

Re: Avant Window Navigator e dipendenze

Messaggioda brainvision » mar set 28, 2010 15:31

allora, per ricapitolare: i pacchetti che riguardano awn a 32bit hanno una mancanza nello slackbuild che a me personalmente (ma anche ad altri, da quanto ho letto) non inficia il funzionamento.
la versione a 64bit (non mia), da quanto ho capito ha invece questa parte..

quindi parlare di non funzionamento è errato: credo che possa capitare più spesso che non vada con gnome. io ad esempio ho xfce e va alla grande.
(anche se ultimamente sto prefendo cairo-dock, ma questa è un'altra storia! :D :D )
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Avant Window Navigator e dipendenze

Messaggioda hashbang » mar set 28, 2010 15:54

brainvision ha scritto:non riesco a far funzionare solo l'applet Pandora, che richiede una dipendenza assurda, che non ho mai sentito e che non riesco a trovare
Se non hai già risolto; che dipendenza è?
There's a certain kind of programmer who'll look at any problem and say, 'I know, I will use XML.' Now he has two problems.
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1842
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Avant Window Navigator e dipendenze

Messaggioda sunreal » mar set 28, 2010 22:27

LoneStar ha scritto:Ciao,

già da qualche mese mi sono compilato awn 0.4.0 e lo uso con successo sia su slack32 che su slack64

magari a qualcuno possono essere d'aiuto queste brevi indicazioni:
http://www.lonestar.it/2010/05/informatica/avant-window-navigator-awn-040-su-slackware64/

sicuramente ci sono mancanze ed errori, siate comprensivi ;)


Con il tuo salckbuild mi funziona, anche se come con il pacchetto preso dal repo di slacky, sulla slack 13.1 a 64 bit, non mi funziona neanche una applets, ma per adesso meglio che niente. Grazie.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Avant Window Navigator e dipendenze

Messaggioda LoneStar » mar set 28, 2010 22:46

sunreal ha scritto:Con il tuo salckbuild mi funziona, anche se come con il pacchetto preso dal repo di slacky, sulla slack 13.1 a 64 bit, non mi funziona neanche una applets, ma per adesso meglio che niente. Grazie.


per le applet devi vedere di installare tutte le librerie citate nelle dipendenze di awn-extras. http://wiki.awn-project.org/Awn_Extras:Dependency_Matrix
Avatar utente
LoneStar
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: ven ago 15, 2008 10:10
Località: Ragusa
Slackware: current 32 & 64
Kernel: 3.4.2
Desktop: KDE4

PrecedenteProssimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite