Repository 32bit  Forum
Repository 64bit  Wiki

multilib all-in-one

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: multilib all-in-one

Messaggioda ZeroUno » sab set 25, 2010 16:57

Wine è per 32 bit
anzi, wine è opensource quindi si compila anche a 64 bit, ma in tal caso puoi farci girare solamente programmi windows a 64 bit ;-)
quindi va usata la versione a 32bit
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda robbybby » sab set 25, 2010 17:04

1. Scaricato Wine 1.3.3 da Slacky. assieme alle sue dipendenze.
2. Installato.
3. Funziona (con le multilib di ZeroUno, of course). Ho lanciato write, skype e winhelp, direttamente dalla partizione di Win7. Firefox, e altri programmi, non funzionano, ma penso sia colpa di wine.
4. Yuppiiiieieieieieie!!! :)

Se ti servono altri dati, o prove, chiedi pure. La partizione di test è lì apposta.

PS: ho scaricato firefox dal sito, l'ho installato in wine, e funziona!
Quindi direi che le multilib di ZeroUno sono promosse a pieni voti.

Non avevo mai usato Wine, e forse si vede :)
Adesso devo vedere se funziona TomTome Home, perché mi servirebbe.

PS: nel pacchetto wine 1.3.3 manca wine_gecko-1.1.0-x86.cab.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1174
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: multilib all-in-one

Messaggioda robbybby » dom set 26, 2010 16:24

Mi è venuto in mente un altro programma che esiste solo a 32 bit: GoogleEarth.
Ho appena installato la versione a 32 bit, e funziona.
E con questo direi che il test delle multilib di ZeroUno può dirsi concluso, in maniera più che positiva. O no? :)
@ZeroUno: le metti nel repository ufficiale?
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1174
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: multilib all-in-one

Messaggioda ZeroUno » dom set 26, 2010 22:23

L'ho appena caricato... sarà disponibile a breve.

Mentre per current: compat32-libraries-1.0_current-x86_64-1sl
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda ZeroUno » gio mag 19, 2011 13:46

compat32-libraries-1.1_13.37-x86_64-1sl.txz

Ho fatto la versione per slackware 13.37 ma ho poco modo di testarla.

Qualcuno sa darmi qualche riscontro?

A breve sarà disponibile sul repository.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda neongen » gio mag 19, 2011 21:38

adobe reader:
Codice: Seleziona tutto
error while loading shared libraries: libgdk_pixbuf_xlib-2.0.so.0: cannot open shared object file: No such file or directory


google-earth:
Codice: Seleziona tutto
/usr/bin/google-earth: line 43: ./googleearth-bin: File o directory non esistente
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: multilib all-in-one

Messaggioda ZeroUno » gio mag 19, 2011 22:16

in slackware 13.37 alcune librerie sono state spostate in altri pacchetti rispetto alla 13.1; alcune tolte alcune aggiunte. Per questo non so se l'elenco delle librerie che ho inserito sono sufficienti.

Dammi un ldd di googleearth-bin e del binario di adobe reader che gli do una occhiata domani.
ti funzionava con il pacchetto precedente?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda neongen » ven mag 20, 2011 12:35

prima usavo le librerie di bluewhite64, adesso volevo provare il tuo pacchetto... in ogni caso:

acroread:
Codice: Seleziona tutto
ldd acroread | grep not
        libBIB.so => not found
        libBIBUtils.so => not found
        libACE.so => not found
        libAGM.so => not found
        libCoolType.so => not found
        libAXE8SharedExpat.so => not found
        libJP2K.so => not found
        libAdobeXMP.so => not found
        libicuuc.so.36 => not found
        libgdk_pixbuf_xlib-2.0.so.0 => not found
        libgdk_pixbuf-2.0.so.0 => not found
        libResAccess.so => not found
        libgdk_pixbuf-2.0.so.0 => not found
        libgdk_pixbuf-2.0.so.0 => not found

a parte gdk-pixbuf, le altre segnate mancanti sono presenti nell'installazione di acroread

per google-earth: da sempre l'errore file not found, nonostante il link /lib/ld-linux
Codice: Seleziona tutto
ldd googleearth-bin | grep not
        libgoogleearth_free.so => not found
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: multilib all-in-one

Messaggioda ZeroUno » ven mag 20, 2011 14:56

libgdk_pixbuf è giusto una libreria scorporata e messa in un altro pacchetto.
compat32-libraries-1.1.02_13.37-x86_64-1sl.txz

Ora dovrebbe andare.

per quanto riguarda earth però la libreria che cerca dovrebbe essere nel pacchetto di earth stesso.
Funzionava con la precedente versione di compat32-libraries?

fai una find di quella libreria e vedi in che path si trova.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda neongen » ven mag 20, 2011 15:37

si si, google-earth non trova le sue stesse librerie; l'avevo scritto nel post precedente ma si deve essere perso rimaneggiando il testo :lol:
intendevo dire che il problema non è nuovo, ma prima avevo risolto con il symlink /lib/ld-linux.so.2 -> ld-2.13.so mentre adesso non va più.

adobe reader invece funziona, grazie!
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: multilib all-in-one

Messaggioda ZeroUno » ven mag 20, 2011 16:01

Il pacchetto che ti ho dato lo fa lui il link. Quello precedente (1.0) linkava a ld-2.11.so

Da dove hai scaricato earh? se me lo passi lo installo e provo io.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda ZeroUno » ven mag 20, 2011 16:31

Ho provato a scaricare l'ultimo dal repository slacky e mi funziona.

se dai ls -l /lib/ld-lsb.so.3 cosa ti da?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda neongen » ven mag 20, 2011 16:57

risolto: ld-lsb.so.3 -> ld-2.13.so era questo il link che mancava
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: multilib all-in-one

Messaggioda ZeroUno » ven mag 20, 2011 17:46

neongen ha scritto:risolto: ld-lsb.so.3 -> ld-2.13.so era questo il link che mancava

lo crea googleearth in fase di installazione
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: multilib all-in-one

Messaggioda neongen » ven mag 20, 2011 19:13

#-o creando il pacchetto sulla 64bit non lo mette al posto giusto
Codice: Seleziona tutto
( cd lib64 ; ln -sf /lib64/ld-linux.so.2 ld-lsb.so.3 )
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

PrecedenteProssimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 2 ospiti