Repository 32bit  Forum
Repository 64bit  Wiki

current <-> stable; aggiornamento librerie

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

current <-> stable; aggiornamento librerie

Messaggioda ZeroUno » gio ott 21, 2010 9:33

Nella data del 13 Ottobre, in current sono state aggiornate le librerie di sistema, passando dalla glibc-2.11.1 della slackware 13.1 stable alla glibc-2.12.1


Come conseguenza si otterrà che i pacchetti finora compilati finora potrebbero comportarsi in modo diverso da sistema a sistema. Ecco la caseistica che mi viene in mente:

1) il mio sistema è installato da 0 con current:
a) scarico e installo pacchetti compilati per stable: se il pacchetto va a cercare la libreria diretta 2.11.1 allora il pacchetto non funzionerà; se va a cercare la libreria versione 2.* allora la troverà e il pacchetto funzionerà; nel primo caso tuttavia talvolta è sufficiente andare nella /lib e, della libreria richiesta, fare un link simbolico a quello della 2.12.1; a meno di speciali (e rare) incompatibilità verso il basso, il pacchetto funzionerà perfettamente.
b) scarico e installo un pacchetto compilato current dopo il 13 Ottobre: il pacchetto funzionerà perfettamente
2) il mio sistema è stato aggiornato a current: l'aggiornamento non elimina le librerie 2.11.1 così i pacchetti compilati su 13.1 o current precedenti al 13 Ottobre o current successive a tale data funzioneranno perfettamente salvo eventuali incompatibilità verso il basso.
3) il mio sistema è 13.1 stable; i pacchetti compilati per current successive al 13 Ottobre potrebbero:
a) cercare direttamente la libreria 2.12.1; in tal caso il pacchetto non funzionerà; lo si potrebbe forzare con un link simbolico a quelle del 2.11.1
b) cercare la libreria 2.*; in tal caso, a meno di utilizzo di particolari feature non ancora presenti nella 2.11.1, il pacchetto dovrebbe funzionare correttamente.


credo di aver esaurito la caseistica.


Ciao
01
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4300
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: current <-> stable; aggiornamento librerie

Messaggioda brainvision » ven ott 22, 2010 8:11

scusa, solo per curiosità, ma non si dice casistica? Ho provato a cercare caseistica ma non risulta da nessuna parte!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: current <-> stable; aggiornamento librerie

Messaggioda ZeroUno » ven ott 22, 2010 9:03

che fiscalismo...
http://www.google.it/#q=caseistica : "Forse cercavi: casistica" :-)

grazie della segnalazzione e della corezione.
Io e l'itagliano non andiamo molto daccordo
ma a d'agio a d'agio imparo...

:-D :-D :-D
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4300
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti