[RISOLTO] GTKPOD - configure: error:id3tag

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
amonamarth
Linux 1.0
Linux 1.0
Messaggi: 27
Iscritto il: lun mar 03, 2008 21:20
Slackware: 13.37
Desktop: kde 4

[RISOLTO] GTKPOD - configure: error:id3tag

Messaggioda amonamarth » mer feb 02, 2011 22:14

Ciao a tutti,
ho un problema nella compilazione di GTKPOD .
Ho scaricato la versione per Slackware 13.1 da Slackbuilds.org .
Eseguendo lo script per creare il pacchetto ottengo l'errore

Codice: Seleziona tutto

checking for library containing id3_frame_field... no
configure: error: *** id3tag >= 0.15 lib not found (0.14 will not work!)

Il pacchetto id3tag è correttamente installato

Codice: Seleziona tutto

$ ll /var/log/packages/ |grep id3
-rw-r--r--  1 root root 2.0K Feb  1 19:35 id3lib-3.8.3-x86_64-2_SBo
-rw-r--r--  1 root root  549 Feb  1 19:37 id3v2-0.1.11-x86_64-2_SBo
-rw-r--r--  1 root root 1001 Jan 31 23:59 libid3tag-0.15.1b-x86_64-3

Lo stesso problema ce l'ho se cerco di compilare da sorgente, senza utilizzare lo Slackbuild.
Utilizzo Slackware64-current aggiornata.
La versione dei sorgenti di GTKPOD è gtkpod-0.99.14.tar.gz
Grazie a chiunque possa darmi un suggerimento.
AmonAmarth
Ultima modifica di amonamarth il gio feb 03, 2011 20:48, modificato 1 volta in totale.

Avatar utente
boh
Linux 3.x
Linux 3.x
Messaggi: 1011
Iscritto il: ven set 16, 2005 0:00
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3
Località: Milano
Contatta:

Re: GTKPOD - configure: error:id3tag

Messaggioda boh » mer feb 02, 2011 23:48

Capisco che non centra con l'errore che hai postato, ma sulla pagina di slackbuild.org c'è scritto anche questo:
This requires libgnomecanvas and optionally libmp4v2.

Li hai installati?
Magari è correlato...

EDIT:
Confermo!
Ho installato i seguenti pacchetti: id3lib-3.8.3-x86_64-1sl, libid3tag-0.15.1b-x86_64-3, libgnomecanvas-2.30.1-x86_64-1sl e mp4v2-1.9.1-x86_64-2sl; poi ho eseguito lo slackbuild e ha creato il pacchetto senza problemi!
"Be yourself. Everyone else is already taken." ~ Oscar Wilde

Avatar utente
amonamarth
Linux 1.0
Linux 1.0
Messaggi: 27
Iscritto il: lun mar 03, 2008 21:20
Slackware: 13.37
Desktop: kde 4

Re: GTKPOD - configure: error:id3tag

Messaggioda amonamarth » gio feb 03, 2011 14:08

boh ha scritto:Capisco che non centra con l'errore che hai postato, ma sulla pagina di slackbuild.org c'è scritto anche questo:
This requires libgnomecanvas and optionally libmp4v2.

Li hai installati?
Magari è correlato...


Si, sono correttamente installati...

Codice: Seleziona tutto

$ ll /var/log/packages/ |grep canvas
-rw-r--r--  1 root root  14K Jan 31 14:22 libgnomecanvas-2.30.1-x86_64-1_SBo
$ ll /var/log/packages/ |grep mp4
-rw-r--r--  1 root root 1.7K Jan 31 14:21 libmp4v2-1.9.1-x86_64-3_SBo


Grazie per la risposta.

Avatar utente
conraid
Staff
Staff
Messaggi: 12649
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: GTKPOD - configure: error:id3tag

Messaggioda conraid » gio feb 03, 2011 15:04

lo da anche a me sulla -current (sulla 13.1 non ho provato, ma credo che il "problema" sia solo su -current"), ma sinceramente non ho indagato più di tanto, visto che la versione in sviluppo ha troppe dipendenze gnomesche, quindi in futuro fare il pacchetto richiederà troppi altri pacchetti. Per esempio richiede libanjuta, che vedo che a sua volta richiede troppe librerie di gnome

Avatar utente
conraid
Staff
Staff
Messaggi: 12649
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: GTKPOD - configure: error:id3tag

Messaggioda conraid » gio feb 03, 2011 15:17

ho riprovato oggi con la versione 1.0.0 e funziona, probabilmente un aggiornamento in -current ha risolto la cosa

Avatar utente
amonamarth
Linux 1.0
Linux 1.0
Messaggi: 27
Iscritto il: lun mar 03, 2008 21:20
Slackware: 13.37
Desktop: kde 4

Re: GTKPOD - configure: error:id3tag

Messaggioda amonamarth » gio feb 03, 2011 15:36

conraid ha scritto:ho riprovato oggi con la versione 1.0.0 e funziona, probabilmente un aggiornamento in -current ha risolto la cosa


Appena possibile proverò.
Grazie mille.
AmonAmarth

Avatar utente
conraid
Staff
Staff
Messaggi: 12649
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: GTKPOD - configure: error:id3tag

Messaggioda conraid » gio feb 03, 2011 15:38

ah, la versione 1.0.0 non richiede gnomecanvas

Avatar utente
amonamarth
Linux 1.0
Linux 1.0
Messaggi: 27
Iscritto il: lun mar 03, 2008 21:20
Slackware: 13.37
Desktop: kde 4

Re: GTKPOD - configure: error:id3tag

Messaggioda amonamarth » gio feb 03, 2011 20:47

conraid ha scritto:ho riprovato oggi con la versione 1.0.0 e funziona, probabilmente un aggiornamento in -current ha risolto la cosa

Dunque:
dopo aver aggiornato tutti i pacchetti, compresi quelli del 1 febbraio, sono riuscito nella compilazione.
E gtkpod funziona.
Forse , come ha detto Conraid, qualche aggiornamento nella current ha risolto qualcosa.
Risolto.
Grazie a tutti. =D> =D> =D>
AmonAmarth

Avatar utente
amonamarth
Linux 1.0
Linux 1.0
Messaggi: 27
Iscritto il: lun mar 03, 2008 21:20
Slackware: 13.37
Desktop: kde 4

Re: GTKPOD - configure: error:id3tag

Messaggioda amonamarth » ven feb 04, 2011 20:15

conraid ha scritto:ah, la versione 1.0.0 non richiede gnomecanvas


già già !!!
:thumbright: :thumbright:
Grazie.


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti