Repository 32bit  Forum
Repository 64bit  Wiki

kernel panic saltuario

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

kernel panic saltuario

Messaggioda boh » lun nov 22, 2010 15:07

Ciao a tutti!
Il mio problema è praticamente riassunto nel titolo; in pratica del tutto casualmente durante il boot si verifica un kernel panic.
Il problema posso intuire a cosa si riferisca, ma non saprei come risolverlo.
Per farvi capire, ho fatto una foto allo schermo con quello che rimane dell'errore.

http://www.iouppo.com/life/img/fbee5718 ... 0147ba.JPG

Il mio disco è partizionato nel seguente modo (disco da 1TB):
    /dev/sdb1 /home 910GB
    /dev/sdb2 / 30GB
    /dev/sdb3 swap 512MB
    /dev/sdb4 60GB circa

sdb1 e sdb2 ospitano slackware 13.1_64; sdb4 ospita Ubuntu 10.04_64 (mi serve per il progetto che sto svolgendo con CUDA) e sdb3 è la swap di entrambi i sistemi operativi.

Qualcuno sa dirmi a cosa può essere dovuto tale errore? Servono altre informazioni?
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: kernel panic saltuario

Messaggioda phobos3576 » lun nov 22, 2010 18:37

E' il solito problema dovuto al fatto che il kernel al boot non trova il modo di accedere al disco per caricare i moduli più importanti e cioè, in particolare, il controller dell'hd e il tipo di filesystem da usare; generalmente, questo succede quando ricompili il kernel disattivando l'initramdisk.
Il problema si risolve compilando direttamente nel kernel il driver del controller dell'HD e del tipo di filesystem da usare; ad esempio, se usi EXT4 devi compilare EXT4 nel kernel e gli altri filesystem come moduli.

Se cerchi nel forum troverai centinaia di problemi uguali al tuo.

Strano però che il kernel panic sia saltuario; dovrebbe verificarsi ad ogni boot.
Potrebbe trattarsi allora di qualche altro problema.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: kernel panic saltuario

Messaggioda boh » mar nov 23, 2010 0:44

Grazie per la risposta!
Sì, capita apparentemente random...
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: kernel panic saltuario

Messaggioda boh » gio apr 21, 2011 10:26

Ciao a tutti!
Riesumo il topic perchè il kernel panic del primo post ha ricominciato a presentarsi più frequentemente :|
Ho letto qui sul forum i vari topic che riguardavano il mio stesso problema, ma le differenze sostanziali sono due:

--- Io non ho ricompilato nessun kernel, quello che uso è il 2.6.33.4 (default su slackware 13.1); questa slackware è semplicemente stata installata (non aggiornata) su un PC nuovo.
--- Questo kernel panic è saltuario.

Qualcuno ha qualche idea in proposito? Come faccio a verificare l'effettivo caricamento dei moduli del filesystem nel kernel?
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: kernel panic saltuario

Messaggioda darkstaring » gio apr 21, 2011 22:01

Strano errore.... io proverei ad eseguire e2fsck su tutte le partizioni... non sò se possa essere dato da questo, prova :o


Altra cosa, quale bootloader usi? quello di slack o quello di ubuntu?..
Verifica che sia apposto anche quello

Ciao :)
darkstaring
Linux 2.4
Linux 2.4
 
Messaggi: 364
Iscritto il: mer ott 13, 2010 12:55
Slackware: Current
Desktop: xfce

Re: kernel panic saltuario

Messaggioda urka58 » gio apr 21, 2011 22:31

Prova a dare 5 secondi di ritardo al boot in modo che ci sia un settle del disco. Succede frequentemente con i dischi USB, ma ci sono in giro dischi SATA, soprattutto di grande capacità un po' pigri...
Nella sezione iniziale del lilo.conf aggiungi la riga
Codice: Seleziona tutto
rootdelay = 5

prova e poi ci dici
Ciao
Avatar utente
urka58
Linux 2.6
Linux 2.6
 
Messaggi: 530
Iscritto il: mer dic 07, 2005 23:29

Re: kernel panic saltuario

Messaggioda boh » gio apr 21, 2011 22:58

Grazie per le risposte!
Per provare e2fsck devo avere la partizione smontata quindi al momento non posso farlo, provo appena vado sull'altra partizione.
Intanto ho aggiunto la riga di codice al lilo.conf:
Codice: Seleziona tutto
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sdc
rootdelay = 5

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used. We don't specify it here, as there's just one column.
bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/sda1
label = Windows7_64
table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sdb2
label = Slack13.1_64
read-only
# Linux bootable partition config ends
#Ubuntu
image = /mnt/hd/vmlinuz
root = /dev/sdb4
label = Ubuntu10.04_64
read-only
#Fine Ubuntu


Faccio sapere nei prossimi giorni :)

EDIT: quando lancio lilo mi dice
Unrecognized token "rootdelay" at or above line 9 in file '/etc/lilo.conf'
Come mai non lo riconosce?
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: kernel panic saltuario

Messaggioda urka58 » gio apr 21, 2011 23:10

perchè va passato come parametro al kernel :-( colpa mia...non è un comando Lilo.
Dal momento che usi anche ubuntu mettilo nella sezione slackware, visto che ubuntu mi pare di capire non soffra del problema.
Codice: Seleziona tutto
append = rootdelay=5

Ciao
Avatar utente
urka58
Linux 2.6
Linux 2.6
 
Messaggi: 530
Iscritto il: mer dic 07, 2005 23:29

Re: kernel panic saltuario

Messaggioda murdock » ven apr 22, 2011 3:41

Il connettore SATA mi ha sempre, ed ha sempre dato parecchi problemi, va pulito spesso.
Prova a staccare il connettore di alimentazione ed il cavo sata ripetutamente per almeno 5/6 volte e riprova.
Se vuoi essere più preciso pulisci i connettori con un disessicante secco o gomma da penna (quella blu).
Fatto questo puoi almeno escludere il problema hardware.

Saluti,
MuRdOcK
Avatar utente
murdock
Linux 2.4
Linux 2.4
 
Messaggi: 451
Iscritto il: ven mag 25, 2007 11:58
Slackware: 64 14.1
Kernel: 3.14.4
Desktop: KDE 4.12.5

Re: kernel panic saltuario

Messaggioda boh » ven apr 22, 2011 10:02

Allora ho provato a mettere l'append nella sezione slackware, ma ho ottenuto questo:
Syntax error at or above line 69 in file '/etc/lilo.conf'


Allora ho provato a metterlo ancora nella sezione dei parametri da passare al kernel come
Codice: Seleziona tutto
append="rootdelay=5"
ma ottengo questo messaggio:
Duplicate entry 'append' at or above line 8 in file '/etc/lilo.conf'


@murdock: in giornata provo :) Ma intendi il connettore SATA nel disco o nella scheda madre?
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: kernel panic saltuario

Messaggioda rik70 » ven apr 22, 2011 10:39

boh ha scritto:Allora ho provato a mettere l'append nella sezione slackware, ma ho ottenuto questo:
Duplicate entry 'append' at or above line 8 in file '/etc/lilo.conf'



Questo errore credo sia dovuto al fatto che ci sono 2 entry "append" in lilo.conf

Sulla base del lilo.conf che hai postato sopra, dovresti modificarlo così (alla riga 7 circa):
Codice: Seleziona tutto
# Append any additional kernel parameters:
append=" vt.default_utf8=0 rootdelay=5"


eliminando - ovviamente - l' "append=" che hai aggiunto tu successivamente.

Bye
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1040
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: kernel panic saltuario

Messaggioda murdock » ven apr 22, 2011 11:59

boh ha scritto:@murdock: in giornata provo :) Ma intendi il connettore SATA nel disco o nella scheda madre?

Puliscili tutti e due, sulla scheda madre la gomma non puoi passarla, rischi di rompere qualcosa.
Sulla MoBo limitati a sfilare e reinfilare il connettore ripetutamente.

Saluti,
MuRdOcK
Avatar utente
murdock
Linux 2.4
Linux 2.4
 
Messaggi: 451
Iscritto il: ven mag 25, 2007 11:58
Slackware: 64 14.1
Kernel: 3.14.4
Desktop: KDE 4.12.5

Re: kernel panic saltuario

Messaggioda Mario Vanoni » ven apr 22, 2011 12:44

boh ha scritto:Per provare e2fsck devo avere la partizione smontata quindi al momento non posso farlo, provo appena vado sull'altra partizione.

su Slackware 12.2
touch /etc/forcefsck
al prossimo boot e2fsck incondizionato di tutto
alla fine/al boot il file viene cancellato

lo uso una tantum con FS che hanno tune2fs -c troppo differenti per conteggio
Mario Vanoni
Iper Master
Iper Master
 
Messaggi: 3174
Iscritto il: lun set 03, 2007 20:20
Località: Cuasso al Monte (VA)
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey

Re: kernel panic saltuario

Messaggioda boh » gio apr 28, 2011 9:38

Ho seguito il consiglio di murdock finora.
A breve passerò alla 13.37 quindi vedrò a quel punto se il problema si verificherà allo stesso modo.
Ho notato però una cosa: dando
Codice: Seleziona tutto
uname -a
ottengo
Codice: Seleziona tutto
Linux darkstar 2.6.33.4 #3 SMP Tue Sep 21 17:42:09 CDT 2010 x86_64 Intel(R) Core(TM) i7 CPU         950  @ 3.07GHz GenuineIntel GNU/Linux


e Pat (nelle RELEASE_NOTES della 13.37, ma è un discorso che vale anche per la 13.1) dice:
The best kernel to run (even on a one CPU/core machine) is the
generic SMP one, but that needs an initrd [...]


Ora io ho un SMP, ma non ho nessun initrd!
Il problema può essere quello? O non dovrebbe essere saltuario se si trattasse di quello?
In caso non centri nulla, proverò con il rootdelay ;)

@Mario: non ho ben capito, fai fare e2fsck al boot dando touch /etc/forcefsck?

Intanto grazie per le risposte e per il tempo che mi state dedicando :D
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 946
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.10.17
Desktop: KDE 4.10.5

Re: kernel panic saltuario

Messaggioda erio » gio apr 28, 2011 13:07

se hai il kernel huge l'initrd non ti serve, smp mi pare e' il supporto ai multiprocessori,quindi con il tuo problema non c'entra.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1069
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite