Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Avvio di altri sistemi operativi con lilo

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Avvio di altri sistemi operativi con lilo

Messaggioda theodallago » sab mag 14, 2011 8:49

È la prima volta che uso lilo, prima usavo grub. Il problema è questo: ho aggiunto le voci Slackware13.1 e Ubuntu oltre a Slackware13.37 che era presente di default ma quando scelgo Ubuntu o Slackware 13.1 si avviano ma quando lancio startx non riconosce più ne mouse ne tastiera. Questo non succede invece con Slackware 13.37. Penso sia dovuto a lilo perchè prima di installarlo, con grub, tutto andava perfettamente e non ho più apportato modifiche a questi due SO.

Codice: Seleziona tutto
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sda
lba32

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
#vga=791
# VESA framebuffer console @ 1024x768x32k
#vga=790
# VESA framebuffer console @ 1024x768x256
#vga=773
# VESA framebuffer console @ 800x600x64k
#vga=788
# VESA framebuffer console @ 800x600x32k
#vga=787
# VESA framebuffer console @ 800x600x256
#vga=771
# VESA framebuffer console @ 640x480x64k
#vga=785
# VESA framebuffer console @ 640x480x32k
#vga=784
# VESA framebuffer console @ 640x480x256
#vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda6
  label = Ubuntu
  read-only
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Slackware13.37
  read-only
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda4
  label = Slackware13.1
  read-only
# Linux bootable partition config ends


Ultima modifica di theodallago il mar mag 17, 2011 10:41, modificato 1 volta in totale.
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE

Re: Avvio di altri sistemi operativi con lilo

Messaggioda theodallago » mar mag 17, 2011 10:41

ho formattato tutto (dovevo comunque farlo, non pensate male :lol: ) ed il problema si è risolto
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti