Repository 32bit  Forum
Repository 64bit  Wiki

Problema Nvidia gt 525m e Intel

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema Nvidia gt 525m e Intel

Messaggioda rfringuello89 » mer mag 11, 2011 14:57

Salve a tutti, sono in possesso di un DELL Inspiron 15r equipaggiato di una scheda video Nvidia gt525m e di un'altra GPU intel hd, non riesco ad avviare X perchè mi viene proposto il messaggio di device not found, in sostanza penso il problema sia che prova a usare la Intel anzichè la Nvidia. Come posso disattivare la intel??
(premetto che ho installato i driver e modificato a dovere xorg.conf)
Grazie a tutti
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 242
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: Problema Nvidia gt 525m e Intel

Messaggioda teox99 » mer mag 11, 2011 15:41

se il tuo portatile è equipaggiato con NVIDIA OPTIMUS
in poche parole ti attacchi!!!
per ora nvidia non supporta lo switch dinamico delle due gpu sotto linux e neanche pensa di farlo...
ci sono vari workaround ma per ora sperimentali.

se è il tuo caso devi blacklistare i driver nouveau, in questo modo potrai utilizzare la gpu intel.
la gpu nvidia sarà inutilizzabile e quindi (dipende dal modello) x non consumare la batteria dovresti spengerla.

comunque...

ultimamente qualcosa si sta muovendo...
puoi vedere qui:
http://www.martin-juhl.dk/2011/05/optim ... em-solved/
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 729
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: Problema Nvidia gt 525m e Intel

Messaggioda rfringuello89 » mer mag 11, 2011 15:53

Magnifico....

Grazie
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 242
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: Problema Nvidia gt 525m e Intel

Messaggioda teox99 » mer mag 11, 2011 16:15

beh mica tanto!!!
io ho appena comprato un dell xps 17 (702x) spendendo molto di più per una nvidia GT555M con 3GB di ram che attulmente è INUTILIZZATA!!!
MA PER SLACKWARE QUESTO E ALTRO!
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 729
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: Problema Nvidia gt 525m e Intel

Messaggioda ocman » lun mag 16, 2011 2:12

sembra ci siano buone novità.
http://www.phoronix.com/scan.php?page=n ... &px=OTQzMA

una domanda visto che sono prossimo all'acquisto dell'xps 17.
tralasciando il discorso delle prestazioni e del risparmio energetico e dello switch a runtime.
- se compilo il kernel senza supporto per le schede video intel integrate nella cpu o comunque faccio il blacklist del driver riesco ad utilizzare solo i driver Nouveau al boot successivo per la scheda nvidia senza workaround?
- se nel kernel non compilo ne i nouveau ne quelli intel e installo gli nvidia propietari al boot successivo funziona X senza workaround?
grazie
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana

Re: Problema Nvidia gt 525m e Intel

Messaggioda ponce » lun mag 16, 2011 6:13

no, perche' se non hai un opzione nel bios per usare solo la nvidia, sta molto probabilmente a significare che il display e' collegato alla scheda intel (come nella maggior parte dei modelli recenti) e quindi i vari driver nvidia non funzioneranno.
Avatar utente
ponce
Linux 3.x
Linux 3.x
 
Messaggi: 1467
Iscritto il: mer mar 05, 2008 16:45
Località: limbo
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.16-rc7
Desktop: lxde

Re: Problema Nvidia gt 525m e Intel

Messaggioda teox99 » lun mag 16, 2011 8:54

@ocman: il merge di David Airile comprende l'inserimento del modulo acpicall nel kernel x lo switch software della scheda integrata.

posso dirti che il dell xps 17 (L702x) è completamente compatibile con slackware 13.37
logicamente senza supporto windows like di optimus, ma se prendi una cpu abbastanza potente come i7-2630QM puoi usare nel frattempo la gpu intel che ti assicuro è ottima.
comunque è solo questione di tempo una soluzione funzionale sarà trovata forse dopo l'estate.
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 729
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: Problema Nvidia gt 525m e Intel

Messaggioda ocman » lun mag 16, 2011 9:33

ciao teox99
grazie della risposta!
facevo proprio riferimento al L702x; ho cercato su internet e sembrerebbe proprio non esserci un'opzione su bios per selezionare la scheda nvidia.
per questioni varie sono sicuro che andrò sulla vers. core i3 e scheda video nvidia gt550m (629€)

cosa intendi completamente compatibile? con il kernel della 13.37 posso utilizzare la scheda nvidia?
come diceva 'ponce' mi interesserebbe particolarmente una cosa sopra tutte ed è la seguente: quale scheda il sistema usa di default all'avvio?

vi spiego il problema: utilizzo molto spesso sistemi solaris. per solaris non esistono driver proprietari Intel o Ati ma solo Nvidia. Quelli nvidia funzionano molto bene, sono certificati e sono aggiornati con le stesse tempistiche di linux. Vorrei quindi che dopo aver installato i driver proprietari su solaris possa utilizzarli senza casini e senza ricorrere alla solita modalità VESA (lentissima per gnome). Ora il kernel solaris di certo non supporta gli hd dei sandy bridge e con solo quella gpu intel andrebbe solo in vesa mode. Se il kernel solaris si ritrova un bel modulo per i driver proprietari nvidia e due schede sotto il c**o cosa utilizza?
...ho provato a cercare nel readme dei drivers nvidia ma non trovo nulla.

thx

update:
il problema dai vari forum in rete sembrerebbe essere in realtà del server grafico Xorg? confermate?

update2:
a pensarci bene tutti i notebook che hanno una CPU recente Intel e una scheda grafica separata nvidia avranno sempre 2 GPU. vuole dire che questo problema si presenta per tutti i portatili con questa accoppiata? o solo quelli che dichiarano specificatamente la 'sfunzionalità' optimus?
per le mie esigenze andrebbe benissimo un laptop con scheda nvidia e cpu recente intel che semplicemente usi nvidia e amen...ma non ne trovo...ne conoscete?
Ultima modifica di ocman il lun mag 16, 2011 9:54, modificato 1 volta in totale.
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana

Re: Problema Nvidia gt 525m e Intel

Messaggioda teox99 » lun mag 16, 2011 9:54

completamente compatibile intendo che non avrai prob. con la scheda wireless (io ho anche montato quella maggiorata Advanced-N 6230), pulsanti con funzioni speciali, mouse pad, scheda audio ecc...
io ho un xps 17 con nvidia gt555m (3gb ram) 6gb ram e i7-2630QM non c'è uno switch x le gpu nel bios (neanche nelle ver. aggiornate)
se vuoi usare anche l'nvidia ... come ho già detto nei primi post ... puoi usare il workaround di martin-juhl altrimenti solo gpu-intel.

Xorg ancora non supporta lo switch dinamico delle gpu senza riavviare x quindi il supporto optimus non può essere integrato per come è stato pensato.

se pensi di non avere il supporto ai driver gpu intel, allora X non partirà. solo init 3.


update:
sia ben chiaro OPTIMUS non è una SFUNZIONALITÀ.
E' una grande cosa che x ora non è supportata sotto linux.
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 729
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: Problema Nvidia gt 525m e Intel

Messaggioda ocman » lun mag 16, 2011 10:08

grazie per le preziose info.
da quello che dici e dal blog martin-juhl.dk sembra proprio che il sistema usi intel per partire di default ed avvi la scheda nvidia solo in caso di alto carico.
e quindi il problema è nell'escludere l'intel e tenere nvidia e non viceversa. il workaround che descrive a fine pagina sembra risolvere questo ma devo dire che è abbastanza laborioso....ora guardo meglio. al max cerco altri laptop.

riguardo al discorso 'sfunzionalità' ho visto che su windows la logica di optimus e delle decisioni prese dal sistema di attivare l'nvidia sono stettamente basate sui profili di carico delle applicazioni avviate sul sistema. questi profili non penso nvidia li potrà mai creare per tutte le apps in tutte le varie distribuzioni, al massimo penso lo potrà fare l'utente a mano dopo che avranno corretto Xorg....
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti