Repository 32bit  Forum
Repository 64bit  Wiki

scheda video...la grafica va a scatti...

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

scheda video...la grafica va a scatti...

Messaggioda deadcandance » mer mag 18, 2011 11:52

ciao...
ho qualche problema con la scheda grafica,poichè il tutto va un po leggermente a scatti,infatti dando glxgears,non ottengo dei buoni risultati:

Codice: Seleziona tutto
189 frames in 5.0 seconds = 37.788 FPS
180 frames in 5.0 seconds = 35.838 FPS
186 frames in 5.0 seconds = 37.030 FPS


e a volte anche più bassi,tipo 50 in 5 secondi...ho provato a dare X -configure e copiare il nuovo xorg.conf ma continua a non andare bene come dovrebbe...ora,si che ho una scheda integrata,che comunque dovrebbe funzionare bene visto che è intel,ma solitamente la scheda video è sempre andata un po meglio,solo con la 13.37 va un po cosi....

Codice: Seleziona tutto
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)


grazie per l'aiuto...
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: scheda video...la grafica va a scatti...

Messaggioda 414N » mer mag 18, 2011 16:02

Ma almeno il direct rendering è attivo? Lo puoi vedere con
Codice: Seleziona tutto
glxinfo | grep direct

Non so se la tua scheda rientri in quelle col KMS. All'avvio il framebuffer aumenta la risoluzione di suo?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: scheda video...la grafica va a scatti...

Messaggioda deadcandance » gio mag 19, 2011 1:00

si è attivo...

Codice: Seleziona tutto
bash-4.1$ glxinfo | grep direct
direct rendering: Yes
bash-4.1$ glxgears


comunque,sono con xfce,ho attivato nelle impostazioni il compositore in regolazioni del gestore delle finestre,e sembra esserci un leggero miglioramento,adesso faccio 300 frame in 5 secondi....
per quanto riguarda la tua domanda
414N ha scritto: All'avvio il framebuffer aumenta la risoluzione di suo?


non so cosa intendi....

grazie per l'aiuto..
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: scheda video...la grafica va a scatti...

Messaggioda 414N » gio mag 19, 2011 12:37

deadcandance ha scritto:
414N ha scritto: All'avvio il framebuffer aumenta la risoluzione di suo?


non so cosa intendi....

Il KMS (Kernel ModeSetting) è una funzionalità presente negli ultimi kernel (dal 2.6.30, se non sbaglio) che delega al kernel la gestione della memoria video (prima era appannaggio dei driver). Questo ha comportato anche il fatto che già in fase di avvio pre-X il kernel può sfruttare la scheda video utilizzando un framebuffer alla risoluzione piena dello schermo (non più limitato alle sole risoluzioni VESA che imposti in LILO, ad esempio).
È per questo che ti ho chiesto se all'avvio noti un "aumento di risoluzione" dopo un certo punto: quando il kernel arriva a caricare i moduli video e di drm, solitamente cambia framebuffer e passa alla risoluzione piena dello schermo.
Dovresti accorgertene con un
Codice: Seleziona tutto
dmesg | grep drm
eseguito da root, visto che nell'ultima slack dmesg non è più accessibile da utente non privilegiato.
Altro posto in cui guardare è il log di X in /var/log/Xorg.0.log, specialmente le linee che cominciano con (WW) (warning) e (EE) (errori).
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: scheda video...la grafica va a scatti...

Messaggioda deadcandance » gio mag 19, 2011 21:39

...quell'aumento di risoluzione l'ho notato in debian...in slack sinceramente non ci ho fatto caso,comunque l'output del comando che mi hai detto è il seguente:
Codice: Seleziona tutto
[    8.217724] [drm] Initialized drm 1.1.0 20060810
[    8.867786] [drm] initialized overlay support
[    9.241129] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.
[    9.246192] fb0: inteldrmfb frame buffer device
[    9.246231] drm: registered panic notifier
[    9.246429] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
bash-4.1#


grazie per l'aiuto...
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: scheda video...la grafica va a scatti...

Messaggioda darkstaring » ven mag 20, 2011 23:33

Senza xorg.conf come và?

Offtopic: Il nuovo Kernel 2.6.39
ha una migliore gestione delle schede video Intel con il chip grafico Intel GMA500 e per le schede video della famiglia Cayman, prodotte da Advanced Micro Devices.

Altre info qui
darkstaring
Linux 2.4
Linux 2.4
 
Messaggi: 364
Iscritto il: mer ott 13, 2010 12:55
Slackware: Current
Desktop: xfce

Re: scheda video...la grafica va a scatti...

Messaggioda deadcandance » sab mag 21, 2011 16:33

ho provato a togliere xorg.conf,e fa pena,quindi l'ho rimesso ma non funziona più come prima...le ruote di glxgears non girano proprio bene...e sinceramente non capisco il motivo...
hai altri consigli da darmi?
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: scheda video...la grafica va a scatti...

Messaggioda 414N » mar mag 24, 2011 14:29

La scheda non è di certo delle più perfomanti e glxgears non è un benchmark affidabile...
Comunque, prova a postare il log di X (/var/log/Xorg.0.log) dopo aver avviato una sessione desktop. Mi raccomando, tra tag code.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: scheda video...la grafica va a scatti...

Messaggioda deadcandance » gio mag 26, 2011 9:38

ecco qui:
Codice: Seleziona tutto
[    37.907]
X.Org X Server 1.9.5
Release Date: 2011-03-17
[    37.908] X Protocol Version 11, Revision 0
[    37.908] Build Operating System: Slackware 13.37 Slackware Linux Project
[    37.908] Current Operating System: Linux darkstar 2.6.37.6-smp #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686
[    37.908] Kernel command line: BOOT_IMAGE=/boot/vmlinuz root=/dev/sda6 ro vt.default_utf8=0 vga = normal
[    37.908] Build Date: 18 March 2011  12:08:03AM
[    37.908] 
[    37.924] Current version of pixman: 0.20.2
[    37.924]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    37.924] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    37.925] (==) Log file: "/var/log/Xorg.0.log", Time: Thu May 26 10:34:51 2011
[    37.990] (==) Using config file: "/etc/X11/xorg.conf"
[    37.990] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    37.990] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    38.048] (==) ServerLayout "X.org Configured"
[    38.048] (**) |-->Screen "Screen0" (0)
[    38.048] (**) |   |-->Monitor "Monitor0"
[    38.049] (**) |   |-->Device "Card0"
[    38.049] (**) |-->Input Device "Mouse0"
[    38.049] (**) |-->Input Device "Keyboard0"
[    38.049] (==) Automatically adding devices
[    38.049] (==) Automatically enabling devices
[    38.050] (WW) The directory "/usr/share/fonts/local" does not exist.
[    38.050]    Entry deleted from font path.
[    38.050] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    38.050]    Entry deleted from font path.
[    38.076] (WW) The directory "/usr/share/fonts/local" does not exist.
[    38.076]    Entry deleted from font path.
[    38.076] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    38.076]    Entry deleted from font path.
[    38.076] (**) FontPath set to:
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic,
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic
[    38.076] (**) ModulePath set to "/usr/lib/xorg/modules"
[    38.076] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    38.076] (WW) Disabling Mouse0
[    38.076] (WW) Disabling Keyboard0
[    38.076] (II) Loader magic: 0x81f0f80
[    38.076] (II) Module ABI versions:
[    38.076]    X.Org ANSI C Emulation: 0.4
[    38.076]    X.Org Video Driver: 8.0
[    38.076]    X.Org XInput driver : 11.0
[    38.076]    X.Org Server Extension : 4.0
[    38.078] (--) PCI:*(0:0:2:0) 8086:27a2:1179:ff10 rev 3, Mem @ 0xdc100000/524288, 0xc0000000/268435456, 0xdc200000/262144, I/O @ 0x00001800/8
[    38.078] (--) PCI: (0:0:2:1) 8086:27a6:1179:ff10 rev 3, Mem @ 0xdc180000/524288
[    38.078] (II) Open ACPI successful (/var/run/acpid.socket)
[    38.078] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[    38.078] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[    38.078] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    38.078] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[    38.078] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[    38.078] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[    38.078] (II) LoadModule: "dbe"
[    38.099] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    38.114] (II) Module dbe: vendor="X.Org Foundation"
[    38.114]    compiled for 1.9.5, module version = 1.0.0
[    38.114]    Module class: X.Org Server Extension
[    38.114]    ABI class: X.Org Server Extension, version 4.0
[    38.114] (II) Loading extension DOUBLE-BUFFER
[    38.114] (II) LoadModule: "dri2"
[    38.115] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    38.127] (II) Module dri2: vendor="X.Org Foundation"
[    38.127]    compiled for 1.9.5, module version = 1.2.0
[    38.127]    ABI class: X.Org Server Extension, version 4.0
[    38.127] (II) Loading extension DRI2
[    38.127] (II) LoadModule: "record"
[    38.129] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    38.129] (II) Module record: vendor="X.Org Foundation"
[    38.130]    compiled for 1.9.5, module version = 1.13.0
[    38.130]    Module class: X.Org Server Extension
[    38.130]    ABI class: X.Org Server Extension, version 4.0
[    38.130] (II) Loading extension RECORD
[    38.130] (II) LoadModule: "glx"
[    38.131] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    38.160] (II) Module glx: vendor="X.Org Foundation"
[    38.160]    compiled for 1.9.5, module version = 1.0.0
[    38.160]    ABI class: X.Org Server Extension, version 4.0
[    38.163] (==) AIGLX enabled
[    38.163] (II) Loading extension GLX
[    38.163] (II) LoadModule: "extmod"
[    38.164] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    38.168] (II) Module extmod: vendor="X.Org Foundation"
[    38.168]    compiled for 1.9.5, module version = 1.0.0
[    38.168]    Module class: X.Org Server Extension
[    38.168]    ABI class: X.Org Server Extension, version 4.0
[    38.168] (II) Loading extension MIT-SCREEN-SAVER
[    38.168] (II) Loading extension XFree86-VidModeExtension
[    38.168] (II) Loading extension XFree86-DGA
[    38.169] (II) Loading extension DPMS
[    38.169] (II) Loading extension XVideo
[    38.169] (II) Loading extension XVideo-MotionCompensation
[    38.169] (II) Loading extension X-Resource
[    38.169] (II) LoadModule: "dri"
[    38.171] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    38.172] (II) Module dri: vendor="X.Org Foundation"
[    38.172]    compiled for 1.9.5, module version = 1.0.0
[    38.172]    ABI class: X.Org Server Extension, version 4.0
[    38.172] (II) Loading extension XFree86-DRI
[    38.172] (II) LoadModule: "intel"
[    38.173] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    38.196] (II) Module intel: vendor="X.Org Foundation"
[    38.196]    compiled for 1.9.5, module version = 2.15.0
[    38.196]    Module class: X.Org Video Driver
[    38.196]    ABI class: X.Org Video Driver, version 8.0
[    38.196] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
   Sandybridge, Sandybridge
[    38.196] (--) using VT number 7

[    38.196] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[    38.196] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[    38.205] drmOpenDevice: node name is /dev/dri/card0
[    38.205] drmOpenDevice: open result is 11, (OK)
[    38.205] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[    38.205] drmOpenDevice: node name is /dev/dri/card0
[    38.205] drmOpenDevice: open result is 11, (OK)
[    38.205] drmOpenByBusid: drmOpenMinor returns 11
[    38.206] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[    38.206] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    38.206] (==) intel(0): RGB weight 888
[    38.206] (==) intel(0): Default visual is TrueColor
[    38.206] (II) intel(0): Integrated Graphics Chipset: Intel(R) 945GM
[    38.206] (--) intel(0): Chipset: "945GM"
[    38.206] (**) intel(0): Relaxed fencing disabled
[    38.206] (**) intel(0): Framebuffer tiled
[    38.206] (**) intel(0): Pixmaps tiled
[    38.206] (**) intel(0): 3D buffers tiled
[    38.206] (**) intel(0): SwapBuffers wait enabled
[    38.206] (==) intel(0): video overlay key set to 0x101fe
[    38.206] (II) intel(0): Output LVDS1 using monitor section Monitor0
[    38.206] (II) intel(0): found backlight control interface /sys/class/backlight/acpi_video0
[    38.230] (II) intel(0): Output VGA1 has no monitor section
[    38.470] (II) intel(0): Output TV1 has no monitor section
[    38.470] (II) intel(0): EDID for output LVDS1
[    38.470] (II) intel(0): Manufacturer: SEC  Model: 3633  Serial#: 0
[    38.470] (II) intel(0): Year: 2005  Week: 0
[    38.470] (II) intel(0): EDID Version: 1.3
[    38.470] (II) intel(0): Digital Display Input
[    38.470] (II) intel(0): Max Image Size [cm]: horiz.: 33  vert.: 21
[    38.470] (II) intel(0): Gamma: 2.20
[    38.470] (II) intel(0): No DPMS capabilities specified
[    38.470] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[    38.470] (II) intel(0): First detailed timing is preferred mode
[    38.470] (II) intel(0): redX: 0.580 redY: 0.340   greenX: 0.310 greenY: 0.550
[    38.470] (II) intel(0): blueX: 0.155 blueY: 0.155   whiteX: 0.313 whiteY: 0.329
[    38.470] (II) intel(0): Manufacturer's mask: 0
[    38.470] (II) intel(0): Supported detailed timing:
[    38.470] (II) intel(0): clock: 68.9 MHz   Image Size:  331 x 207 mm
[    38.470] (II) intel(0): h_active: 1280  h_sync: 1296  h_sync_end 1344 h_blank_end 1408 h_border: 0
[    38.470] (II) intel(0): v_active: 800  v_sync: 801  v_sync_end 804 v_blanking: 816 v_border: 0
[    38.470] (II) intel(0): Unknown vendor-specific block f
[    38.470] (II) intel(0):  SAMSUNG
[    38.470] (II) intel(0):  LTN154X3-L06
[    38.470] (II) intel(0): EDID (in hex):
[    38.470] (II) intel(0):    00ffffffffffff004ca3333600000000
[    38.470] (II) intel(0):    000f0103802115780a87f594574f8c27
[    38.470] (II) intel(0):    27505400000001010101010101010101
[    38.471] (II) intel(0):    010101010101ee1a0080502010301030
[    38.471] (II) intel(0):    13004bcf100000190000000f00000000
[    38.471] (II) intel(0):    00000000002387026402000000fe0053
[    38.471] (II) intel(0):    414d53554e470a2020202020000000fe
[    38.471] (II) intel(0):    004c544e31353458332d4c30360a0070
[    38.471] (II) intel(0): EDID vendor "SEC", prod id 13875
[    38.471] (II) intel(0): Printing DDC gathered Modelines:
[    38.471] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[    38.471] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[    38.472] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[    38.472] (II) intel(0): Printing probed modes for output LVDS1
[    38.472] (II) intel(0): Modeline "1280x800"x60.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[    38.472] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[    38.472] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[    38.472] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[    38.472] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[    38.496] (II) intel(0): EDID for output VGA1
[    38.726] (II) intel(0): EDID for output TV1
[    38.726] (II) intel(0): Output LVDS1 connected
[    38.726] (II) intel(0): Output VGA1 disconnected
[    38.726] (II) intel(0): Output TV1 disconnected
[    38.726] (II) intel(0): Using exact sizes for initial modes
[    38.726] (II) intel(0): Output LVDS1 using initial mode 1280x800
[    38.726] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[    38.726] (II) intel(0): Kernel page flipping support detected, enabling
[    38.726] (**) intel(0): Display dimensions: (330, 210) mm
[    38.726] (**) intel(0): DPI set to (98, 96)
[    38.726] (II) Loading sub module "fb"
[    38.726] (II) LoadModule: "fb"
[    38.728] (II) Loading /usr/lib/xorg/modules/libfb.so
[    38.747] (II) Module fb: vendor="X.Org Foundation"
[    38.747]    compiled for 1.9.5, module version = 1.0.0
[    38.747]    ABI class: X.Org ANSI C Emulation, version 0.4
[    38.747] (II) Loading sub module "dri2"
[    38.747] (II) LoadModule: "dri2"
[    38.750] (II) Reloading /usr/lib/xorg/modules/extensions/libdri2.so
[    38.750] (==) Depth 24 pixmap format is 32 bpp
[    38.750] (II) intel(0): [DRI2] Setup complete
[    38.750] (II) intel(0): [DRI2]   DRI driver: i915
[    38.750] (II) intel(0): Allocated new frame buffer 1280x800 stride 8192, tiled
[    38.769] (II) UXA(0): Driver registered support for the following operations:
[    38.769] (II)         solid
[    38.769] (II)         copy
[    38.769] (II)         composite (RENDER acceleration)
[    38.769] (II)         put_image
[    38.769] (II)         get_image
[    38.769] (==) intel(0): Backing store disabled
[    38.769] (==) intel(0): Silken mouse enabled
[    38.771] (II) intel(0): Initializing HW Cursor
[    38.793] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    38.793] (==) intel(0): DPMS enabled
[    38.793] (==) intel(0): Intel XvMC decoder disabled
[    38.793] (II) intel(0): Set up textured video
[    38.793] (II) intel(0): Set up overlay video
[    38.793] (II) intel(0): direct rendering: DRI2 Enabled
[    38.793] (==) intel(0): hotplug detection: "enabled"
[    38.794] (--) RandR disabled
[    38.794] (II) Initializing built-in extension Generic Event Extension
[    38.794] (II) Initializing built-in extension SHAPE
[    38.794] (II) Initializing built-in extension MIT-SHM
[    38.794] (II) Initializing built-in extension XInputExtension
[    38.794] (II) Initializing built-in extension XTEST
[    38.794] (II) Initializing built-in extension BIG-REQUESTS
[    38.794] (II) Initializing built-in extension SYNC
[    38.794] (II) Initializing built-in extension XKEYBOARD
[    38.794] (II) Initializing built-in extension XC-MISC
[    38.794] (II) Initializing built-in extension XINERAMA
[    38.794] (II) Initializing built-in extension XFIXES
[    38.794] (II) Initializing built-in extension RENDER
[    38.794] (II) Initializing built-in extension RANDR
[    38.794] (II) Initializing built-in extension COMPOSITE
[    38.794] (II) Initializing built-in extension DAMAGE
[    38.892] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    38.892] (II) AIGLX: enabled GLX_INTEL_swap_event
[    38.892] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    38.892] (II) AIGLX: enabled GLX_SGI_make_current_read
[    38.892] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    38.893] (II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/i915_dri.so
[    38.893] (II) GLX: Initialized DRI2 GL provider for screen 0
[    38.894] (II) intel(0): Setting screen physical size to 338 x 211
[    39.474] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[    39.474] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    39.474] (**) Power Button: Applying InputClass "keyboard-all"
[    39.474] (**) Power Button: Applying InputClass "keyboard-all"
[    39.474] (II) LoadModule: "evdev"
[    39.475] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    39.487] (II) Module evdev: vendor="X.Org Foundation"
[    39.487]    compiled for 1.9.3, module version = 2.6.0
[    39.487]    Module class: X.Org XInput Driver
[    39.487]    ABI class: X.Org XInput driver, version 11.0
[    39.487] (**) Power Button: always reports core events
[    39.488] (**) Power Button: Device: "/dev/input/event4"
[    39.493] (--) Power Button: Found keys
[    39.493] (II) Power Button: Configuring as keyboard
[    39.493] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    39.493] (**) Option "xkb_rules" "evdev"
[    39.493] (**) Option "xkb_model" "evdev"
[    39.493] (**) Option "xkb_layout" "it"
[    39.493] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    39.548] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[    39.548] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    39.548] (**) Video Bus: Applying InputClass "keyboard-all"
[    39.548] (**) Video Bus: Applying InputClass "keyboard-all"
[    39.548] (**) Video Bus: always reports core events
[    39.548] (**) Video Bus: Device: "/dev/input/event5"
[    39.553] (--) Video Bus: Found keys
[    39.553] (II) Video Bus: Configuring as keyboard
[    39.553] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
[    39.553] (**) Option "xkb_rules" "evdev"
[    39.553] (**) Option "xkb_model" "evdev"
[    39.553] (**) Option "xkb_layout" "it"
[    39.553] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    39.565] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    39.565] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    39.565] (**) Power Button: Applying InputClass "keyboard-all"
[    39.565] (**) Power Button: Applying InputClass "keyboard-all"
[    39.565] (**) Power Button: always reports core events
[    39.565] (**) Power Button: Device: "/dev/input/event3"
[    39.570] (--) Power Button: Found keys
[    39.570] (II) Power Button: Configuring as keyboard
[    39.570] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    39.570] (**) Option "xkb_rules" "evdev"
[    39.570] (**) Option "xkb_model" "evdev"
[    39.570] (**) Option "xkb_layout" "it"
[    39.570] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    39.570] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[    39.571] (II) No input driver/identifier specified (ignoring)
[    39.581] (II) config/udev: Adding input device HID 1241:1166 (/dev/input/event6)
[    39.581] (**) HID 1241:1166: Applying InputClass "evdev pointer catchall"
[    39.581] (**) HID 1241:1166: always reports core events
[    39.581] (**) HID 1241:1166: Device: "/dev/input/event6"
[    39.586] (--) HID 1241:1166: Found 9 mouse buttons
[    39.586] (--) HID 1241:1166: Found scroll wheel(s)
[    39.586] (--) HID 1241:1166: Found relative axes
[    39.586] (--) HID 1241:1166: Found x and y relative axes
[    39.586] (II) HID 1241:1166: Configuring as mouse
[    39.586] (II) HID 1241:1166: Adding scrollwheel support
[    39.586] (**) HID 1241:1166: YAxisMapping: buttons 4 and 5
[    39.586] (**) HID 1241:1166: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    39.586] (II) XINPUT: Adding extended input device "HID 1241:1166" (type: MOUSE)
[    39.586] (**) HID 1241:1166: (accel) keeping acceleration scheme 1
[    39.586] (**) HID 1241:1166: (accel) acceleration profile 0
[    39.586] (**) HID 1241:1166: (accel) acceleration factor: 2.000
[    39.586] (**) HID 1241:1166: (accel) acceleration threshold: 4
[    39.586] (II) HID 1241:1166: initialized for relative axes.
[    39.587] (II) config/udev: Adding input device HID 1241:1166 (/dev/input/mouse0)
[    39.587] (II) No input driver/identifier specified (ignoring)
[    39.602] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event1)
[    39.602] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    39.602] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[    39.602] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[    39.602] (**) AT Translated Set 2 keyboard: always reports core events
[    39.602] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
[    39.610] (--) AT Translated Set 2 keyboard: Found keys
[    39.610] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    39.610] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    39.610] (**) Option "xkb_rules" "evdev"
[    39.610] (**) Option "xkb_model" "evdev"
[    39.610] (**) Option "xkb_layout" "it"
[    39.610] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    39.611] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event7)
[    39.611] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    39.611] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad"
[    39.611] (II) LoadModule: "synaptics"
[    39.611] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    39.612] (II) Module synaptics: vendor="X.Org Foundation"
[    39.612]    compiled for 1.9.4, module version = 1.4.0
[    39.612]    Module class: X.Org XInput Driver
[    39.612]    ABI class: X.Org XInput driver, version 11.0
[    39.612] (**) Option "Device" "/dev/input/event7"
[    39.650] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[    39.650] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[    39.650] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    39.650] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    39.650] (--) SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    39.650] (**) Option "TapButton1" "1"
[    39.650] (**) Option "TapButton2" "2"
[    39.650] (**) Option "TapButton3" "3"
[    39.682] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    39.682] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    39.698] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[    39.698] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    39.698] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[    39.698] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[    39.698] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    39.698] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    39.698] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    39.698] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    39.722] (--) SynPS/2 Synaptics TouchPad: touchpad found
[    39.722] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
[    39.722] (II) No input driver/identifier specified (ignoring)
[    39.732] (II) config/udev: Adding input device Speakup (/dev/input/event0)
[    39.732] (**) Speakup: Applying InputClass "evdev keyboard catchall"
[    39.732] (**) Speakup: Applying InputClass "keyboard-all"
[    39.733] (**) Speakup: Applying InputClass "keyboard-all"
[    39.733] (**) Speakup: always reports core events
[    39.733] (**) Speakup: Device: "/dev/input/event0"
[    39.738] (--) Speakup: Found keys
[    39.738] (II) Speakup: Configuring as keyboard
[    39.738] (II) XINPUT: Adding extended input device "Speakup" (type: KEYBOARD)
[    39.738] (**) Option "xkb_rules" "evdev"
[    39.738] (**) Option "xkb_model" "evdev"
[    39.738] (**) Option "xkb_layout" "it"
[    39.738] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    49.718] (II) intel(0): EDID vendor "SEC", prod id 13875
[    49.718] (II) intel(0): Printing DDC gathered Modelines:
[    49.718] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)
[    49.971] (II) intel(0): EDID vendor "SEC", prod id 13875
[    49.971] (II) intel(0): Printing DDC gathered Modelines:
[    49.971] (II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801 804 816 -hsync -vsync (49.0 kHz)


ho notato inoltre che quando lascio il pc,e si avvia lo screen saver,si blocca il pc,credo probabilmente sia dovuto al fatto che non riesce ad elaborare la grafica dello screen saver...
grazie per l'aiuto...
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: scheda video...la grafica va a scatti...

Messaggioda rik70 » gio mag 26, 2011 9:56

Prova a dare:

Codice: Seleziona tutto
glxinfo | grep 'OpenGL renderer string'


oppure:
Codice: Seleziona tutto
glxinfo | grep render


Se dall'output salta fuori un 'Mesa DRI[*]', allora puoi provare a disattivare il Kernel Mode Setting: potrebbe essere "lui" il problema.

P.s.
Occhio che gli screensaver OpenGL possono causare il blocco del sistema, specie se il supporto 3D non è completo.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1053
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: scheda video...la grafica va a scatti...

Messaggioda 414N » gio mag 26, 2011 10:17

rik70 ha scritto:Prova a dare:

Codice: Seleziona tutto
glxinfo | grep 'OpenGL renderer string'


oppure:
Codice: Seleziona tutto
glxinfo | grep render


Se dall'output salta fuori un 'Mesa DRI[*]', allora puoi provare a disattivare il Kernel Mode Setting: potrebbe essere "lui" il problema.

Non vedo cosa c'entri con la questione. Ti ricordo che si parla di una scheda intel integrata, non nvidia/ati. L'output sarà per forza Mesa DRI e senza il KMS, X non partirebbe neppure.
Detto questo, io proverei a passare all'accelerazione EXA invece di UXA.
Crea un file /etc/X11/xorg.conf (se già non esiste) con una sezione Device minimale, del tipo:
Codice: Seleziona tutto
Section "Device"
Identifier "devname"
Driver "intel"
AccelMethod "EXA"
EndSection
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: scheda video...la grafica va a scatti...

Messaggioda rik70 » gio mag 26, 2011 10:36

414N ha scritto:
rik70 ha scritto:Prova a dare:

Non vedo cosa c'entri con la questione. Ti ricordo che si parla di una scheda intel integrata, non nvidia/ati. L'output sarà per forza Mesa DRI e senza il KMS, X non partirebbe neppure.



Non so, io non sono un'esperto e non ho VGA intel, però l'output - con la nuova Slack - potrebbe anche essere gallium piuttosto che mesa.

Se Pat ha compilato le mesa per intel con supporto gallium, il KMS è obbligatorio per avere l'accelerazione 3d. Diversamente, con le Intel si dovrebbe poter utilizzare l'accelerazione via mesa anche disabilitando il kms.

Da quello che sapevo io, il KMS è obbligatorio solo con i driver nouveau (mesa o gallium che sia); e con i driver su cui è stato attivato gallium al posto di mesa: quindi, in quest'ultima ipotesi, anche per le (=alcune) radeon.

Così ti dico, così come potrei (molto probabilmente) sbagliarmi.
Ultima modifica di rik70 il gio mag 26, 2011 11:34, modificato 1 volta in totale.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1053
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: scheda video...la grafica va a scatti...

Messaggioda deadcandance » gio mag 26, 2011 11:01

allora questi sono gli output dei comandi sopra postati...

Codice: Seleziona tutto
bash-4.1$ glxinfo | grep 'OpenGL renderer string'
OpenGL renderer string: Mesa DRI Intel(R) 945GM  x86/MMX/SSE2
bash-4.1$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 945GM  x86/MMX/SSE2


rik70 ha scritto:Prova a dare:

[code]
Se dall'output salta fuori un 'Mesa DRI[*]', allora puoi provare a disattivare il Kernel Mode Setting: potrebbe essere "lui" il problema.


e ad essere sincero non ho ben capito cosa dovrei fare nel caso mi dia questa risposta....

per quanto riguarda lo xorg.conf,se do quella modifica mi da problemi,tanto che non si avvia....

grazie ancora per l'aiuto..
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: scheda video...la grafica va a scatti...

Messaggioda rik70 » gio mag 26, 2011 11:20

deadcandance ha scritto:

per quanto riguarda lo xorg.conf,se do quella modifica mi da problemi,tanto che non si avvia....


Forse c'è un errore, dovrebbe essere così la stringa sull'accelerazione Exa:

Codice: Seleziona tutto
Option  "AccelMethod" "EXA"


Prova a correggere, e vedi se risolvi col metodo di 414N.

Nel caso poi si prova a fare un boot senza KMS - che però mi pare dall'output che hai postato non sia in uso: col KMS attivo ci dovrebbe essere un Mesa DRI2 e non Mesa DRI. Ma anche qui, saprà dire di + chi ha intel.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1053
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: scheda video...la grafica va a scatti...

Messaggioda rik70 » gio mag 26, 2011 11:43

P.s.
@deadcandance

Prova a dare anche un:
Codice: Seleziona tutto
cat /var/log/Xorg.0.log | grep -i KMS

...così proviamo a toglierci ogni dubbio.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1053
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Prossimo

Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite