Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]prime installazioni

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]prime installazioni

Messaggioda prometeo » lun mag 23, 2011 16:33

Salve a tutti!!
SONO nuovo del forum e del mondo linux in generale, ho deciso di iniziare con slackware anche se ho letto da diverse "fonti" che è una delle più ostiche, per i novizi(e non solo :) ),ma ti da il totale controllo su tutto quello che fai , quindi quale migliore palestra .
Fatta questa premessa, ho scaricato la 13.37,versione installando i pacchetti,A,AP,D,F,K,L,N,TLC,X e XAP, ho letto sul forum che era un'ottima combinazione per computer poco potenti (come il mio),come WM uso xfce, ora volevo installare gnumeric e abiword, li ho scaricati dai reposity della 13.1, li ho installati comprese le dipendenze(anche se alcune erano identificate come dipendenze di GNOME) e sembrano funzionare,ma lanciandoli da shell mi da questo mess. per tutti e 2 i software molto simile es:
(gnumeric:3249): GLib-GObject-CRITICAL **:object class GnmEXPRENTRY DOENSIT IMPLEMENT propriety `editing-canceled ' from interface GTKCELLEDITABlE

se volete vi scrivo l'altro
A cosa sono dovuti questi "avvisi" al fatto che non dovevo installare le dipendenze di GNOME?? AL fatto che sono pacchetti per la 13.1?? HO dimenticato di installare qualcosa dal dvd di installazione...oppure devo ignorarli :)
spero qualcuno possa darmi una mano...e scusate se mi sono dilungato troppo ma volevo dare un quadro più chiaro possibile
GRAZIE
Ultima modifica di prometeo il mer mag 25, 2011 22:07, modificato 1 volta in totale.
prometeo
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: gio mag 19, 2011 16:21
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: xfce

Re: prime installazioni

Messaggioda zoros » lun mag 23, 2011 17:07

be, se hai installato gnumeric e abiword manualmente e funzionano non sei tanto nuovo di Linux :D ...

non hai chiesto aiuto a SlackyD ?
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: prime installazioni

Messaggioda 414N » lun mag 23, 2011 17:55

Benvenuto! :D
Può darsi che quegli errori siano dovuti al fatto che hai installato pacchetti compilati per la 13.1 sulla 13.37.
È sempre consigliabile installare pacchetti compilati per la propria versione di Slackware. Nel caso non ci siano ancora nel repo di slacky, scaricati gli SlackBuild e i sorgenti e creati da te il pacchetto.
Questo perché da una versione all'altra di Slackware cambiano librerie basilari quali le glibc (e i compilatori stessi), portando a possibili "incompatibilità" a livello di binari.
Ti consiglio di darti una letta alla "Slackware for dummies" (trovi il link nell'header di slacky) che, nonostante sia riferita ad una vecchia versione di Slackware (la 11), spiega comunque molto sulla distribuzione.
In particolare, per quanto riguarda gli SlackBuild (non sono altro che semplici script bash per automatizzare il processo di compilazione e creazione di un pacchetto), consulta la sezione 12.10.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: prime installazioni

Messaggioda prometeo » lun mag 23, 2011 22:50

ahahahaah zoros,ci sono riuscito perchè i repo sono veramente ben gestiti e documentati con tutte le indicazioni, slacyD sembra un ottimo tool...lo proverò.
slackware for dummies lo usata per l'installazione e per le configurazioni iniziali( un'ottima guida), l'ho abbandonata perchè nei repo non trovavo i pacchetti .tgz e non capivo cosa c'era di sbagliato la guida o i repo :D ,poi ho scoperto che dallla 12 si è passato hai .txz , (veramente migliori nelle prestazioni??)...comunque, proverò a usare gli slackbuild per crearne uno nuovo vediamo che succede.
grazie
prometeo
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: gio mag 19, 2011 16:21
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: xfce

Re: prime installazioni

Messaggioda jdrake » mar mag 24, 2011 1:14

prometeo ha scritto:...poi ho scoperto che dalla 12 si è passato al .txz , (veramente migliori nelle prestazioni??)...


Sperando di non andare troppo OT la domanda mi ha incuriosito e mi sono divertito un po' a fare una piccola prova...
    tar --version tar (GNU tar) 1.26
Prelevato un file a caso... :D
Codice: Seleziona tutto
wget ftp://ftp.slackbook.org/pub/slackbook/slackbook-2.0-docbook.tar.gz

un controllo con file e ls per vedere di che si tratta e le dimensioni estese e leggibili
    slackbook-2.0-docbook.tar.gz: gzip compressed data, from Unix
    1537559 slackbook-2.0-docbook.tar.gz
    1,5M slackbook-2.0-docbook.tar.gz
decompressione e controllo con du per lo spazio occupato in formato esteso e in leggibile
    15312 slackbook/
    15M slackbook/
creazione di un po' di archivi al volo
Codice: Seleziona tutto
tar -jcvf slackbook.tar.bz2 slackbook/
tar -zcvf slackbook.tar.gz slackbook/
tar -Jcvf slackbook.tar.xz slackbook/

controllo finale con file
    slackbook.tar.bz2: bzip2 compressed data, block size = 900k
    slackbook.tar.gz: gzip compressed data, from Unix
    slackbook.tar.xz: XZ compressed data
verifica dei risultati in formato esteso e leggibile
    1118357 slackbook.tar.bz2
    1610836 slackbook.tar.gz
    643160 slackbook.tar.xz
    1,1M slackbook.tar.bz2
    1,6M slackbook.tar.gz
    629K slackbook.tar.xz
Se non ho commesso troppi errori direi che la scelta di xz è davvero motivata... :)
Avatar utente
jdrake
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: ven mag 27, 2005 23:00
Slackware: Current x86_64
Kernel: 3.14.12
Desktop: OpenBox 3.5.2

Re: prime installazioni

Messaggioda ZeroUno » mar mag 24, 2011 11:36

ChangeLog_13.0 ha scritto:Fri May 8 18:49:03 CDT 2009
Hello folks! This batch of updates includes the newly released KDE 4.2.3,
but more noticeably it marks the first departure from the use of gzip for
compressing Slackware packages. Instead, we will be using xz, based on
the LZMA compression algorithm. xz offers better compression than even
bzip2, but still offers good extraction performance (about 3 times better
than bzip2 and not much slower than gzip in our testing). Since support
for bzip2 has long been requested, support for bzip2 and the original lzma
format has also been added (why not?), but this is purely in the interest
of completeness -- we think most people will probably want to use either
the original .tgz or the new .txz compression wrappers. The actual
Slackware package format (which consists of the layout within the package
envelope) has not changed, but this is the first support within Slackware's
package tools for using alternate compression algorithms.
Some people have asked why we don't pick a single extension, such as
.slk. While there's certainly a case to be made for that idea, the tools
would still need to support .tgz to handle older packages. Sticking with
".tgz" for everything makes no sense. Using extensions that reflect the
compression format used by the package envelope seems to be the most
transparent approach, and the one that best follows tradition.
As an example of the compression improvement with .txz, have a look
at the kernel-source package:
Before: kernel-source-2.6.29.2_smp-noarch-1.tgz (73808508 bytes)
After: kernel-source-2.6.29.2_smp-noarch-1.txz (49150104 bytes)
The size of the main package tree in /slackware has been reduced from
1.9GB to 1.4GB by converting most packages to .txz.
Most of the packages have been converted from .tgz to .txz
, but we
will continue to make the gzip, pkgtools, slackpkg, tar, and xz packages
in .tgz format for the foreseeable future.
Enjoy! And thanks to Lasse Collin for the great work on xz. :-)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4362
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re:[RISOLTO]prime installazioni

Messaggioda prometeo » mer mag 25, 2011 21:56

...OK,effettivamente era un problema di pacchetti, compilandoli per la 13.37 non danno più messaggi di errore!!
Per quanto riguarda la differenza tra txz e tgz, mi fido :D tutti i cambiamenti fatti in slackware sono sempre soppesati con cura se è la distro più "longeva" un motivo ci sarà, e solo che avevo letto una dicussione su un altro forum(DI UN' altra distro) che sostenevano che non c'era tutta questa differenza in termini di compressione...tutto qua.
prometeo
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: gio mag 19, 2011 16:21
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: xfce


Torna a Packages

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 2 ospiti

cron