Repository 32bit  Forum
Repository 64bit  Wiki

mingw32

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

mingw32

Messaggioda so_slack » ven mag 27, 2011 13:16

hello
how can i compile mingw32 on slackware x64 13.1
i found a slackbuild here http://forum.slackware-fr.org/viewtopic.php?id=731
but i have this error
Codice: Seleziona tutto
./mingw32-libs.SlackBuild

Codice: Seleziona tutto
checking if mkdir takes one argument... no
*** Configuration x86_64-pc-mingw32 not supported
make: *** [configure-gcc] Error 1

thk
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64

Re: mingw32

Messaggioda Blallo » ven mag 27, 2011 13:46

I suppose that mingw32 is for 32bit systems
On a 64-bit system, you must install multilib packages from alien
http://connie.slackware.com/~alien/multilib/
After this, you obtain a multilib Slackware with a cross-compiler for 32bit architectures
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: mingw32

Messaggioda so_slack » ven mag 27, 2011 13:52

yes i already have the multilib so i can compile and install binutils-mingw32
but i have this error with mingw32-libs
Codice: Seleziona tutto
 ./mingw32-libs.SlackBuild

Codice: Seleziona tutto
/tmp/ccK5hOF6.s: Assembler messages:
/tmp/ccK5hOF6.s:5: Error: unknown pseudo-op: `.def'
/tmp/ccK5hOF6.s:5: Error: unknown pseudo-op: `.scl'
/tmp/ccK5hOF6.s:5: Error: unrecognized symbol type "32"
/tmp/ccK5hOF6.s:5: Error: unknown pseudo-op: `.endef'
/tmp/ccK5hOF6.s:7: Error: invalid instruction suffix for `push'
/tmp/ccK5hOF6.s:9: Error: invalid instruction suffix for `pop'
/tmp/ccK5hOF6.s:11: Error: unknown pseudo-op: `.def'
/tmp/ccK5hOF6.s:11: Error: unknown pseudo-op: `.scl'
/tmp/ccK5hOF6.s:11: Error: unrecognized symbol type "32"
/tmp/ccK5hOF6.s:11: Error: unknown pseudo-op: `.endef'
make[1]: *** [crtbegin.o] Error 1
make[1]: Leaving directory `/tmp/mingw32/stage1-build/gcc'
make: *** [all-gcc] Error 2
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64

Re: mingw32

Messaggioda Vito » ven mag 27, 2011 14:05

Maybe you've missed some dependencies.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: mingw32

Messaggioda hashbang » ven mag 27, 2011 14:53

Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1834
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: mingw32

Messaggioda so_slack » ven mag 27, 2011 14:56

Vito ha scritto:Maybe you've missed some dependencies.

this is the compilation loghttp://noog.fr/output.log and i can't find dependencies error :p
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64

Re: mingw32

Messaggioda Vito » ven mag 27, 2011 15:36

so_slack ha scritto:this is the compilation loghttp://noog.fr/output.log and i can't find dependencies error :p


Codice: Seleziona tutto
checking host system type... x86_64-unknown-linux-gnu


I think that this "unknown" it's not a good parameter.
But I'm not really sure.It's only an idea.

Did you try to clean your build directory?
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: mingw32

Messaggioda so_slack » ven mag 27, 2011 16:02

Vito ha scritto:
so_slack ha scritto:this is the compilation loghttp://noog.fr/output.log and i can't find dependencies error :p


Codice: Seleziona tutto
checking host system type... x86_64-unknown-linux-gnu


I think that this "unknown" it's not a good parameter.
But I'm not really sure.It's only an idea.

Did you try to clean your build directory?


yes i cleaned the build directory and i have the same result with a x32 slackware version on another computer :roll:
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64

Re: mingw32

Messaggioda Vito » ven mag 27, 2011 16:16

Try to take a look the the links that atomix suggested.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: mingw32

Messaggioda Blallo » ven mag 27, 2011 16:29

Inside the SlackBuild, change
Codice: Seleziona tutto
  --build=$ARCH-pc-linux-gnu

with
Codice: Seleziona tutto
  --build=$ARCH-slackware-linux

and try to execute this
Codice: Seleziona tutto
sh /etc/profile.d/32dev.sh

before executing the SlackBuild
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: mingw32

Messaggioda so_slack » ven mag 27, 2011 17:13

jimmy_page_89 ha scritto:Inside the SlackBuild, change
Codice: Seleziona tutto
  --build=$ARCH-pc-linux-gnu

with
Codice: Seleziona tutto
  --build=$ARCH-slackware-linux

and try to execute this
Codice: Seleziona tutto
sh /etc/profile.d/32dev.sh

before executing the SlackBuild


ok i made the modifications but same problem
here is my log file
http://noog.fr/slackbuild/mingw/mingw32-libs/output2.log
and i transfered the whole directory here
http://noog.fr/slackbuild/mingw/mingw32-libs
with the modified slackbuild
http://noog.fr/slackbuild/mingw/mingw32-libs/mingw32-libs.SlackBuild
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64

Re: mingw32

Messaggioda 414N » ven mag 27, 2011 17:37

The error seems to be caused by as (the assembler), which seems the system one, not the one from binutils-mingw32.
This should be caused by the mingw32 bin path (/opt/mingw32/bin) being last inside PATH.
Try to put it first in PATH, changing this snippet from mingw32-libs.SlackBuild from
Codice: Seleziona tutto
if ! echo $PATH | grep -q /opt/mingw32/bin ; then
    PATH=$PATH:/opt/mingw32/bin
fi

to
Codice: Seleziona tutto
if ! echo $PATH | grep -q /opt/mingw32/bin ; then
    PATH=/opt/mingw32/x86_64-pc-mingw32/bin:$PATH
fi

assuming that binutils-mingw32 is installed in that path. Please check that /opt/mingw32/x86_64-pc-mingw32/bin/as exists.
This should solve the issue.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: mingw32

Messaggioda so_slack » dom mag 29, 2011 9:16

ok after the modification the error is the following
Codice: Seleziona tutto
      -c /tmp/mingw32/gcc-3.4.5-20060117-2/gcc/crtstuff.c -DCRT_BEGIN \
     -o crtbegin.o
/tmp/cc3tRX0n.s: Assembler messages:
/tmp/cc3tRX0n.s:7: Error: suffix or operands invalid for `push'
/tmp/cc3tRX0n.s:9: Error: suffix or operands invalid for `pop'
make[1]: *** [crtbegin.o] Error 1
make[1]: Leaving directory `/tmp/mingw32/stage1-build/gcc'
make: *** [all-gcc] Error 2
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64

Re: mingw32

Messaggioda 414N » dom mag 29, 2011 9:28

That error is typical on 64 bit systems when you try to assemble 32 bit assembly in 64 bit code.
My suggestion is to modify the CPUOPT variable, adding the "-m32" flag before compilation starts.
You can do this just before the configure:
Codice: Seleziona tutto
CPUOPT+=" -m32"
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: mingw32

Messaggioda so_slack » dom mag 29, 2011 10:57

414N ha scritto:That error is typical on 64 bit systems when you try to assemble 32 bit assembly in 64 bit code.
My suggestion is to modify the CPUOPT variable, adding the "-m32" flag before compilation starts.
You can do this just before the configure:
Codice: Seleziona tutto
CPUOPT+=" -m32"


i try to change
Codice: Seleziona tutto
x86_64)
    CPUOPT="-O2 -fPIC"
    ;;
*)
to
Codice: Seleziona tutto
x86_64)
    CPUOPT="-O2 -fPIC -m32"
    ;;
*)

but same error :p
so_slack
Linux 1.0
Linux 1.0
 
Messaggi: 19
Iscritto il: gio gen 06, 2011 16:16
Nome Cognome: noog
Slackware: 13.1
Kernel: x86_64


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Bing [Bot], Google [Bot] e 1 ospite