Repository 32bit  Forum
Repository 64bit  Wiki

eclipse su slackware64 13.37 [risolto]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

eclipse su slackware64 13.37 [risolto]

Messaggioda daniele50 » mar giu 07, 2011 11:06

Ciao,
ho scaricato eclipse-jee-helios-SR2-linux-gtk-x86_64.tar.gz e ho estratto l'archivio, quando poi lancio il file bin eclipse mi esce una finastra con questo errore:

Codice: Seleziona tutto
JVM terminated. Exit code=13
/usr/lib/java/bin/java
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/cindan/pkg/eclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /home/cindan/pkg/eclipse/eclipse/eclipse
-name Eclipse
--launcher.library /home/cindan/pkg/eclipse/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.2.R36x_v20101019_1345/eclipse_1310.so
-startup /home/cindan/pkg/eclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar
-exitdata 21b10005
-product org.eclipse.epp.package.jee.product
-vm /usr/lib/java/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/cindan/pkg/eclipse/eclipse//plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar


Purtroppo non ho trovato eclipse pacchettizzato per 64bit... qualcuno lo usa su slackware64 13.37?
Ultima modifica di daniele50 il mar giu 07, 2011 13:42, modificato 1 volta in totale.
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 928
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.2.29
Desktop: Xfce 4.10

Re: eclipse su slackware64 13.37

Messaggioda 414N » mar giu 07, 2011 11:37

Io lo impacchetto regolarmente tramite questo SlackBuild.
Di errori nello spezzone che riporti non ne vedo, a parte la prima riga. Estrai il tarball sempre nella stessa directory? Prova a spostarla/rimuoverla e poi estrai nuovamente il tarball.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: eclipse su slackware64 13.37

Messaggioda pedro70 » mar giu 07, 2011 12:59

Ciao,
secondo me non sta usando la jvm corretta. Dovrebbe essere in /usr/lib64/java e non in /usr/lib.
Puoi forzare la jvm modificando il file eclipse.ini così:
Codice: Seleziona tutto
-vm
/usr/lib64/java/bin/java
pedro70
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: mer ott 17, 2007 8:38
Località: Alessandria
Slackware: 14.0
Kernel: 3.2.29
Desktop: KDE-4.8.5

Re: eclipse su slackware64 13.37

Messaggioda daniele50 » mar giu 07, 2011 13:24

Ho cancellato tutto e ho pacchettizzato eclipse con lo slackBuold (grazie 414N), ho installato il pacchetto e all'avvio avevo ancora l'errore (non identico ma simile: cercava sempre java nella lib e non nella lib64).
Allora ho modificato il file /opt/eclipse/eclipse.ini aggiungendo
Codice: Seleziona tutto
-vm
/usr/lib64/java/bin/java

all'inizio del file (grazie pedro70) ed ora parte! :thumbright:

Ciao!
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 928
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.2.29
Desktop: Xfce 4.10


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Bing [Bot] e 2 ospiti