Repository 32bit  Forum
Repository 64bit  Wiki

[risolto] attivare mod_rewrite

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[risolto] attivare mod_rewrite

Messaggioda theodallago » gio giu 16, 2011 14:00

come si attiva il modulo mod_rewrite di apache su slackware 13.37?
Ultima modifica di theodallago il sab giu 18, 2011 17:09, modificato 1 volta in totale.
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE

Re: attivare mod_rewrite

Messaggioda theodallago » gio giu 16, 2011 15:27

per completezza questo è l'htaccess

Codice: Seleziona tutto
RewriteEngine On
RewriteBase   /
Rewrit/eRule ^p/([^/]+).html index.php?ref=$1 [L]


e puntando a http://localhost/p/2.html mi da errore 404 mentre su alcuni servizi di hosting funziona.
nel phpinfo() mod_rewrite me lo da come attivo...
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE

Re: attivare mod_rewrite

Messaggioda theodallago » gio giu 16, 2011 20:41

non c'e nessuno che mi sappia aiutare?
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE

Re: attivare mod_rewrite

Messaggioda roberto67 » gio giu 16, 2011 21:49

theodallago ha scritto:non c'e nessuno che mi sappia aiutare?


Tempo fa ho scritto questo http://notes.sagredo.eu/node/104 su come abilitare mod_rewrite e usarlo per per i cosiddetti "SEO friendly urls"
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: attivare mod_rewrite

Messaggioda theodallago » gio giu 16, 2011 22:07

Grazie per la risposta. Ho visto che occorre dare il comando:

./configure --enable-rewrite

devo quindi reinstallare apache?
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE

Re: attivare mod_rewrite

Messaggioda roberto67 » gio giu 16, 2011 23:40

theodallago ha scritto:Grazie per la risposta. Ho visto che occorre dare il comando:

./configure --enable-rewrite

devo quindi reinstallare apache?


Se sei sicuro di non aver compilato il modulo si. Altrimenti, se mod_rewrite è stato installato, per far sì che esso possa essere gestito da .htaccess, è necessario avere questo

Codice: Seleziona tutto
AllowOverride Options FileInfo
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: attivare mod_rewrite

Messaggioda theodallago » sab giu 18, 2011 17:09

ok adesso è perfetto!
grazie!!! :thumbright:
Avatar utente
theodallago
Linux 1.0
Linux 1.0
 
Messaggi: 59
Iscritto il: ven lug 02, 2010 14:55
Nome Cognome: theo
Slackware: 13.37
Kernel: 2.6.33.4
Desktop: KDE
Distribuzione: Sabayon, OpenSUSE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: navajo e 5 ospiti