Repository 32bit  Forum
Repository 64bit  Wiki

Non riesco ad installare slacky

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Non riesco ad installare slacky

Messaggioda osharko » gio giu 23, 2011 18:09

scusa volevo dire, comunque con startx funziona... cioè l0interfaccia grafica si è avviata...
per il fatto di aver sbagliato è difficile xke ho tentato + volte.. ho fatto addirittura cosi
cd /etc/modprobe.d/
ls
e col file del nome sopra ho scritto
echo "blacklist neuveau" >> blacklist.conf


poi ravviato... quindi boh...
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda erio » gio giu 23, 2011 18:25

se vai in slackware index, trovi in extra il modulo fatto per i noveau, per metterli in blacklist,cosi non ti complichi la vita,secondo me dopo aver attivato il modulo disinstalla i driver e li rinstalli,ed e' sicuramente la via piu' facile.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1068
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Non riesco ad installare slacky

Messaggioda osharko » gio giu 23, 2011 18:49

passaggi un po piuù dettagliati? sorry se rompo .
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda 414N » ven giu 24, 2011 7:46

osharko ha scritto:echo "blacklist neuveau" >> blacklist.conf

Se hai scritto questo hai sbagliato.
Il nome del modulo è nouveau, non neuveau. Puoi verificare l'esistenza di un modulo (tanto per vedere se il nome è corretto) con
Codice: Seleziona tutto
modinfo nome_modulo

Se sei riuscito ad avviare la sessione grafica, allora puoi usare un qualunque editor di testo sotto X. Sappi che, se lanci la sessione grafica da utente non privilegiato e volessi lanciare un'applicazione come utente root (tipo l'editor di testo per andare a modificare blacklist.conf), molto probabilmente dovrai lanciare questo comando
Codice: Seleziona tutto
xhost +
da utente normale per permettere a root di aprire finestre nella tua sessione X.
Tanto per fare un esempio, mettiamo che tu voglia aprire /etc/modprobe.d/blacklist.conf da root con kate (sto presumendo che tu usi KDE o che, comunque, i suoi pacchetti siano stati installati) e ti sia loggato nel sistema (prima di startx) col tuo utente non privilegiato. Apri un terminale dando xhost come scritto sopra, poi passa a root (su oppure su -) e poi puoi aprire il file con kate tramite
Codice: Seleziona tutto
kate /etc/modprobe.d/blacklist.conf
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Non riesco ad installare slacky

Messaggioda erio » ven giu 24, 2011 10:02

qui lo trovi,http://taper.alienbase.nl/mirrors/slackware/slackware64-13.37/extra/xf86-video-nouveau-blacklist/xf86-video-nouveau-blacklist-noarch-1.txz
dop averlo installato in init 3 nvidia-uninstall e rifai la procedura di installazione,che versione dei driver hai.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1068
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Non riesco ad installare slacky

Messaggioda osharko » ven giu 24, 2011 13:21

dopo essere eentrato nella sezione grafica, ho effettuato direttamente l` accesso al file blacklist, dopodiche` ho inserito
blacklist nouveau.
poi ho ravviato e non partiva piu` il comando sh .-,
ma il comando startx funge ancora....
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda 414N » ven giu 24, 2011 13:56

osharko ha scritto:poi ho ravviato e non partiva piu` il comando sh .-,

E che comando sarebbe? Il comando che ti avevo suggerito in precedenza,
Codice: Seleziona tutto
su -
(su = switch user) serve a diventare root quando si è loggati come utenti normali. Il "-" serve ad ottenere un ambiente il più simile possibile a quello di un'equivalente shell di login, ma non divaghiamo troppo.
Se invece intendevi il comando per far partire l'installazione dei driver nvidia, beh, sei stato molto vago... Quando una cosa non funziona, difficilmente non produce nessun output utile a capire cosa è andato storto, percui aiutaci ad aiutarti.
osharko ha scritto:ma il comando startx funge ancora....

Va bene che funzioni ancora. In mancanza di nouveau (spero), probabilmente X userà VESA.
Quello che dovresti fare ora è accertarti che il modulo nouveau non sia stato caricato automaticamente dal sistema dopo il riavvio in seguito alla modifica del file blacklist.conf, ovvero verificare che la voce aggiunta al file di blacklist abbia sortito l'effetto voluto.
Per farlo, usa il comando che ti avevo detto in precedenza, cioè
Codice: Seleziona tutto
lsmod | grep nouveau

Se il modulo è stato caricato dovrebbe comparirti una riga (male), altrimenti no (bene).
Nel caso nouveau non sia stato caricato, puoi procedere all'installazione dei driver nvidia che avevi scaricato in precedenza.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Non riesco ad installare slacky

Messaggioda osharko » sab giu 25, 2011 21:51

sh è il comando per l'installazione del driver nvidia (perchè per il root ,che mi è gia fornito dal mio accesso con username "root", uso -sudo su-).
comunque mi dice che il comando non esiste e non so che fare...
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda erio » sab giu 25, 2011 22:00

hai scaricato la versione dei driver adatta alla tua architettura in root,se si: sh NVIDIA-Linux-x86_64-275.09.07.run e segui quello che ti dice installa anche le libs 32 alla file salva la vecchia configurazione e dai startx, poi per la risoluzione e altro, pannello di controllo nvidia
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1068
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Non riesco ad installare slacky

Messaggioda osharko » sab giu 25, 2011 22:19

Allora il comando
lsmod | grep neuveau non da risultati quindi e` una buona cosa :)
per quanto riguarda i driver... ora provo a cercarli
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda 414N » dom giu 26, 2011 9:46

osharko ha scritto:sh è il comando per l'installazione del driver nvidia (perchè per il root ,che mi è gia fornito dal mio accesso con username "root", uso -sudo su-).
comunque mi dice che il comando non esiste e non so che fare...

Fammi capire: accedi al sistema come root e poi usi pure "sudo su"? Non è che facendo così diventi "più root" ;)
Bando agli scherzi, se esegui login come root non hai bisogno di nessun cambio utente. Tieni presente inoltre che in Slackware l'utente root esiste e non hai bisogno di "sudare" di continuo per fare ogni minima cosa che possa cambiare il sistema. Al massimo, se sei utente normale, diventi root con "su" o "su -" e applichi i cambiamenti che devi applicare.
Il fatto che il comando non esista può voler dire che non sei nella directory contenente il file d'installazione dei driver. Dove li hai scaricati?
Se li hai scaricati in /home/user/Downloads (tanto per fare un esempio), per lanciare l'installazione dovrai scrivere:
Codice: Seleziona tutto
sh /home/user/Downloads/NVIDIA-Linux....run

oppure entrare in quella directory ed usare il comando senza percorso assoluto. Non so se lo sai, ma la shell dispone dell'autocompletamento dei percorsi dei file, percui non hai bisogno di scrivere a mano tutto il percorso: comincia a scrivere qualche carattere e, premendo TAB, la shell ti suggerirà come completarlo.
osharko ha scritto:Allora il comando
lsmod | grep neuveau non da risultati quindi e` una buona cosa :)

Sarebbe una buona cosa se tu l'avessi scritto correttamente (e 2...).
Ti ripeto che il nome del modulo è nouveau. Spero che quelli che riporti siano typo...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Non riesco ad installare slacky

Messaggioda osharko » mar giu 28, 2011 20:13

non so perchè qui scrivo sempre neuveau e su slacky nouveau o.o
per quanto riguarda la compilazione dei driver , facendo>
sh root/NVIDIA-Linux-x86_64.run
sono riuscito ad installarlo... ma al ravvio per avviare la sessione grafica ho comunque dovuto utilizzare il comando
STARTX...
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda 414N » mer giu 29, 2011 8:08

osharko ha scritto:sono riuscito ad installarlo... ma al ravvio per avviare la sessione grafica ho comunque dovuto utilizzare il comando
STARTX...

Ti ho già spiegato il perché. Leggiti S4D (Slackware for dummies) e cerca come cambiare il runlevel di default da 3 a 4.
Inoltre, hai creato un file xorg.conf base tramite nvidia-settings? Se non lo fai, poi X non userà il driver nvidia...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Non riesco ad installare slacky

Messaggioda osharko » mer giu 29, 2011 11:40

non no l'ho fatto, perchè comunque non ho un interfaccia grafica con la quale posso utilizzare i tools di Nvidia-setting!
Se potessi per l'ennesima volta postarmi i passaggi.. Grazie
osharko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: gio giu 23, 2011 13:30

Re: Non riesco ad installare slacky

Messaggioda 414N » mer giu 29, 2011 12:11

osharko ha scritto:non no l'ho fatto, perchè comunque non ho un interfaccia grafica con la quale posso utilizzare i tools di Nvidia-setting!

Ti chiedo scusa, non avendo una scheda nvidia (e quindi non usando i driver nvidia) mi sono sbagliato.
Intendevo dire di lanciare l'utility per la configurazione iniziale automatica di X, ovvero nvidia-xconfig.
Una volta lanciato come root, dovresti essere in grado di lanciare una sessione X che usi quel driver.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

PrecedenteProssimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite