Repository 32bit  Forum
Repository 64bit  Wiki

Problema accenti con editor di testo

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema accenti con editor di testo

Messaggioda elvis » sab lug 09, 2011 16:14

Salve, quando tramite penna usb trasferisco un file di testo (editato sul netbook, o sul vecchio notebook quando ancora lo usavo) al fisso con slackware, puntualmente aprendolo su slackware vengono sballati tutti i caratteri accentati, per esempio:

è -> Ú
à -> Ã

e così via.
C'è un modo per risolverlo? Il problema penso si presenti su qualsiasi file di testo, per ora l'ho accertato su file .txt, .c e .java

se può servire, gli editor usati sono in entrambe le piattaforme kwrite, kate, e l'editor di eclipse.
Ultima modifica di elvis il lun lug 25, 2011 9:25, modificato 2 volte in totale.
elvis
Linux 1.0
Linux 1.0
 
Messaggi: 53
Iscritto il: lun set 27, 2010 9:35
Slackware: 13.1 x64
Desktop: KDE 4.5.2
Distribuzione: Opensuse 11.3 x86

Re: Problema accenti con editor di testo

Messaggioda Savius » sab lug 09, 2011 18:48

Non vorrei dire una baggianata quindi prendila con le pinze, ma è possibile che la codifica ISO utilizzata è differente. Dovresti provare a selezionare in "Strumenti" > "Codifica" una codifica occidentale, magari la classica iso8859-1 oppure l'UTF-8/UTF-16, ora non saprei. Fai una prova. :D
Avatar utente
Savius
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: gio ago 14, 2008 12:45
Località: Napoli
Slackware: Slackware64 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.8.5

Re: Problema accenti con editor di testo

Messaggioda elvis » ven lug 15, 2011 16:54

Ok, mettendo unicode utf-8 ho risolto, però mentre su kate e kwrite l'ho impostata di default, non riesco a fare lo stesso su eclipse. Per ora ho trovato solo edit->set endocoding, che mi fa scegliere la codifica ma solo temporaneamente. Qualcuno ha idea di come si imposti questa cosa in via definitiva su eclipse?
elvis
Linux 1.0
Linux 1.0
 
Messaggi: 53
Iscritto il: lun set 27, 2010 9:35
Slackware: 13.1 x64
Desktop: KDE 4.5.2
Distribuzione: Opensuse 11.3 x86

Re: Problema accenti con editor di testo

Messaggioda 414N » ven lug 15, 2011 19:04

elvis ha scritto:Qualcuno ha idea di come si imposti questa cosa in via definitiva su eclipse?

Window->Preferences->General->Workspace->Text File Encoding.
Sappi che puoi impostare un encoding specifico a livello di singoli file o a livello di progetto.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema accenti con editor di testo

Messaggioda elvis » sab lug 16, 2011 9:33

Perfetto, grazie a tutti!
elvis
Linux 1.0
Linux 1.0
 
Messaggi: 53
Iscritto il: lun set 27, 2010 9:35
Slackware: 13.1 x64
Desktop: KDE 4.5.2
Distribuzione: Opensuse 11.3 x86

Re: Problema accenti con editor di testo

Messaggioda elvis » lun lug 25, 2011 9:27

Scusate se riuppo, sarebbe più un argomento da affrontare in sezione Programmazione, ma approfitto di questo thread.

Nonostante abbia risolto per quanto riguarda il codice vero e proprio, ho ancora lo stesso problema per quanto riguarda javadoc, qualcuno ha idea di come si imposti la codifica per i testi di javadoc?
elvis
Linux 1.0
Linux 1.0
 
Messaggi: 53
Iscritto il: lun set 27, 2010 9:35
Slackware: 13.1 x64
Desktop: KDE 4.5.2
Distribuzione: Opensuse 11.3 x86

Re: Problema accenti con editor di testo

Messaggioda 414N » lun lug 25, 2011 9:34

Parli delle pagine HTML generate da javadoc, giusto?
javadoc dispone dell'opzione -locale. Digita javadoc -help per vedere i dettagli.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema accenti con editor di testo

Messaggioda elvis » lun lug 25, 2011 14:29

mmm no, per il momento non ho ancora generato i file html veri e propri tramite javadoc, sto semplicemente mettendo i commenti con i tag (@param, ecc.), lasciando che eclipse me li mostri automaticamente al passaggio del mouse sopra un metodo o sopra una classe.
Trattandosi di html ovviamente basterebbe mettere gli - é e soci - del caso, ma non c'è proprio nessun modo per evitare ciò ed evitare di dover creare direttamente i file html?
elvis
Linux 1.0
Linux 1.0
 
Messaggi: 53
Iscritto il: lun set 27, 2010 9:35
Slackware: 13.1 x64
Desktop: KDE 4.5.2
Distribuzione: Opensuse 11.3 x86

Re: Problema accenti con editor di testo

Messaggioda 414N » lun lug 25, 2011 14:42

Non lo so, ma penso di no.
Puoi sempre crearti uno script che sostituisca (tramite sed o awk) le occorrenze dei vari caratteri accentati con le corrispondenti sequenze HTML e lanciarlo sui file scritti normalmente una volta finito di lavorarci.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti