Repository 32bit  Forum
Repository 64bit  Wiki

Macbook pro 5,1

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Macbook pro 5,1

Messaggioda manublade » gio ago 04, 2011 22:10

Ho installato i setuptool, ma synaptiks con il comando da te indicato esce con:
Traceback (most recent call last):
File "setup.py", line 31, in <module>
from kdedistutils import setup
ImportError: No module named kdedistutils
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21

Re: Macbook pro 5,1

Messaggioda 414N » ven ago 05, 2011 8:58

manublade ha scritto:Ho installato libconfuse in /usr/local ma poi pommed non trovava il percorso di PKG_CONFIG.
Ho visto che non era nel path e che nessuna libreria c'è in /usr/local, per caso è deprecato come percorso?

Perché l'hai installato manualmente quando ti ho riportato il link dove trovarne lo SlackBuild?
/usr/local non è il prefix di default di Slackware (che è invece /usr), percui è normale che lo trovi "deserto".
manublade ha scritto:Ho installato i setuptool, ma synaptiks con il comando da te indicato esce con:
Traceback (most recent call last):
File "setup.py", line 31, in <module>
from kdedistutils import setup
ImportError: No module named kdedistutils

A me non succede. Hai provato con l'ultima versione disponibile al momento, la 0.7.0?
Ricordati che tramite i setuptools lisci non puoi disinstallare in modo automatico il programma, quindi forse ti conviene fare un pacchetto...
Per fare un pacchetto manualmente, vai in /tmp, diventa root, estrai il tarball, entra nella directory e lancia il seguente comando
Codice: Seleziona tutto
python setup.py install --root=/tmp/package --single-version-externally-managed

Successivamente, vai in /tmp/package e scrivi il seguente comando:
Codice: Seleziona tutto
makepkg -l y -c n /tmp/synaptiks-0.7.0-noarch-1.txz

Il pacchetto dovrebbe essere ora creato corretamente. Installalo e vedi se funziona.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Macbook pro 5,1

Messaggioda manublade » ven ago 05, 2011 16:39

In giro la 0.6.c11 è l'ultima trovata, ovvero quella qui su slacky. boh?
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21

Re: Macbook pro 5,1

Messaggioda 414N » ven ago 05, 2011 17:40

Intendevo la versione 0.7.0 di synaptiks.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Macbook pro 5,1

Messaggioda manublade » ven ago 05, 2011 21:07

ah si, ho già la 0.7.0.


boh!
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21

Re: Macbook pro 5,1

Messaggioda 414N » sab ago 06, 2011 9:11

Ti pregherei di ricontrollare, perché io alla riga 31 del file setup.py non ho
Codice: Seleziona tutto
from kdedistutils import setup

ma
Codice: Seleziona tutto
from setuptools import setup

Prova a riscaricare il tarball dei sorgenti.
EDIT: ho creato e allegato uno SlackBuild per synaptiks, se vuoi provarlo.
Se ti crea un pacchetto funzionante, magari lo invio ad SBo...
Allegati
synaptiks.tar.gz
SlackBuild per synaptiks
(10 KiB) Scaricato 15 volte
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Macbook pro 5,1

Messaggioda manublade » sab ago 06, 2011 13:30

Ciao e grazie.
Con lo slackbuild e dopo aver riscaricato i sorgenti si installa, ma questo il risultato all'avvio.
Codice: Seleziona tutto
bash-4.1$ synaptiks
Traceback (most recent call last):
  File "/usr/bin/synaptiks", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib64/python2.6/site-packages/pkg_resources.py", line 2603, in <module>
    working_set.require(__requires__)
  File "/usr/lib64/python2.6/site-packages/pkg_resources.py", line 666, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib64/python2.6/site-packages/pkg_resources.py", line 565, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: argparse>=1.1
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21

Re: Macbook pro 5,1

Messaggioda 414N » sab ago 06, 2011 13:36

Hai bisogno di installare anche argparse e pyudev. Di quest'ultimo ti allego uno SlackBuild al post.
Allegati
pyudev.tar.gz
SlackBuild per pyudev
(10 KiB) Scaricato 17 volte
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Macbook pro 5,1

Messaggioda manublade » dom ago 07, 2011 9:28

Ciao, finalmente installato grazie.

Ora con calma, sono in ferie :-), provo tante piccole cose, spero mi aiuterai ancora dovessi avere bisogno.

Ema.
manublade
Linux 2.4
Linux 2.4
 
Messaggi: 499
Iscritto il: dom gen 08, 2006 22:21

Precedente

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti