Repository 32bit  Forum
Repository 64bit  Wiki

Man page in UTF8 e man

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Man page in UTF8 e man

Messaggioda targzeta » lun ago 15, 2011 17:31

Salve a tutti. Non avendo ancora fatto il passaggio a UTF8 (ammetto di avere un po' di timore) ho un fastidioso problema con le pagine man codificate in UTF8. Una per tutte è la pagina italiana di mplayer, quando la visualizzo mi vengono fuori dei caratteri errati, ad esempio:
Codice: Seleziona tutto
mplayer Ú un visualizzatore
Il mio locale è impostato come it_IT@euro.

Su internet ho trovato questo link dove spiega che bisognerebbe modificare il file man.conf (che nella Slackware è sotto /usr/lib e non sotto /etc) inserendo al posto della riga:
Codice: Seleziona tutto
NROFF      /usr/bin/nroff -c --legacy NROFF_OLD_CHARSET -mandoc 2>/dev/null
la riga:
Codice: Seleziona tutto
NROFF      /usr/bin/groff -Tascii -mandoc
peccato però che la riga in questione del file, sotto Slackware sembra sia stata già settata più o meno opportunamente:
Codice: Seleziona tutto
NROFF           /usr/bin/nroff -mandoc
proprio come indicato nello stesso file...anche se lasciando qualche dubbio:
Codice: Seleziona tutto
# For use with utf-8, NROFF should be "nroff -mandoc" without -T option.
# (Maybe - but today I need -Tlatin1 to prevent double conversion to utf8.)

Emanuele

P.S. Se volete possiamo anche discutere su come passare a UTF8 e se ci sono problemi.
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Man page in UTF8 e man

Messaggioda targzeta » dom set 23, 2012 21:52

Aggiorno il thread perché ora succede qualcosa di strano. Se lancio:
Codice: Seleziona tutto
man mplayer
noto che alcune lettere sono corrette, tipo la 'è', la 'ù' e la 'ò', mentre altre no, come la 'à'. Io ci capisco veramente poco. Il manuale è in utf8...boh.

Qualsiasi consiglio è ben accetto.
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti