Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] problema con flash e firefox su slack64

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] problema con flash e firefox su slack64

Messaggioda -sf » sab ago 27, 2011 12:16

Ciao a tutti!

Ho un problemino con l'installazione di flash player su una slackware64.

Dunque premetto che non ho installato firefox in maniera "classica"; non avevo tempo per compilarlo e quindi ho scaricato il pacchetto precompilato di Mozilla, decompresso in una directory e poi creato un symlink in /usr/bin che puntasse all'eseguibile scaricato prima.
Il browser funziona senza problemi, a parte appunto flashplayer!

Ho provato col pacchetto che si trova qui su slacky ma non funziona (giustamente, credo! penso cerchi le directory di un'installazione standard); ho anche provato a mettere a manina il file libflashplayer.so nella directory plugins di firefox ma niente.

Che faccio?
Mi conviene installare firefox in maniera classica e poi posizionare il file libflashplayer.so sotto /usr/lib...ecc?

Grazie! :)
Ultima modifica di -sf il ven set 02, 2011 13:42, modificato 1 volta in totale.
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda 414N » sab ago 27, 2011 12:37

Indipendentemente dal firefox che usi, questo andrà sempre a cercare i plugin anche in ~/.mozilla/plugins, percui io lo piazzerei lì flash.
Se poi serve anche ad altri utenti del computer, si può vedere di capire dove lo vada a cercare a livello system-wide.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema con flash e firefox su slack64

Messaggioda targzeta » sab ago 27, 2011 13:13

Cosa intendi per "maniera classica"? Da quello che scrivi sembra che tu intenda compilare e installare. Credo che invece la maniera classica sia quella di installare il pacchetto precompilato della Slackware, no?

Comunque, la directory in cui sono installati i plugin di sistema è, sulla Slackware64:
Codice: Seleziona tutto
/usr/lib64/mozilla/plugins/

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6149
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: problema con flash e firefox su slack64

Messaggioda -sf » sab ago 27, 2011 18:41

Pardon per maniera classica intendevo dire utilizzando i percorsi di default, ora ho scompattato il tar.gz precompilato di mozilla in /opt se ricordo bene e poi ho creato un collegamento da /usr/bin che punta all'eseguibile in /opt.

Mettendo il file libflash....so in /usr/lib64/mozilla/plugins non funziona (tra l'altro la directory mozilla ho dovuto crearla poiche non esisteva, come sa ff a sapere che deve cercare li?)

Seguendo il consiglio 414N stessa cosa, provando ad accedere a youtube ad esempio al posto del video mi compare il link al sito di adobe.
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda 414N » sab ago 27, 2011 18:45

Mi sa che tu stia tentando di far andare firefox64 con flash a 32 bit o viceversa firefox32 con flash a 64 bit.
Quale firefox hai installato, di preciso? 32 o 64 bit?
Quale flash stai tentando di far andare? 32 o 64 bit?
Ultima modifica di 414N il dom ago 28, 2011 12:01, modificato 1 volta in totale.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema con flash e firefox su slack64

Messaggioda -sf » sab ago 27, 2011 19:56

flash di sicuro a 64, firefox ora mi hai messo il dubbio ma al 90% è a 64... controllerò per maggiore sicurezza!
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda conraid » dom ago 28, 2011 11:55

Il precompilato di mozilla ha percorsi diversi per cercare i plugin, infatti viene patchato su Slackware proprio per questo.
Se usi il precompilato e usi il pc solo tu usa il percorso che ti ha indicato 414n, altrimenti nella directory plugins dove hai decompresso il tar. Per esempio /opt/firefox-6.0/plugins

Qui maggiori info
http://kb.mozillazine.org/Determining_p ... y_on_Linux
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: problema con flash e firefox su slack64

Messaggioda -sf » mer ago 31, 2011 20:10

Niente da fare, ho provato in tutti i percorsi suggeriti ma non ne vuole sapere...

Il fatto che stia utilizzando la nightly potrebbe influire? Per definizione non è una release stabile ma non mi sta dando alcun problema a parte flash
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda 414N » mer ago 31, 2011 20:20

Io sto usando la 9.0a1 pacchettizzata dal buon ZeroUno per Slackware64 13.37 e flash mi funziona senza problemi.
Ho dovuto però creare un link alla directory plugins per fargli rilevare i vari plugin a livello system-wide, dato che il pacchetto non usa la convenzione standard di Slackware (è giusto per testing).
Nella directory dove hai estratto il tarball di firefox, individua la sottodirectory che contiene il binario firefox-bin e lì crea un link simbolico alla directory dei plugin dove hai installato flash e altro.
Per trovare il binario, puoi usare find:
Codice: Seleziona tutto
find /path/dove/hai/piazzato/firefox -name firefox-bin
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema con flash e firefox su slack64

Messaggioda -sf » mer ago 31, 2011 21:15

Ne sto uscendo pazzo, ora non si avvia Firefox...
Se lo avvio da terminale mi risponde con un simpatico segmentation fault :x

Ora provo con la release stable, vediamo se cambia qualcosa...
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda -sf » gio set 01, 2011 13:20

Ho installato il pacchetto presente della directory "extra" del dvd di installazione, ora riesco ad avviare firefox ma il problema con flash persiste.

Se lo lancio da terminale come utente nessun problema, se lo lancio invece come root si avvia ma mi notifica un errore nel caricamento dei plugins:
Codice: Seleziona tutto
LoadPlugin: failed to initialize shared library /usr/lib64/firefox-4.0/plugins/libflashplayer.so [/usr/lib64/firefox-4.0/plugins/libflashplayer.so: wrong ELF class: ELFCLASS32]


In questo momento quindi ho: firefox installato tramite pacchetto preso dal dvd di installazione (v.4.0), libflashplayer.so posizionato in /usr/lib64/firefox-4.0/plugins e in ~/.mozilla/plugins.

Non so interpretare l'errore, che sia la versione sbagliata di flash? Eppure l'ho scaricato dal sito di Adobe, selezionando il tar.gz per "linux 64bit".
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda 414N » gio set 01, 2011 19:53

Direi che sia lampante dall'errore riportato che il plugin presente in /usr/lib64/firefox-4.0/plugins/libflashplayer.so sia a 32 bit (ELFCLASS32), esattamente come sospettavo.
In questo post trovi i pacchetti dell'ultima beta (2) di flashplayer 11 a 64 bit.
Se
Codice: Seleziona tutto
grep lahf /proc/cpuinfo
ti riporta una riga, allora scarica la versione liscia. Altrimenti la versione con fix LAHF.
Magari prima rimuovi il flash a 32 bit che hai installato ora nel sistema
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema con flash e firefox su slack64

Messaggioda -sf » gio set 01, 2011 20:35

Ottimo funziona a meraviglia anche sulla nightly!

Eppure ero sicurissimo di aver scaricato la versione a 64bit...
Non importa, grazie mille! :)

Piccolo OT (neanche poi tanto): ora ho piazzato nuovamente firefox in /opt e il plugins nella directory .mozilla della mia home e funziona tutto; ma come mai l'altra sera se tentavo di avviarlo in questo modo mi restituiva un bel segmentation fault?
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: problema con flash e firefox su slack64

Messaggioda 414N » gio set 01, 2011 22:23

-sf ha scritto:Piccolo OT (neanche poi tanto): ora ho piazzato nuovamente firefox in /opt e il plugins nella directory .mozilla della mia home e funziona tutto; ma come mai l'altra sera se tentavo di avviarlo in questo modo mi restituiva un bel segmentation fault?

Il segmentation fault mi puzza di qualche incompatibilità a livello di librerie.
Per quanto riguarda il mancato funzionamento, firefox64 non può usare plugin a 32 bit (e viceversa).
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: problema con flash e firefox su slack64

Messaggioda -sf » gio set 01, 2011 23:20

414N ha scritto:
-sf ha scritto:Piccolo OT (neanche poi tanto): ora ho piazzato nuovamente firefox in /opt e il plugins nella directory .mozilla della mia home e funziona tutto; ma come mai l'altra sera se tentavo di avviarlo in questo modo mi restituiva un bel segmentation fault?

Il segmentation fault mi puzza di qualche incompatibilità a livello di librerie.
Per quanto riguarda il mancato funzionamento, firefox64 non può usare plugin a 32 bit (e viceversa).

Mi è comparso dopo aver eliminato per un pò di volte le directory di firefox in /opt; d'un tratto non partiva più... pensavo ad un errore mio nella copia dei file o nel creare il link alla dir /usr/bin.
In ogni caso ho risolto! :)

Grazie per le dritte :thumbright:
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron