Repository 32bit  Forum
Repository 64bit  Wiki

Bug report per Openshot e kdenlive

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Bug report per Openshot e kdenlive

Messaggioda gorwell » dom ott 02, 2011 15:17

Salve, Slackware 13.37, configurato slapt-get e come sorgenti il mirror ufficiale, il repo extra e slacky.eu.

LANG settata a it_IT@utf8

Installato kdenlive e openshot.

OPENSHOT
All'avvio openshot da il seguente messaggio:
Codice: Seleziona tutto
------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.3.1)
--------------------------------
Process no longer exists: 30708.  Creating new pid lock file.

------------------------- ERROR 2 ------------------------------
Failed to import 'from openshot.openshot import main'
Error Message: unknown locale: it_IT@utf8
----------------------------------------------------------------

OpenShot has failed to import some of the Python files or libraries
required for our application to run.  Here are some trouble shooting
tips:

Tip 1) Check if MLT can be successfully imported in Python.  Run the
 following commands, and see if any errors are displayed.  If you get
 an error, you need to investigate the correct way to install MLT.
 NOTE:  Do not type the $ or >> characters in the examples below.

       $ python
       >> import mlt
       >> mlt.Factory().init()

Tip 2) If MLT is working from the first example, then the next tip is
 to look at the above error messages very closely, and google for more
 help.  It's likely the problem is already reported, and maybe there is
 a simple work-around.  Also, you can search for bugs or report a new
 bug at https://bugs.launchpad.net/openshot.  Good luck!


Se lo avvio con LANG=it_IT da il seguente:
Codice: Seleziona tutto
pascal@Portatile:~$ LANG=it_IT openshot

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.3.1)
--------------------------------
Process no longer exists: 32663.  Creating new pid lock file.
No formats or codecs were found.  Please check the OpenShot preferences and configure the 'melt' command name.
Errore di segmentazione


Parte solo con LANG=en_US openshot
visualizzandomi 3 finestre consecutivamente (sembra una tv analogica senza antenna) e dopo mi avverte che via gui "No formats or codecs were found. Etc..."

KDENLIVE
Mostra il seguente messaggio:
Il modulo SDL per MLT non è stato trovato. Controllare l'installazione di MLT.

Se qualcuno mi sa dare una mano per risolvere ringrazio, altrimenti considerateli bug reports.

By, Pascal
gorwell
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: mar ott 28, 2008 10:10
Nome Cognome: Pascal Allegra
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE 4.5.5

Re: Bug report per Openshot e kdenlive

Messaggioda gorwell » dom ott 02, 2011 16:53

Amarok non funziona neanche, credevo che i pacchetti di slacky.eu fossero migliori. L'aggiornamento richiede libavformat.so.52 libavcodec.so.52 ma ffmpeg 0.8.4 ha la versione .53.

Mi sa che torno a slackbuilds.org.

Pascal
gorwell
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: mar ott 28, 2008 10:10
Nome Cognome: Pascal Allegra
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE 4.5.5

Re: Bug report per Openshot e kdenlive

Messaggioda targzeta » dom ott 02, 2011 17:24

Per i problemi al primo post: sei sicuro di aver installato tutte le dipendenze richieste?

Per amarok. Vuoi dire che la versione di amarok presente nel repository collide con la versione di ffmpeg dello stesso repository? Se è così sicuramente è un bug, altrimenti spiegati meglio.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Bug report per Openshot e kdenlive

Messaggioda rik70 » dom ott 02, 2011 18:11

Controlla se hai installato il pacchetto mlt.
Prova a dare:
Codice: Seleziona tutto
which melt


Poi c'è un errore nalla variabile LANG.

Lancialo con
Codice: Seleziona tutto
LANG=it_IT.UTF-8


A me con le altre localizzazioni italiane - LANG=it_IT/it_IT@euro - va in segfault senza complimenti (slackware 13.1).

Ciao

P.s.

Il mio è il pacchetto SBo, non quello slacky.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1254
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Bug report per Openshot e kdenlive

Messaggioda gorwell » dom ott 02, 2011 20:12

spina ha scritto:Per i problemi al primo post: sei sicuro di aver installato tutte le dipendenze richieste?

Yes, usato slapt-get e comunque il problema lo dava con mlt (sia openshot che kdenlive). Comunque il bug è facilmente riproducibile, installi una slack 13.37 fresca. Aggiorni con slapt-get aggiungendo solo slacky.eu (e il repos extra ufficiale di slackware).
E fai partire i due programmi.

spina ha scritto:Per amarok. Vuoi dire che la versione di amarok presente nel repository collide con la versione di ffmpeg dello stesso repository? Se è così sicuramente è un bug, altrimenti spiegati meglio.

Emanuele

Voglio dire proprio questo, che amarok da repo cerca libavformat.so.52 e libavcodec.so.52 e ffmpeg fornisce le versioni .53.

Ma già è stato segnalato leggi qui: http://www.slacky.eu/asche/pkgreports/
in the slacky 13.37 repo amarok (2.4.3) is linked to libavformat.so.52, libavcodec.so.52; but 13.37 ships with the .53 versions. Contattare tschaeie nel canale irc #slackware nel server di syrolnet. Ciao e grazie naitso

Parliamo di più di un mese fa... :oops:
gorwell
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: mar ott 28, 2008 10:10
Nome Cognome: Pascal Allegra
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE 4.5.5

Re: Bug report per Openshot e kdenlive

Messaggioda gorwell » dom ott 02, 2011 20:19

rik70 ha scritto:Controlla se hai installato il pacchetto mlt.
Prova a dare:
Codice: Seleziona tutto
which melt


Poi c'è un errore nalla variabile LANG.

Lancialo con
Codice: Seleziona tutto
LANG=it_IT.UTF-8


A me con le altre localizzazioni italiane - LANG=it_IT/it_IT@euro - va in segfault senza complimenti (slackware 13.1).

Ciao

P.s.

Il mio è il pacchetto SBo, non quello slacky.

mlt installato (da slacky.eu e credo il problema stia lì), ma kdenlive lamenta la mancanza dei binding SDL e openshot è un dramma.

Comunque chiudiamo qui che è meglio. Ho dato un bel
Codice: Seleziona tutto
slackpkg clean-system
e mi sto costruendo tutti i pacchetti da slackbuild.org (con sbopkg ad essere onesti dopo che mi sono scaricato i file .queue da git).
Certo metterò un po' di tempo ma alla fine credo sia l'unico vero modo di tenere una slack pulita.
Grazie a tutti.

P.S. Comunque impostare la LANG a it_IT.UTF-8 lo devo provare anche se:
Codice: Seleziona tutto
pascal@Portatile:~$ locale -a|grep it_IT
it_IT
it_IT.utf8
it_IT@euro
gorwell
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: mar ott 28, 2008 10:10
Nome Cognome: Pascal Allegra
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE 4.5.5

Re: Bug report per Openshot e kdenlive

Messaggioda rik70 » dom ott 02, 2011 20:37

pascal@Portatile:~$ locale -a|grep it_IT
it_IT
it_IT.utf8
it_IT@euro


E' uguale, puoi scriverli in entrambe i modi:
Codice: Seleziona tutto
:~$ locale -av
[...]
locale: it_IT.utf8      directory: /usr/lib/locale/it_IT.utf8
-------------------------------------------------------------------------------
   title | Italian locale for Italy
   source | RAP
   address | Sankt Jørgens Alle 8, DK-1615 København V, Danmark
   email | bug-glibc-locales@gnu.org
   language | Italian
   territory | Italy
   revision | 1.0
   date | 2000-06-29
   codeset | UTF-8


In pratica, o metti:
Codice: Seleziona tutto
it_IT.utf8

oppure it_IT.[CODESET]:
Codice: Seleziona tutto
it_IT.UTF-8


Di sicuro non puoi scrivere:
Codice: Seleziona tutto
it_IT@utf8
o forse sì? :-k
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1254
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Bug report per Openshot e kdenlive

Messaggioda gohanz » dom ott 02, 2011 21:11

Tutti i pacchetti multimediali presenti su Slacky sono stati compilati con la serie 0.7 di FFmpeg. Sul repository ,attualmente, ci sono due serie (0.8 e la 0.7). Entrambi le versioni contengono le stesse funzioni, ma la 0.7 è retrocompatibile con la serie 0.6.
Quindi in sintesi se volete che i pacchetti funzionino disinstallate la 0.8 e usate versione la 0.7 di FFmpeg.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Bug report per Openshot e kdenlive

Messaggioda gorwell » lun ott 03, 2011 5:27

rik70 ha scritto:Di sicuro non puoi scrivere:
Codice: Seleziona tutto
it_IT@utf8
o forse sì? :-k

Di sicuro no. it_IT.utf8 funziona benissimo (e immagino anche it_IT.UTF-8.
it_IT@utf8 non viene riconosciuto da tutte le app in python.
gorwell
Linux 1.0
Linux 1.0
 
Messaggi: 9
Iscritto il: mar ott 28, 2008 10:10
Nome Cognome: Pascal Allegra
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE 4.5.5

Re: Bug report per Openshot e kdenlive

Messaggioda nyquist » sab nov 05, 2011 20:30

Nonostante abbia installato ffmpeg-0.7.6 con slackyd, e poi kdenlive 0.8 (sempre con slackyd) mi dà il solito errore fatale relativo al modulo SDL di MLT. Premetto che il pacchetto mlt è installato con versione 0.7.4. Ultimamente con sti programmi di video editing non me ne va dritta una... Qualcuno di voi ha risolto in qualche maniera???
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora

Re: Bug report per Openshot e kdenlive

Messaggioda gohanz » dom nov 06, 2011 7:51

Ci sono i nuovi pacchetti di OpenShot-1.4.0 e Kdenlive-0.8.2 compilati su FFmpeg-0.8.6 e Mlt-0.7.6 caricati su Slacky. Dovresti solo aspettare Loris che li metta a disposizione.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Bug report per Openshot e kdenlive

Messaggioda nyquist » dom nov 06, 2011 11:48

Ah ok, ottimo, grazie per l'info.
Altra cosa. Per le librerie come faccio? Tutto ciò che ho installato fin'ora l'ho installato "appoggiandomi" alla versione 0.7.6 di ffmpeg. Devo per forza togliere ffmpeg 0.7.6 e dipendenze e reinstallare la versione 0.8.6 (e quindi tutti i programmi ad essa collegati, come ad esempio vlc) oppure posso installare il tutto assieme alla versione già presente? E lo stesso per mlt?
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora

Re: Bug report per Openshot e kdenlive

Messaggioda gohanz » dom nov 06, 2011 20:11

Devi aggiornare sia FFmpeg alla serie 8 che Mlt all'ultima versione. Per il resto le sottodipendenze di FFmpeg sono uguali sia per la serie 7 che per la 8.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Bug report per Openshot e kdenlive

Messaggioda nyquist » lun nov 07, 2011 21:35

Dunque, ho scaricato "manualmente" (cioè senza slackyd) e aggiornato ffmpeg:
Codice: Seleziona tutto
upgradepkg ffmpeg-0.7.6-i686-1sl ffmpeg-0.8.6-i686-1sl.txz

Poi ho scaricato mlt-0.7.4-i686-1sl.txz + dipendenze con slackyd e ho installato il tutto con installpkg.
Poi ho aggiornato mlt con il solito comando:
Codice: Seleziona tutto
upgradepkg mlt-0.7.4-i686-1sl mlt-0.7.6-i686-1sl.txz

Infine ho scaricato "manualmente" il pacchetto openshot-1.4.0-i686-1sl.txz e alcune dipendenze che mi mancavano (goocanvas, httplib2, pygoocanvas, pyxdg) e ho installato il tutto.
Dal menù di kde lancio openshot e non parte. Allora lo lancio da terminale per vedere l'output e ottengo:
Codice: Seleziona tutto
cristiano@darkstar:~$ openshot

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.4.0)
--------------------------------
Process no longer exists: 2358.  Creating new pid lock file.
mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so
  (libaacplus.so.2: impossibile aprire il file oggetto condiviso: File o directory non esistente)

Detecting formats, codecs, and filters...
Errore di segmentazione

Scusate se ho fatto tutto sto caos ma non capisco come mai slackyd non mi trova i pacchetti nuovi. Accade questo:
Codice: Seleziona tutto
slackyd -u

Warning: package `google-talkplugin_current_i386' isn't standard. Skipping.
Repository: slackware [ftp.nluug.nl]
`- Downloading FILELIST.TXT [File not found]             

Warning: cannot retreive all file (0/8). Trying next: found

Repository: slackware [sunsite.cnlab-switch.ch]
`- Downloading FILELIST.TXT [Already update]             
Repository: slacky [darkstar.ist.utl.pt]
`- Downloading FILELIST.TXT [Already update]             



È probabile che sia io che sto sbagliando qualcosa... :-k
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora

Re: Bug report per Openshot e kdenlive

Messaggioda nyquist » lun nov 07, 2011 21:47

EDIT:
Ho installato libaacplus-2.0.2-i486-1sl.txz (che sembrava mancarmi #-o ) dopo averla scaricata "manualmente" da slacky.eu.
Lanciando nuovamente openshot da linea di comando, il risultato è ora il seguente:
Codice: Seleziona tutto
cristiano@darkstar:~$ openshot

------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.4.0)
--------------------------------
Process no longer exists: 3276.  Creating new pid lock file.

Detecting formats, codecs, and filters...
---
video_codecs:
  - a64multi
  - a64multi5
  - asv1
  - asv2
  - bmp
  - dnxhd
  - dpx
  - dvvideo
  - ffv1
  - ffvhuff
  - flashsv
  - flashsv2
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpegls
  - ljpeg
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v2
  - msmpeg4
  - msvideo1
  - pam
  - pbm
  - pcx
  - pgm
  - pgmyuv
  - png
  - ppm
  - qtrle
  - rawvideo
  - roqvideo
  - rv10
  - rv20
  - sgi
  - snow
  - svq1
  - targa
  - tiff
  - v210
  - wmv1
  - wmv2
  - zlib
  - zmbv
  - libdirac
  - libschroedinger
  - libtheora
  - libvpx
  - libx264
  - libxavs
  - libxvid
...
---
audio_codecs:
  - aac
  - ac3
  - ac3_fixed
  - alac
  - dca
  - eac3
  - flac
  - mp2
  - nellymoser
  - real_144
  - sonic
  - sonicls
  - vorbis
  - wmav1
  - wmav2
  - pcm_alaw
  - pcm_f32be
  - pcm_f32le
  - pcm_f64be
  - pcm_f64le
  - pcm_mulaw
  - pcm_s8
  - pcm_s16be
  - pcm_s16le
  - pcm_s24be
  - pcm_s24daud
  - pcm_s24le
  - pcm_s32be
  - pcm_s32le
  - pcm_u8
  - pcm_u16be
  - pcm_u16le
  - pcm_u24be
  - pcm_u24le
  - pcm_u32be
  - pcm_u32le
  - pcm_zork
  - roq_dpcm
  - adpcm_adx
  - g722
  - g726
  - adpcm_ima_qt
  - adpcm_ima_wav
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libaacplus
  - libfaac
  - libgsm
  - libgsm_ms
  - libmp3lame
  - libopencore_amrnb
  - libspeex
  - libvo_aacenc
  - libvo_amrwbenc
  - libvorbis
...
---
formats:
  - a64
  - ac3
  - adts
  - aiff
  - amr
  - asf
  - ass
  - asf_stream
  - au
  - avi
  - avm2
  - caf
  - cavsvideo
  - crc
  - daud
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - ffm
  - ffmetadata
  - filmstrip
  - flac
  - flv
  - framecrc
  - framemd5
  - g722
  - gif
  - gxf
  - h261
  - h263
  - h264
  - image2
  - image2pipe
  - ipod
  - ivf
  - m4v
  - md5
  - matroska
  - matroska
  - microdvd
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - null
  - nut
  - ogg
  - alaw
  - mulaw
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - RoQ
  - rso
  - rtp
  - rtsp
  - sap
  - sox
  - spdif
  - srt
  - swf
  - 3g2
  - 3gp
  - truehd
  - rcv
  - voc
  - wav
  - webm
  - yuv4mpegpipe
  - libnut
  - alsa
  - oss
  - sdl
...
Errore di segmentazione
cristiano@darkstar:~$

:-k Any ideas?
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti