Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] fatal su lilo

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] fatal su lilo

Messaggioda Procopio » lun ott 17, 2011 23:27

Ciao a tutti!

quest oggi ho effettuato l'avanzamento di versione di ubuntu e ovviamente il grub mi ha sovrascritto il lilo. Sono allora andato a modificare il lilo.conf per quanto riguarda i parametri del kernel e dell'initrd di ubuntu perchè fossero aggiornati, per poi andare a dare un lilo -v e sovrascrivere dinuovo lilo a grub....questo comando però mi ha restituito un fatal
Codice: Seleziona tutto
root@darkstar:/home/matteo# lilo -v
LILO version 22.8, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007 and compiled at 03:08:28 on Mar 27 2011

Warning: LBA32 addressing assumed
Reading boot sector from /dev/sda
Warning: Unable to determine video adapter in use in the present system.
Using BITMAP secondary loader
Calling map_insert_data
Mapping bitmap file /boot/slack.bmp
Warning: Video adapter does not support VESA BIOS extensions needed for
  display of 256 colors.  Boot loader will fall back to TEXT only operation.
Calling map_insert_file

Boot image: /boot/vmlinuz -> vmlinuz-huge-smp-2.6.37.6-smp
Added Slackware *

Boot image: /mnt/tmp/boot/vmlinuz-3.0.0-12-generic
Fatal: Setup length exceeds 31 maximum; kernel setup will overwrite boot loader


ho trovato qualche soluzione googlando, ma sono di diverso tipo e tutte in inglese, quindi per essere sicuro volevo passare di qua :)

tra i vari, la soluzione più contratta mi sembra questa
Codice: Seleziona tutto
#define MAX_SETUPSECS 63
ma è un comando vero? cioè funziona? :)
Ultima modifica di Procopio il mar ott 18, 2011 15:09, modificato 1 volta in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: fatal su lilo

Messaggioda Plaoo » lun ott 17, 2011 23:42

Bhè possiamo vedere lilo.conf?
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: fatal su lilo

Messaggioda Procopio » mar ott 18, 2011 0:01

certamente! :)
Codice: Seleziona tutto
matteo@darkstar:~$ cat /etc/lilo.conf
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
#compact        # faster, but won't work on all systems.
# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255
# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Append any additional kernel parameters:
append=" vt.default_utf8=0"
prompt
timeout = 50
# VESA framebuffer console @ 1024x768x256
  vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k                                                                                                                                                                 
# vga=790                                                                                                                                                                                                 
# VESA framebuffer console @ 1024x768x256                                                                                                                                                                 
# vga=773                                                                                                                                                                                                 
# VESA framebuffer console @ 800x600x64k                                                                                                                                                                   
# vga=788                                                                                                                                                                                                 
# VESA framebuffer console @ 800x600x32k                                                                                                                                                                   
# vga=787                                                                                                                                                                                                 
# VESA framebuffer console @ 800x600x256                                                                                                                                                                   
# vga=771                                                                                                                                                                                                 
# VESA framebuffer console @ 640x480x64k                                                                                                                                                                   
# vga=785                                                                                                                                                                                                 
# VESA framebuffer console @ 640x480x32k                                                                                                                                                                   
# vga=784                                                                                                                                                                                                 
# VESA framebuffer console @ 640x480x256                                                                                                                                                                   
# vga=769                                                                                                                                                                                                 
# ramdisk = 0     # paranoia setting                                                                                                                                                                       
# End LILO global section                                                                                                                                                                                 
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda7
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
image=/mnt/tmp/boot/vmlinuz-3.0.0-12-generic
  label=ubuntu
  root = /dev/sda8
  read-only  # Partitions should be mounted read-only for checking
  initrd=/mnt/tmp/boot/initrd.img-3.0.0-12-generic
  append="root=UUID=8b32897d-5bd1-440c-8264-daebf9d8e5a8 quiet"
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda2
  label = Vista
  table = /dev/sda
# Windows bootable partition config ends
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: fatal su lilo

Messaggioda -sf » mar ott 18, 2011 0:19

Come mai hai l'immagine del kernel e l'initrd sotto /mnt/tmp?

EDIT: da profano proverei a cambiare la posizione di questi 2... una volta provai a inserire (con un kernel di prova) un "percorso lungo" (a livello di caratteri) e dava un errore che mi pare fosse simile al tuo...
Si vede che lilo non digerisce stringhe lunghe, anche label non deve essere lunga più di tot caratteri mi pare ecc.
Magari aspetta qualcuno che ne sappia di più, ma provare e cambiare la posizione costa poco ;)
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: fatal su lilo

Messaggioda targzeta » mar ott 18, 2011 9:06

Supposto che tutti i percorsi siano stati dati correttamente:
  • aggiungi lba32 al lilo.conf, tanto il tuo PC è compatibile.
  • gli errori sull'adattatore grafico non li capisco, ma evidentemente sono causati dalle direttive bitmap.
  • l'errore fatale lo ottieni perché hai una vecchia versione di LiLO e la soluzione che scrivi non si riferisce al lilo.conf ma ai sorgenti veri e propri. Per risolvere dovresti upgradare LiLO. Secondo me potresti usare il pacchetto della current (hai una Slackware a 32 bit giusto? non una Slackware64).
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6149
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: fatal su lilo

Messaggioda Procopio » mar ott 18, 2011 10:19

-sf ha scritto:Come mai hai l'immagine del kernel e l'initrd sotto /mnt/tmp?
perche` la root di ubuntu e` su una partizione separata(sda8) da quella della root di slackware(sda7) su cui ho il lilo.conf

-sf ha scritto:Si vede che lilo non digerisce stringhe lunghe, anche label non deve essere lunga più di tot caratteri mi pare ecc.
si, ma il precedente kernel di ubuntu era qualcosa del tipo 2.6.38-8 e questo e`3.0.0-12 quindi paradossalmente ha addirittura un carattere in meno!

spina ha scritto:l'errore fatale lo ottieni perché hai una vecchia versione di LiLO e la soluzione che scrivi non si riferisce al lilo.conf ma ai sorgenti veri e propri.
si ma io pensavo proprio di modificare le impostazione del lilo anziche` il lilo.conf, ma comunque seguo il tuo consiglio e upgrado lilo :)


a proposito, sulla home di slacky ci sono appunto i link alle versioni current e stable di slackware, ma sono solo dei changelog giusto? io devo poi andare sul server ftp (o sull'altro) e scaricare e upgradare/installare i pacchetti che mi suggerisce li` giusto?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: fatal su lilo

Messaggioda targzeta » mar ott 18, 2011 10:34

Procopio ha scritto:...a proposito, sulla home di slacky ci sono appunto i link alle versioni current e stable di slackware, ma sono solo dei changelog giusto? io devo poi andare sul server ftp (o sull'altro) e scaricare e upgradare/installare i pacchetti che mi suggerisce li` giusto?

Questa non l'ho capita. Per risolvere il tuo problema dovrebbe bastare upgradare LiLO con il pacchetto che ti ho linkato. Sì, sulla homepage c'è solo il changelog, ma a te interessa solo il pacchetto LiLO...per ora. Poi se questo non dovesse funzionare si potrebbe pensare di farti passare direttamente in current.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6149
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: fatal su lilo

Messaggioda Procopio » mar ott 18, 2011 15:08

spina ha scritto:Questa non l'ho capita.
cioè ti chiedevo come funziona il meccanismo per ottenere la versione current....il changelog contiene tutte le differenze dalla versione standard no? quindi per upgradare la mia versione alla current scarico i pacchetti che sono segnalati sul changelog e poi dò un upgradepkg nome_pacchetti.txz nella directory dove li ho scaricati?.......(oppure se ho un mirror configurato do direttamente upgrade nome_pacchetti.txz senza dover prima scaricare?)


ad ogni modo ho upgradato lilo, ed è sparito il fatal, anche se mi dava ancora i tre warnings, ho quindi inserito lba32 ed è sparito un warning, ma già nella versione precedente era così, quindi mi accontento di avere i due warnings:) Metto risolto. :)
Ultima modifica di Procopio il mar ott 18, 2011 20:43, modificato 1 volta in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 589
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE 4.10.5

Re: [RISOLTO] fatal su lilo

Messaggioda tano70 » gio ago 22, 2013 11:03

scusate anche io ho il medesimo problema, premetto che uso slackware14 64 bit, già aggiornato alla current. ma con l'ultimo aggiornamento di stamattina (21 agosto) dove oltre al kernel ha aggiornato i vari driver xf86_64 al reboot mi trovo il sistema piantato su BIOS data check successfull e da li non va avanti!! che fare??
da chroot sono entrato nel sistema e lanciato un lilo -v e questi sono i 3 warnig che ottengo:

Warning: LBA32 addressing asumed
Reading Boot Sector from /dev/sda
Warning: Unable to determing video adapter in use in the present system
Using Bitmap Secondary Loader
Caling map_insert_data_
Mapping bitmap file /boot/slack.bmp
Calling map_insert_file
warning: Video adapter does not support VESA BIOS extensions needed for display of 256 colors. Boot loader will fall back to TEXT only operation.
calling map_insert_file

Boot other: /dev/sda1, on /dev/sda, loader CHAIN

Boot Image: /boot/vmlinuz
Adding Linux*
Boot Other: /dev/hda1, on /dev/dev/hda, loader CHAIN

Come risolvo questa sitiuazione?? e comunque dove va inserito lba32 al lilo?? in quale parte?
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: [RISOLTO] fatal su lilo

Messaggioda ZeroUno » gio ago 22, 2013 11:55

Ricorda, il crosspost (scrivere lo stesso post in due parti diverse) non è una buona pratica, e non è una buona pratica nemmeno riesumare post di due anni fa a meno di casi particolari.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4300
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO] fatal su lilo

Messaggioda tano70 » gio ago 22, 2013 14:24

ZeroUno ha scritto:Ricorda, il crosspost (scrivere lo stesso post in due parti diverse) non è una buona pratica, e non è una buona pratica nemmeno riesumare post di due anni fa a meno di casi particolari.

si scusami hai ragione, ma ero preso dal panico del ripristino e cosi trovando questo post molto attiguo al mio problema mi è venuto spontaneo riutilizzarlo, ma capisco che ho sbagliato, in effetti sempre meglio aprirne uno nuovo, anche se simile ad uno già risolto. Scusate ancora...cercherò di non fare più questi doppi post!! ;)
Avatar utente
tano70
Linux 2.0
Linux 2.0
 
Messaggi: 154
Iscritto il: lun ago 12, 2013 9:28
Nome Cognome: Tony
Slackware: 14.1 stable 64bit
Kernel: 3.10.17
Desktop: Xfce

Re: [RISOLTO] fatal su lilo

Messaggioda ZeroUno » gio ago 22, 2013 15:37

tano70 ha scritto:In effetti sempre meglio aprirne uno nuovo, anche se simile ad uno già risolto.

Non sempre. A volte è utile anche in quello risolto; per esempio "ho fatto gli stessi passi eppure non ho risolto" può essere un caso. Oppure riprendere un post vecchio per continuare un discorso aperto.
In verità ammiro questo tuo entusiasmo, perchè significa che non ti limiti, al primo problema, ad aprire nuovi post ma che piuttosto usi il pulsante "cerca" del forum, cosa che non tutti fanno, e che leggi più di una pagina di post. Però quando il topic a cui ci si aggancia è vecchio di due anni è molto probabile che il pacchetto in oggetto è anche stato aggiornato e le considerazioni fatte su una versione non sono più valide sull'altra e soprattutto il problema è completamente diverso.
Insomma, ci vuole discernimento caso per caso.


Scusate ancora...cercherò di non fare più questi doppi post!! ;)

Ecco, su questo non c'è bisogno di discernimento; il doppio post è SEMPRE male. Se ti agganci ad un topic vecchio non ne apri uno nuovo e viceversa, e non scrivi lo stesso post su due sezioni diverse per sperare in una risposta più veloce (chiamasi crosspost).
Ma tranquillo, non verrai bannato per questo :).
A volte può capitare che si va a finire a parlare dello stesso problema in due topic diversi perchè per esempio ho aperto un topic per un problema e un topic per un altro e poi analizzando si va a scoprire che il problema è collegato o che i due vanno a convergere sullo stesso discorso, o che due persone hanno aperto un topic simili (tipicamente di attualità; per esempio all'uscita di slackware 14.1 troverai che si farà a gara a chi lo annuncerà per primo ;) e plausibilmente scriveranno in due a bassa distanza di tempo; oppure a seguito di un aggiornamento a slackware current due persone possono aver avuto lo stesso problema); in questi casi il "continuiamo a parlarne sull'altro topic" (e mettendo il link all'altro) è una saggia idea.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4300
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron