Repository 32bit  Forum
Repository 64bit  Wiki

Eclipse-PDT e slack 13.67 .... sono stranito

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda dottor3 » lun ott 24, 2011 22:53

Ciao a tutti
ho rimpiazzato la mia vechcia e obsoleta slamd64 con una bella slack 13.37 64 bit nuov fiammante.
Tutto ok tranne qualche novità di kde4, tutta roba risolvibile.
Comunque ora devo reinstallare i tool che uso per sviluppare, tra questi c'è PDT una versione di eclipse per sviluppare in PHP. scarico, decomprimo, vado nella directory e quando scrivo ./eclipse per farlo partire mi dice bash: ./eclipse no such file or directory, ??? cavolo eppure sono nella directory, provando da root idem.
Mi manca qualche passaggio? o mi sono rimbecillito di botto? grazie a tutti
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda miklos » lun ott 24, 2011 22:59

ciao, controlla di non aver per sbaglio scaricato la versione a 32bit.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1236
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda Plaoo » mar ott 25, 2011 0:08

Hai controllato i permessi?
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda dottor3 » mar ott 25, 2011 21:12

Permessi ok, versione 64bit.......
giuro non so che cosa sia......
ho provato con altri eseguibili da file decompressi e mi da lo stesso errore.....c'e' qualche restrizione di sicurezza di cui non sono al corrente?
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda Vic Steele » mar ott 25, 2011 21:21

Ma se, invece di scrivere a mano ./eclipse, lo iniziassi a scrivere e poi ti aiutassi con il TAB, l'autocompletamento avviene?
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda dottor3 » mar ott 25, 2011 22:55

certo l'autocompletamento avviene.
E' alquanto strano perchè ho appena usato uno slackbuild a buon fine.....in 12 anni è la prima volta che mi capita una cosa simile.
Non saprei che altri indizi dare, questo è quello che accade:
bash-4.1# ./eclipse
eclipse eclipse.ini
bash-4.1# ./eclipse
bash: ./eclipse: No such file or directory


sono bloccato e mi serve l'ambiente di sviluppo perchè devo consegnare un progetto giorni........ #-o #-o #-o
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda michele.p » mar ott 25, 2011 23:23

...la butto lì: lo script eclipse ha qualche "strana" appartenenza a gruppi, chi è il "proprietario" del file? ...per curiosità, hai provato indicando il percorso completo?

Bye 8)
Avatar utente
michele.p
Packager
Packager
 
Messaggi: 1275
Iscritto il: ven nov 24, 2006 16:52
Località: Pontecorvo(FR)
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda Vic Steele » mer ott 26, 2011 6:52

Se usi sh cosa succede?
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda fgcl2k » mer ott 26, 2011 7:33

Prova:
Codice: Seleziona tutto
strace -f -o filedilog ./eclipse

e poi esamina l'output in filedilog.

P.S. Idea buttata lì: eclipse è uno script o un programma? Se è uno script verifica che non sia in formato DOS (CR-LF a fine riga)
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 131
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda dottor3 » mer ott 26, 2011 12:26

Strace mi sputa fuori questo:
12155 execve("./eclipse", ["./eclipse"], [/* 51 vars */]) = -1 ENOENT (No such file or directory)
12155 dup(2) = 3
12155 fcntl(3, F_GETFL) = 0x8002 (flags O_RDWR|O_LARGEFILE)
12155 fstat(3, {st_mode=S_IFCHR|0600, st_rdev=makedev(136, 0), ...}) = 0
12155 mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd27939e000
12155 lseek(3, 0, SEEK_CUR) = -1 ESPIPE (Illegal seek)
12155 write(3, "strace: exec: No such file or di"..., 40) = 40
12155 close(3) = 0
12155 munmap(0x7fd27939e000, 4096) = 0
12155 exit_group(1) = ?


I permessi sono tutto ok:
bash-4.1# ls -al
total 431
drwxr-xr-x 9 dottor_3 dottor_3 504 Oct 26 13:28 .
drwxr-xr-x 45 dottor_3 users 13360 Oct 26 13:25 ..
-rwxr-xr-x 1 dottor_3 dottor_3 59 Sep 12 2008 .eclipseproduct
-rwxr-xr-x 1 dottor_3 dottor_3 13852 Sep 12 2008 about.html
drwxr-xr-x 2 dottor_3 dottor_3 216 Sep 12 2008 about_files
-rw-r--r-- 1 dottor_3 dottor_3 39292 Sep 12 2008 artifacts.xml
drwxr-xr-x 5 dottor_3 dottor_3 208 Sep 12 2008 configuration
drwxr-xr-x 3 dottor_3 dottor_3 72 Sep 12 2008 dropins
-rwxr-xr-x 1 dottor_3 dottor_3 52576 Sep 12 2008 eclipse
-rwxr-xr-x 1 dottor_3 dottor_3 161 Sep 12 2008 eclipse.ini
-rwxr-xr-x 1 dottor_3 dottor_3 16536 Sep 12 2008 epl-v10.html
-rw-r--r-- 1 root root 649 Oct 26 13:28 errlog
drwxr-xr-x 6 dottor_3 dottor_3 424 Sep 12 2008 features
-rwxr-xr-x 1 dottor_3 dottor_3 266168 Sep 12 2008 libcairo-swt.so
-rwxr-xr-x 1 dottor_3 dottor_3 6506 Sep 12 2008 notice.html
drwxr-xr-x 5 dottor_3 dottor_3 192 Sep 12 2008 p2
drwxr-xr-x 8 dottor_3 dottor_3 9240 Sep 12 2008 plugins
drwxr-xr-x 2 dottor_3 dottor_3 88 Sep 12 2008 readme


Il file è un eseguibile e usando sh non cambia nulla. :-k
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda 414N » mer ott 26, 2011 12:28

Ho scaricato il pacchetto PDT 2.2.0 all in one e anche a me non funziona.
Il file eclipse è un binario ed i permessi di esecuzione ci sono, ma quando tento di avviarlo mi appare una finestra d'errore con scritto:
"The Eclipse executable launcher was unable to locate its companion shared library."
Ho controllato il MD5 del pacchetto scaricato con quello indicato sul sito e non combaciano: presumo abbiano pubblicato un pacchetto corrotto con pezzi mancanti.
Tuttavia dovresti essere in grado di installare le funzionalità offerte da quel pacchetto anche da un'installazione normale di eclipse tramite gli update sites.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda fgcl2k » mer ott 26, 2011 12:45

dottor3 ha scritto:Strace mi sputa fuori questo:
[b]12155 execve("./eclipse", ["./eclipse"], [/* 51 vars */]) = -1 ENOENT (No such file or directory)


Dalla prima riga sembra proprio che il file non ci sia. Cosa dice il comando
Codice: Seleziona tutto
ldd eclipse
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 131
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Eclipse-PDT e slack 13.67 .... sono stranito

Messaggioda dottor3 » mer ott 26, 2011 14:02

ldd ritorna :
bash-4.1# ldd eclipse
not a dynamic executable

..... :-k

Ora vedo di scaricare eclips SDK classic e vedo....comunque nonostante l'eventuale corruzione del file almeno un messaggio di errore dovrebbe ritornalo.
Avatar utente
dottor3
Linux 2.0
Linux 2.0
 
Messaggi: 162
Iscritto il: dom lug 27, 2008 11:59
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: kde 4.5


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti