Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] Problema con driver nvidia

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] Problema con driver nvidia

Messaggioda pol » lun nov 07, 2011 11:22

Ho aggiornato l'hardware del mio pc, scheda madre gigabyte z68, vga gtx 580, ed una scheda audio asus, ho fatto l'installazione, tutto ok.

Primo problema, con kde è impossibile accedere, quindi ho risolto con xfce,

ho provato ad installare i driver nvidia, la versione 275.36 (ho provato altre versioni), mi da questo errore:

"ERROR: The Nouveau kernel driver is currently in use by your system. This
driver is incompatible with the NVIDIA driver, and must be disabled
before proceeding. Please consult the NVIDIA driver README and your
Linux distribution's documentation for details on how to correctly
disable the Nouveau kernel driver."

Un aiuto ?
Ultima modifica di pol il lun nov 07, 2011 14:00, modificato 2 volte in totale.
pol
Linux 2.4
Linux 2.4
 
Messaggi: 400
Iscritto il: ven apr 15, 2005 23:00
Località: Uno dei posti più belli d'Italia

Re: Problema con driver nvidia

Messaggioda Plaoo » lun nov 07, 2011 11:29

Devi disinstallare il pkg nouveau, poi se vuoi aggiungi i moduli nella black-list ma penso che siano i driver stessi nvidia che ci pensino.

PS: il pkg dovrebbe chiamarsi xf86-video-nouveau
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Problema con driver nvidia

Messaggioda erio » lun nov 07, 2011 11:32

metti in blacklist i driver noveau, di solito e lo stesso installer che ti chiede vuoi disattivarli? tu rispondi si e riavvii poi installi normalmente i driver.mi pare che esiste anche un pacchetto in slackware che fa questo lavoro: http://ftp.heanet.ie/mirrors/ftp.slackw ... blacklist/
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1083
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Problema con driver nvidia

Messaggioda hashbang » lun nov 07, 2011 12:38

pol ha scritto:Primo problema, con kde è impossibile accedere, quindi ho risolto con xfce,

Molto probabilmente dipende dalla mancanza dei driver nvidia, che inficia l'uso della composizione del desktop.

Changes and Hints.txt ha scritto:Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection


ho provato ad installare i driver nvidia, la versione 275.36 (ho provato altre versioni), mi da questo errore:

"ERROR: The Nouveau kernel driver is currently in use by your system. This
driver is incompatible with the NVIDIA driver, and must be disabled
before proceeding. Please consult the NVIDIA driver README and your
Linux distribution's documentation for details on how to correctly
disable the Nouveau kernel driver."

Un aiuto ?
O segui il consiglio di erio (usando il pacchetto), oppure:
Codice: Seleziona tutto
# echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf


In ogni caso, riavvia il computer, prima di installare i driver nvidia.

PS: il simbolo "#" l'ho messo per identificare che quell'operazione la devi svolgere come root.

PPS: Per i driver nvidia, assicurati di avere i sorgenti del kernel in uso.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1834
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con driver nvidia

Messaggioda pol » lun nov 07, 2011 13:58

Grazie 1000 a tutti, ho risolto seguendo il vostro consiglio, installando il pkg xf86-video-nouveau.
pol
Linux 2.4
Linux 2.4
 
Messaggi: 400
Iscritto il: ven apr 15, 2005 23:00
Località: Uno dei posti più belli d'Italia


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 1 ospite