Repository 32bit  Forum
Repository 64bit  Wiki

kernel panic dopo fsck [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

kernel panic dopo fsck [RISOLTO]

Messaggioda roberto67 » sab dic 03, 2011 22:19

Cari amici,
questo è quello che vedo di un kernel panic attraverso uno switch KVM attaccato a un server remoto slackware64 13.37, dove ho patchato un kernel 3.1.4 monolitco.

Codice: Seleziona tutto
fsck from util-linux 2.19
/sbin/e2fsck: No such file or directory while trying to open /dev/sda1
Possibly non-existent device?


Ho le ore contate perchè tra non molto mi scriveranno che non possono più lasciarmi il KVM. Ho aperto anche un post su LQ http://www.linuxquestions.org/questions ... ck-916919/ senza fortuna (finora).

Ho provato 3 kernel diversi, tra cui uno che funziona su un server praticamente identico con un file di configurazione simile, ma niente, e non so più cosa pensare. Il file system è ext4.

Questo il mio config: http://notes.sagredo.eu/sites/notes.sag ... /config.gz

Codice: Seleziona tutto
#lspci -k
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge (rev 02)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: agpgart-intel
        Kernel modules: intel-agp
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: i915
        Kernel modules: i915
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
        Kernel modules: shpchp
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
        Kernel modules: shpchp
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
        Kernel modules: shpchp
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
        Kernel modules: shpchp
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci-hcd
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci-hcd
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci-hcd
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci-hcd
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: ehci_hcd
        Kernel modules: ehci-hcd
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
        Subsystem: Intel Corporation Device 4f4d
        Kernel driver in use: ata_piix
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: i801_smbus
        Kernel modules: i2c-i801
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
        Subsystem: Intel Corporation DeskTop Board D510MO
        Kernel driver in use: r8169
        Kernel modules: r8169


Il driver ata_piix è presente nel mio config..

questo il mio fstab

Codice: Seleziona tutto
/dev/sda2        swap             swap        defaults         0   0
/dev/sda1        /                ext4        data=ordered     1   1
/dev/sda3        /usr/local       ext4       data=ordered,rw,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 1   2
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0


grazie per ogni aiuto
Ultima modifica di roberto67 il dom dic 04, 2011 22:02, modificato 1 volta in totale.
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda murdock » sab dic 03, 2011 22:34

I dischi SATA hanno il vizio di andarsene se i contatti non sono perfettamente puliti.
I dischi Maxtor inoltre accentuano il difetto (non so se il tuo disco lo è).
Prova a staccare gli spinotti SATA e alimentazione, e riattaccarli per una decina di volte (se è un falso contatto degli stessi, con lo "sfregamento" si potrebbe risolvere la faccenda), poi riprova.

Saluti,
MuRdOcK
Avatar utente
murdock
Linux 2.4
Linux 2.4
 
Messaggi: 451
Iscritto il: ven mag 25, 2007 11:58
Slackware: 64 14.1
Kernel: 3.14.4
Desktop: KDE 4.12.5

Re: kernel panic dopo fsck

Messaggioda Ansa89 » sab dic 03, 2011 22:36

Il panic te lo dava anche senza patch?
Che patch hai usato?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2619
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.5-ck1
Desktop: XFCE 4.6.1

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 22:42

murdock ha scritto:I dischi SATA hanno il vizio di andarsene se i contatti non sono perfettamente puliti.
I dischi Maxtor inoltre accentuano il difetto (non so se il tuo disco lo è).
Prova a staccare gli spinotti SATA e alimentazione, e riattaccarli per una decina di volte (se è un falso contatto degli stessi, con lo "sfregamento" si potrebbe risolvere la faccenda), poi riprova.

Saluti,
MuRdOcK


purtroppo si tratta di un server remoto che come ho detto posso riavviare con un KVM :?

però, come può dipendere dall'hardware?Ho riavviato decine di volte con il kernel di Pat e parte normalmente. Ogni volta che carico il mio kernel si presenta il problema..

grazie ragazzi..
Ultima modifica di roberto67 il sab dic 03, 2011 22:47, modificato 1 volta in totale.
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 22:45

Ansa89 ha scritto:Il panic te lo dava anche senza patch?
Che patch hai usato?


no, il kernel di pat funziona. Sto patchando per poi virtualizzare la macchina con linux-vserver http://linux-vserver.org/Welcome_to_Linux-VServer.org

è una cosa che ho già fatto con altri server, uno sempre su aruba con hardware quasi analogo.

Qualcuno potrebbe dare un'occhiata al mio config, vedere se ho lasciato qualcosa? ext4 mi pare pure di averlo configurato..
Che devo fare? #-o

grazie.. grazie..
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda Ansa89 » sab dic 03, 2011 22:46

Hai provato a compilare il kernel con un printk più verboso (magari ti dà qualche informazione in più di debug)?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2619
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.5-ck1
Desktop: XFCE 4.6.1

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 22:49

Ansa89 ha scritto:Hai provato a compilare il kernel con un printk più verboso (magari ti dà qualche informazione in più di debug)?


no, come si fa?
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 22:53

Ansa89 ha scritto:Hai provato a compilare il kernel con un printk più verboso (magari ti dà qualche informazione in più di debug)?


Codice: Seleziona tutto
cat /proc/sys/kernel/printk
3       4       1       7


provo a mettere tutti 7..
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda Ansa89 » sab dic 03, 2011 22:54

Imposta a 7 in valore di "Kernel Hacking --> Default message log level (1-7)".
E magari abilita anche "Kernel Hacking --> Early printk".
Ultima modifica di Ansa89 il sab dic 03, 2011 22:57, modificato 1 volta in totale.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2619
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.5-ck1
Desktop: XFCE 4.6.1

Re: kernel panic dopo fsck

Messaggioda murdock » sab dic 03, 2011 22:57

Non avevo colto. :P
Dopo una rapida scorsa del tuo config, mi pare tutto a posto.
Indagherei sulle patch che usi.

Saluti,
MuRdOcK
Avatar utente
murdock
Linux 2.4
Linux 2.4
 
Messaggi: 451
Iscritto il: ven mag 25, 2007 11:58
Slackware: 64 14.1
Kernel: 3.14.4
Desktop: KDE 4.12.5

Re: kernel panic dopo fsck

Messaggioda Ansa89 » sab dic 03, 2011 22:58

In effetti usare patch in fase di sviluppo non aiuta la stabilità del sistema :roll: .
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2619
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.5-ck1
Desktop: XFCE 4.6.1

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 22:59

murdock ha scritto:Non avevo colto. :P
Dopo una rapida scorsa del tuo config, mi pare tutto a posto.
Indagherei sulle patch che usi.

Saluti,
MuRdOcK


ok, faccio anche un tentativo senza la patch..
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 23:03

Ansa89 ha scritto:Imposta a 7 in valore di "Kernel Hacking --> Default message log level (1-7)".
E magari abilita anche "Kernel Hacking --> Early printk".


per modificare questi valori devo editare ho /proc/sys/kernel/printk? perchè l'ho fatto mettendo tutti 7, e il messaggio di errore non è più verboso di prima, e al riavvio con vecchio kernel questo file è tornato uguale a prima della mia modifica. che ho sbagliato?
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: kernel panic dopo fsck

Messaggioda Ansa89 » sab dic 03, 2011 23:05

roberto67 ha scritto:per modificare questi valori devo editare ho /proc/sys/kernel/printk?

No, devi ricompilare il kernel, impostando i nuovi valori.


Adesso che ci penso, non mi torna una cosa: il kernel vede correttamente "/dev/sda1", infatti non dà un errore di vfs.
Un'ulteriore prova è il fatto che arriva ad eseguire e2fsck (che suppongo risieda su "/dev/sda1").

Il problema dunque si sposta su e2fsck che per qualche arcano motivo non vede "/dev/sda1", o mi sbaglio?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2619
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.15.5-ck1
Desktop: XFCE 4.6.1

Re: kernel panic dopo fsck

Messaggioda roberto67 » sab dic 03, 2011 23:10

Ansa89 ha scritto:
roberto67 ha scritto:per modificare questi valori devo editare ho /proc/sys/kernel/printk?

No, devi ricompilare il kernel, impostando i nuovi valori.


vuoi dire imposto i nuovi valori in quel file e poi ricompilando il kernel?

Ansa89 ha scritto:Adesso che ci penso, non mi torna una cosa: il kernel vede correttamente "/dev/sda1", infatti non dà un errore di vfs.
Un'ulteriore prova è il fatto che arriva ad eseguire e2fsck (che suppongo risieda su "/dev/sda1").

Il problema dunque si sposta su e2fsck che per qualche arcano motivo non vede "/dev/sda1", o mi sbaglio?


già.. è e2fsck che dà errore..
roberto67
Packager
Packager
 
Messaggi: 289
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: ponce e 2 ospiti